[SRU] unreadable text color in confirmation dialog with ubuntu theme

Bug #1481216 reported by Nobuto Murata on 2015-08-04
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Corey Bryant
Kilo
High
Unassigned
Mitaka
High
Unassigned
Newton
High
Unassigned
Ocata
High
Unassigned
Pike
High
Corey Bryant
horizon (Ubuntu)
High
Corey Bryant
Xenial
High
Unassigned
Zesty
High
Unassigned
Artful
High
Corey Bryant

Bug Description

[Description]
The same symptom appeared as LP: #1308651.

When deleting an instance or other resources, confirmation dialog will be shown up. Background color and text color of confirm button are orange/orange. Firefox calculated css rules are as follows (color: #DD4814, background-color: #DD4814).

element {

}
a, a:link, a:visited {

    color: #DD4814;

}
.btn-primary {

    background: #DD4814 none repeat scroll 0% 0%;
    border-color: #C64012;

}
.btn-primary {

    color: #FFF;
    background-color: #428BCA;
    border-color: #357EBD;

}
.btn {

    display: inline-block;
    margin-bottom: 0px;
    font-weight: normal;
    text-align: center;
    vertical-align: middle;
    cursor: pointer;
    background-image: none;
    border: 1px solid transparent;
    white-space: nowrap;
    padding: 6px 12px;
    font-size: 13px;
    line-height: 1.42857;
    border-radius: 4px;
    -moz-user-select: none;

}
<snip>

$ apt-cache policy openstack-dashboard-ubuntu-theme
openstack-dashboard-ubuntu-theme:
  Installed: 1:2015.1.0-0ubuntu1~cloud0
  Candidate: 1:2015.1.0-0ubuntu1~cloud0
  Version table:
 *** 1:2015.1.0-0ubuntu1~cloud0 0
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu/ trusty-updates/kilo/main amd64 Packages
        100 /var/lib/dpkg/status
     1:2014.1.5-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     1:2014.1.2-0ubuntu1.1 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     1:2014.1-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

[Test Case]
See screenshots attached to bug.

[Regression Potential]
This is a minor update to scss primary-button color override for the openstack dashboard with minimal regression potential.

Nobuto Murata (nobuto) wrote :

Screenshot.

description: updated
Nobuto Murata (nobuto) on 2015-08-17
tags: added: cpec
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu):
status: New → Confirmed
James Page (james-page) on 2015-09-17
Changed in horizon (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in cloud-archive:
status: New → Triaged
importance: Undecided → Low
Ryan Beisner (1chb1n) on 2017-09-18
Changed in cloud-archive:
importance: Low → High
Changed in horizon (Ubuntu):
importance: Low → High
tags: added: backport-potential uosci
Ryan Beisner (1chb1n) on 2017-09-18
Changed in horizon (Ubuntu):
assignee: nobody → Corey Bryant (corey.bryant)
Changed in cloud-archive:
assignee: nobody → Corey Bryant (corey.bryant)
Corey Bryant (corey.bryant) wrote :

Hi Nobuto,

Thank you for reporting this. Are you seeing this on any release other than Kilo?

Thanks,
Corey

Sean McGinnis (sean-mcginnis) wrote :

I have seen this with Ocata and Pike.

Corey Bryant (corey.bryant) wrote :

Thanks Sean.

Mihaela Andronic (mihaela) wrote :

Affecting Openstack customers #canonical-bootstack

tags: added: canonical-bootstack
Corey Bryant (corey.bryant) wrote :

As Nobuto inferred, the problem is that a:link color is taking precedence over the btn-primary color. I have a patch as an initial attempt to fix this (attached) however I want to run it by the design team to get more experienced eyes on the CSS change.

Corey Bryant (corey.bryant) wrote :
Corey Bryant (corey.bryant) wrote :

Screenshot with above patch.

tags: added: patch
Corey Bryant (corey.bryant) wrote :

Minimized patch

Looks good to me

Changed in horizon (Ubuntu Xenial):
status: New → Triaged
Changed in horizon (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → Critical
Changed in horizon (Ubuntu Xenial):
importance: Undecided → High
Changed in horizon (Ubuntu Zesty):
importance: Critical → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:12.0.0-0ubuntu2

---------------
horizon (3:12.0.0-0ubuntu2) artful; urgency=medium

  * debian/theme/ubuntu/_styles.scss: Ensure btn-primary text color takes
    precedence (LP: #1481216).

 -- Corey Bryant <email address hidden> Fri, 22 Sep 2017 10:23:14 -0400

Changed in horizon (Ubuntu Artful):
status: Triaged → Fix Released
Corey Bryant (corey.bryant) wrote :

This is uploaded for all releases except kilo and awaiting sru team review. I'll get the kilo version uploaded soon.

summary: - unreadable text color in confirmation dialog with ubuntu theme
+ [SRU] unreadable text color in confirmation dialog with ubuntu theme
description: updated

Hello Nobuto, or anyone else affected,

Accepted horizon into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
James Page (james-page) wrote :

Hello Nobuto, or anyone else affected,

Accepted horizon into newton-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:newton-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-newton-needed to verification-newton-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-newton-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-newton-needed
Brian Murray (brian-murray) wrote :

Hello Nobuto, or anyone else affected,

Accepted horizon into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:11.0.3-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Zesty):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-zesty
Changed in horizon (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Nobuto, or anyone else affected,

Accepted horizon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/2:9.1.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Corey Bryant (corey.bryant) wrote :

Package uploaded for kilo.

Ryan Beisner (1chb1n) wrote :

Hello Nobuto, or anyone else affected,

Accepted horizon into kilo-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:kilo-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-kilo-needed to verification-kilo-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-kilo-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-kilo-needed
Ante Karamatić (ivoks) on 2017-09-27
tags: added: cpe-onsite
removed: cpec
Ryan Beisner (1chb1n) wrote :

Hello Nobuto, or anyone else affected,

Accepted horizon into ocata-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ocata-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ocata-needed to verification-ocata-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ocata-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ocata-needed
Ryan Beisner (1chb1n) wrote :

Hello Nobuto, or anyone else affected,

Accepted horizon into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Karl Williams (deadlight) wrote :

Hello Karl here (frontend dev, design team),
I was away on leave when this was emailed to me last week.
The patch suggestion looks good to me. It would be nice to avoid !importants where we can but this looks like the best approach to get this fairly critical bug out.
We can look at better structuring these greedy selectors in future updates.
 - K

Laurent Sesques (sajoupa) wrote :

Hi,

I just tested on a fresh deployment, upgraded python-django-horizon, openstack-dashboard, and openstack-dashboard-ubuntu-theme to 2:9.1.2-0ubuntu2.
After:
  apt-get install python-django-horizon=2:9.1.2-0ubuntu2 openstack-dashboard=2:9.1.2-0ubuntu2 openstack-dashboard-ubuntu-theme=2:9.1.2-0ubuntu2'
It displays the default theme.
Then after:
  apt-get install --reinstall openstack-dashboard-ubuntu-theme=2:9.1.2-0ubuntu2'
The display is all broken, see attachment.

Rolling back to 2:9.1.2-0ubuntu1 brings back the previous theme without any issues (except the one described in this bug).

http://pastebin.ubuntu.com/25632495/

Corey Bryant (corey.bryant) wrote :

Hi Laurent,

Thanks for testing. Would you be able to test an install from scratch from -proposed without upgrading? Then we can verify this particular bug and get another bug opened for the upgrade issue.

Corey Bryant (corey.bryant) wrote :

Laurent, To ensure this isn't a regression in the fix for this bug, I'll create a ppa that contains the same contents as 2:9.1.2-0ubuntu1 that is named 2:9.1.2-0ubuntu2 to force an upgrade.

Corey Bryant (corey.bryant) wrote :

ie. to force an upgrade with no changes in package contents

Corey Bryant (corey.bryant) wrote :

Here is a PPA that we can test upgrade to: https://launchpad.net/~corey.bryant/+archive/ubuntu/xenial-mitaka-bug-1481216

This package (2:9.1.2-0ubuntu2) is the same as 2:9.1.2-0ubuntu1 without the fix for bug 1481216.

Felipe Reyes (freyes) on 2017-09-29
tags: added: sts
Felipe Reyes (freyes) wrote :

> Hi Laurent,
>
> Thanks for testing. Would you be able to test an install from scratch from
> -proposed without upgrading? Then we can verify this particular bug and get
> another bug opened for the upgrade issue.

I tested installing directly using cloud-archive:pike-proposed and the problem
persist. See screenshot attached.

The dashboard is loading a css file named 34f8a8f8d5e5.css[0], this file does
not contain the updated rule (color: #fff !important), but other one of the
files[1] available under /var/lib/openstack-dashboard/static/dashboard/css contains
the expected rule

The difference between both css can be found at
http://paste.ubuntu.com/25636811/

Also I could verify as well that if you install the package from -proposed and
*then* you try to rollback to the version in -updates, the website css gets
totally broken as reported by Laurent.

[0] http://pastebin.ubuntu.com/25636789/
[1] http://paste.ubuntu.com/25636802/

Corey Bryant (corey.bryant) wrote :

Let's track the upgrade issues in this bug: https://bugs.launchpad.net/ubuntu/+source/horizon/+bug/1677207

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package horizon - 3:10.0.5-0ubuntu1~cloud1
---------------

 horizon (3:10.0.5-0ubuntu1~cloud1) xenial-newton; urgency=medium
 .
   * debian/theme/ubuntu/_styles.scss: Ensure btn-primary text color takes
     precedence (LP: #1481216).

Corey Bryant (corey.bryant) wrote :

I've verified this is fixed in xenial-pike-proposed.

tags: added: verification-pike-done
removed: verification-pike-needed
Corey Bryant (corey.bryant) wrote :

I've verified this is fixed in zesty-ocata-proposed and xenial-ocata-proposed.

tags: added: verification-done-zesty verification-ocata-done
removed: verification-needed-zesty verification-ocata-needed
Corey Bryant (corey.bryant) wrote :

I've verified this is fixed in xenial-mitaka-proposed and trusty-mitaka-proposed.

tags: added: verification-done-xenial verification-mitaka-done verification-newton-done
removed: verification-mitaka-needed verification-needed-xenial verification-newton-needed
Corey Bryant (corey.bryant) wrote :

I've verified this is fixed in xenial-newton-proposed.

Corey Bryant (corey.bryant) wrote :

I've verified this is fixed in trusty-kilo-proposed.

tags: added: verification-kilo-done
removed: verification-kilo-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:11.0.3-0ubuntu3

---------------
horizon (3:11.0.3-0ubuntu3) zesty; urgency=medium

  * d/openstack-dashboard.preinst: Clean up /usr/share location of static
    assets (from pre-Ocata package versions) prior to installing Ocata with
    new /var/lib location of static assets (LP: #1677207).

 -- Corey Bryant <email address hidden> Fri, 29 Sep 2017 12:23:50 -0400

Changed in horizon (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2:9.1.2-0ubuntu2

---------------
horizon (2:9.1.2-0ubuntu2) xenial; urgency=medium

  * debian/theme/ubuntu/_styles.scss: Ensure btn-primary text color takes
    precedence (LP: #1481216).

 -- Corey Bryant <email address hidden> Mon, 25 Sep 2017 16:27:00 -0400

Changed in horizon (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in cloud-archive:
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package horizon - 2:9.1.2-0ubuntu2~cloud0
---------------

 horizon (2:9.1.2-0ubuntu2~cloud0) trusty-mitaka; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 horizon (2:9.1.2-0ubuntu2) xenial; urgency=medium
 .
   * debian/theme/ubuntu/_styles.scss: Ensure btn-primary text color takes
     precedence (LP: #1481216).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :
Download full text (18.2 KiB)

This bug was fixed in the package horizon - 1:2015.1.4-0ubuntu3
---------------

 horizon (1:2015.1.4-0ubuntu3) trusty-kilo; urgency=medium
 .
   * debian/theme/ubuntu/_styles.scss: Ensure btn-primary text color takes
     precedence (LP: #1481216).
 .
 horizon (1:2015.1.4-0ubuntu2) trusty-kilo; urgency=medium
 .
   * d/p/remove-can-access-caching.patch (LP: #1382079): Remove session
     caching of can_access call results which was disabling the project
     selector.
 .
 horizon (1:2015.1.4-0ubuntu1) trusty-kilo; urgency=medium
 .
   * New upstream stable release (LP: #1580334).
 .
 horizon (1:2015.1.3-0ubuntu1) trusty-kilo; urgency=medium
 .
   * New upstream stable release (LP: #1559215, #1352256).
 .
 horizon (1:2015.1.2-0ubuntu1) vivid; urgency=medium
 .
   [ Chuck Short ]
   * Resynchronize with stable/kilo (5b9bdca) (LP: #1481008):
     - [5b9bdca] Use security group id not name in the create instance dialog
     - [74d885f] Fix not opening region selector on first click
     - [b8e1ce8] Neutron Quota Settings Flag Disables Neutron GUI
     - [853f0ec] Fix inability to switch region via Switch Region dropdown
     - [0b3c92d] Updated from global requirements
     - [d6be306] Fix a unit test for create instance
     - [8ed7624] Compatibility fix for pyscss 1.3.4
     - [7c8fc8f] Skip test_routerrule_detail blocking the gate
     - [fea681e] Remove 'shared' from Neutron Firewall table
     - [1d20ea0] Fix static file paths in heat topology view
     - [8da65b6] Don't get descript if attribute doesn't exist.
     - [905e92b] Fix attribute error with old glance backend
     - [c079705] Added correct URL to edit QoS spec
     - [900ca63] Updated from global requirements
     - [3becb61] Port cleanup on failed VM instance launch
     - [b84218d] N1Kv: Fix failing network and port creates
     - [0f9d94e] Add OPENSTACK_NOVA_EXTENSIONS_BLACK
 .
   [ Corey Byrant ]
   * d/rules: Prevent dh_python2 from guessing dependencies.
   * d/openstack-dashboard-ubuntu-theme.postrm: Ensure that purge and
     reload of static assets is only done on purge/remove, resolving
     problems when upgrading to new versions (LP: #1506826).
 .
 horizon (1:2015.1.1-0ubuntu1) vivid; urgency=medium
 .
   * Resynchronize with stable/kilo (bb05237) (LP: #1481008):
     - [d29a68c] Removing Network Profile support in stable/kilo
     - [cfb16ec] Add a conditional judgement to avoid invalid dict index
     - [824df76] Fix mock issues found due to new mock release
     - [82f63a5] Fix Create User form's fields sorting for Django 1.7
     - [f0691cf] changing email from user list deletes user passwd
     - [25c961f] fix delete action always cause error
     - [ec27165] Fix date pickers in metering modal
     - [8ed6a85] Wait until the image is registered in Sahara image test
     - [fcff73c] Skip test_{floatingip,image_register_unregister,create_delete_user} for now
     - [1e84c93] Handle errors during glance image updates correctly
     - [2fc3fcd] corrected the create volume from snapshot
     - [84da479] Escape the description param from heat template
     - [bafdabb] Prevent multiple form submission on table row actions
     - [0642fdd] Fixing data processing operat...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers