openstack-dashboard-ubuntu-theme fails to install

Bug #1424042 reported by Chris J Arges on 2015-02-20
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
horizon (Ubuntu)
High
Unassigned

Bug Description

[Impact]

Users won't be able to install openstack-dashboard on vivid.

Setting up openstack-dashboard-ubuntu-theme (1:2015.1~b2-0ubuntu2) ...
Collecting and compressing static assets...
CommandError: An error occured during rendering /usr/share/openstack-dashboard-ubuntu-theme/templates/_stylesheets.html: 'dashboard/css/rickshaw.css' could not be found in the COMPRESS_ROOT '/usr/share/openstack-dashboard/static' or with staticfiles.
dpkg: error processing package openstack-dashboard-ubuntu-theme (--configure):

ubuntu@controller:~$ ls /usr/share/openstack-dashboard/static/dashboard/css/
f7e146208cbd.css

[Test Case]
Install vivid, run:
sudo apt-get install openstack-dashboard apache2 libapache2-mod-wsgi

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: openstack-dashboard-ubuntu-theme 1:2015.1~b2-0ubuntu2
ProcVersionSignature: User Name 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic x86_64
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
Date: Fri Feb 20 19:29:29 2015
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: horizon
UpgradeStatus: No upgrade log present (probably fresh install)

Chris J Arges (arges) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu):
status: New → Confirmed
Changed in horizon (Ubuntu):
importance: Undecided → High
James Page (james-page) on 2015-04-28
Changed in horizon (Ubuntu):
status: Confirmed → Triaged
James Page (james-page) on 2015-09-03
Changed in horizon (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers