openstack-dashboard should suggest python-lesscpy

Bug #1226674 reported by Scott Moser on 2013-09-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
horizon (Ubuntu)
Undecided
Unassigned

Bug Description

Upstream horizon commit at [1] dropped requirement on less.js in favor of python-lesscpy. Upstream MP at [2] specifically says "still waiting on ubuntu package".

As packaged in ubuntu and debian, 'lesscpy' binary is only available in 'python3-lesscpy' package.

In order to support upstream's ci that wants to use lesscpy from cloud archive, we're interested in uploading it to the cloud archive.
However, we don't really want to have packages (other than "top level" openstack packages) in the cloud archive that are not dependencies.

I'm not sure how best to address this really. One suggestion (as in the title here) is to 'Suggests' the python3-lesscpy package from openstack-dashboard. Then, at least we have *some* link as to why this package is being added.

[1] https://github.com/openstack/horizon/commit/a0739c9423a4c559b45af96fa4cdb30539dcdbd7
[2] https://review.openstack.org/#/c/40218/

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: openstack-dashboard 1:2013.2~b3-0ubuntu1
ProcVersionSignature: User Name 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.1-0ubuntu4
Architecture: amd64
Date: Tue Sep 17 15:47:52 2013
Ec2AMI: ami-000004e5
Ec2AMIManifest: FIXME
Ec2AvailabilityZone: nova
Ec2InstanceType: m1.tiny
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: horizon
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :

I'm going to remove the upload to '-staging' of python-lesscpy.

As it stands, this is *broken* because:
 a.) python-lesscpy depends on python-ply, which wasn't uploaded
 b.) python-lesscpy depends on 'python3 (>= 3.2.3-3~)', and version in 12.04 of python3-defaults is 3.2.3-0ubuntu1.2.

Additionally, the python-lesscpy package is less than ideal in these ways:
 c.) only builds python3-lesscpy while python2 is listed as supported by upstream.
 d.) there would ideally be a 'lesscpy' package that delivered the binary /usr/bin/lesscpy that depended on python3-lesscpy.

James Page (james-page) wrote :

Scott

I've fixed up lesscpy in Saucy for python2 and 3 (it was not built for 2 and broken with 3).

This should get into the cloud-archive IMHO; if you want to run with online compression then you have to have this package installed. We did not have the same problem with nodejs/node-lessc as that is present in Ubuntu 12.04.

summary: - openstack-dashboard should suggest python3-lesscpy
+ openstack-dashboard should suggest python-lesscpy
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2013.2~rc1-0ubuntu1

---------------
horizon (1:2013.2~rc1-0ubuntu1) saucy; urgency=low

  [ James Page ]
  * New upstream release candidate:
    - d/static: Refreshed static assets for 2013.2~rc1.
    - d/patches: Refreshed patches.

  [ Chuck Short ]
  * debian/control: Add python-lesscpy as a suggests to optionally
    support online compression of static assets (LP: #1226674).
 -- James Page <email address hidden> Thu, 03 Oct 2013 13:48:12 +0100

Changed in horizon (Ubuntu):
status: New → Fix Released
James Page (james-page) on 2013-10-11
Changed in cloud-archive:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers