Havana-3 Dependency missing: python-troveclient

Bug #1221906 reported by Adam Gandelman
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Matthias Runge
horizon (Ubuntu)
Critical
Unassigned
Saucy
Critical
Unassigned

Bug Description

This is blocking Havana-3 release of Horizon into Ubuntu. Since H2, python-troveclient was introduced as a dependency of Horizon and the application will not function without it. Currently it is not available in Ubuntu.

[Fri Sep 06 19:44:01 2013] [notice] Apache/2.2.22 (Ubuntu) mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] mod_wsgi (pid=6347): Exception occurred processing WSGI script '/usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi'.
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] Traceback (most recent call last):
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] File "/usr/lib/python2.7/dist-packages/django/core/handlers/wsgi.py", line 236, in __call__
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] self.load_middleware()
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] File "/usr/lib/python2.7/dist-packages/django/core/handlers/base.py", line 45, in load_middleware
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] for middleware_path in settings.MIDDLEWARE_CLASSES:
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] File "/usr/lib/python2.7/dist-packages/django/conf/__init__.py", line 53, in __getattr__
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] self._setup(name)
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] File "/usr/lib/python2.7/dist-packages/django/conf/__init__.py", line 48, in _setup
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] self._wrapped = Settings(settings_module)
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] File "/usr/lib/python2.7/dist-packages/django/conf/__init__.py", line 134, in __init__
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] raise ImportError("Could not import settings '%s' (Is it on sys.path?): %s" % (self.SETTINGS_MODULE, e))
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path?): No module named troveclient
[Fri Sep 06 19:44:53 2013] [error] [client 192.168.25.30] File does not exist: /var/www/favicon.ico

Changed in horizon (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Adam Gandelman (gandelman-a) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu):
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (master)

Fix proposed to branch: master
Review: https://review.openstack.org/46466

Changed in horizon:
assignee: nobody → Matthias Runge (mrunge)
status: New → In Progress
Revision history for this message
Adam Gandelman (gandelman-a) wrote :

python-troveclient 1:0.1.4-0ubuntu1 uploaded to Ubuntu, promoted to main.

Changed in horizon (Ubuntu Saucy):
status: Confirmed → Fix Released
Matthias Runge (mrunge)
Changed in horizon:
milestone: none → havana-rc1
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (master)

Reviewed: https://review.openstack.org/46466
Committed: http://github.com/openstack/horizon/commit/c9022fa0657bdf298c594c458f7faec37434084e
Submitter: Jenkins
Branch: master

commit c9022fa0657bdf298c594c458f7faec37434084e
Author: Matthias Runge <email address hidden>
Date: Fri Sep 13 12:05:31 2013 +0200

    Make troveclient optional

    Fixes bug 1221906

    Change-Id: I3d022fca2f6bc1f0f5143373259882f2522f7958

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx)
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in horizon:
milestone: havana-rc1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers