openstack-dashboard no longer installs a functioning webserver

Bug #1218535 reported by Adam Gandelman on 2013-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
horizon (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

Previously, installing openstack-dashboard would install an apache2 server (if required) and configure and add a configuration entry for the dashboard. Using saucy, this is no longer the case. apache2-bin is installed, but there is no server running, nothing listening on port 80, and only the minimal required apache config installed in /etc/apache2:

./conf.d
./conf.d/openstack-dashboard.conf
./mods-available
./mods-available/wsgi.conf
./mods-available/wsgi.load

Related branches

Changed in horizon (Ubuntu Saucy):
importance: Undecided → High
Adam Gandelman (gandelman-a) wrote :

Looks like the package needs to be properly transitioned to apache 2.4 There is a proposed but incomplete merge at https://code.launchpad.net/~zulcss/horizon/apache-transition/+merge/175641. We also need to ensure the package remains compatible with apache2.2 in the Cloud Archive.

Changed in cloud-archive:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 1:2013.2~b2-0ubuntu4

---------------
horizon (1:2013.2~b2-0ubuntu4) saucy; urgency=low

  * Update for apache 2.4, preserve 2.2 compatability. (LP: #1218535)
 -- Adam Gandelman <email address hidden> Fri, 30 Aug 2013 15:31:49 -0700

Changed in horizon (Ubuntu Saucy):
status: New → Fix Released
James Page (james-page) on 2013-10-11
Changed in cloud-archive:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers