Ubuntu theme in Horizon dashboard causes formatting issues

Bug #1064420 reported by steve A on 2012-10-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
horizon (Ubuntu)
Critical
Adam Gandelman

Bug Description

I am creating a folsom multi server installation
I use the additopnal folsom cloud archives as described here to install openstack-folsom on ubuntu server 12.04LTS.
http://docs.openstack.org/trunk/openstack-compute/install/apt/content/assumptions.html

I followed this documentation for the entire build -
http://docs.openstack.org/trunk/openstack-compute/install/apt/content/ch_installing-openstack-overview.html

I followed the procedure for installing the dashboard -
http://docs.openstack.org/trunk/openstack-compute/install/apt/content/ch_install-dashboard.html

once installed, the openstack-ubuntu-theme is also installed. However there are formatting errors . All pages are missing buttons, the fonts are wrong and left and right margins appear be invalid. pop up windows also do not appear correctly.

Steps to reproduce -
apt-get install -y memcached libapache2-mod-wsgi openstack-dashboard
<configure all config files as per documentation>
navigateto <ipaddress of host>/horizon

workaround to restore page formatting
 apt-get purge openstack-dashboard-ubuntu-theme
navigateto <ipaddress of host>/horizon

Dave Walker (davewalker) on 2012-10-09
Changed in horizon (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Adam Gandelman (gandelman-a)
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2012.2-0ubuntu2

---------------
horizon (2012.2-0ubuntu2) quantal; urgency=low

  * debian/control: Set strict version requirements between python-django-horizon,
    openstack-dashboard, and openstack-ubuntu-theme. (LP: #1061961)
  * debian/theme/css/ubuntu.css: Refreshed against Folsom. (LP: #1064420)
  * debian/patches/add_juju_panel.patch: Update and refresh for Folsom
    compatability. (LP: #1064605)
  * debian/patches/allow_alternate_css.patch: Remove unapplied, obsolete
    patch.
 -- Adam Gandelman <email address hidden> Tue, 09 Oct 2012 09:59:55 -0700

Changed in horizon (Ubuntu):
status: Triaged → Fix Released
Jasper Aikema (jasper-aikema) wrote :

The fix works for me. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers