Upgrading openstack-dashboard does not upgrade dependencies.

Bug #1061961 reported by Adam Gandelman on 2012-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
horizon (Ubuntu)
Undecided
Adam Gandelman

Bug Description

When upgrading from the openstack-dashboard package from 2012.1.3+stable~20120815-691dd2-0ubuntu1 to 2012.2-0ubuntu1~cloud0, a newer version of python-django-horizon is also required but is not updated with openstack-dashboard. As a result, a bunch of missing requirements (namely all of the new Folsom python=${foo}client packages) are missing, which results in a broken dashboard

[Fri Oct 05 00:08:22 2012] [error] [client 71.236.173.142] ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path?): No module named cinderclient, referer: http://ec2-50-112-7-145.us-west-2.compute.amazonaws.com/dashboard/auth/login/

tags: added: openstack-ubuntu-upgrade
Changed in horizon (Ubuntu):
assignee: nobody → Adam Gandelman (gandelman-a)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2012.2-0ubuntu2

---------------
horizon (2012.2-0ubuntu2) quantal; urgency=low

  * debian/control: Set strict version requirements between python-django-horizon,
    openstack-dashboard, and openstack-ubuntu-theme. (LP: #1061961)
  * debian/theme/css/ubuntu.css: Refreshed against Folsom. (LP: #1064420)
  * debian/patches/add_juju_panel.patch: Update and refresh for Folsom
    compatability. (LP: #1064605)
  * debian/patches/allow_alternate_css.patch: Remove unapplied, obsolete
    patch.
 -- Adam Gandelman <email address hidden> Tue, 09 Oct 2012 09:59:55 -0700

Changed in horizon (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers