Attempting to change regions in the dashboard does not display correctly

Bug #1033934 reported by Andrew Glen-Young on 2012-08-07
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Gabriel Hurley
horizon (Ubuntu)
High
Unassigned

Bug Description

After logging in to the dashboard in one region I attempted to change regions by selecting the other region in the top right corner. After doing this, login credentials form elements appear on the bottom left-hand side and does not look correct (I have attached screenshots to illustrate what I see).

While I am not a UX expert, I do not believe that it is intended to display this way. I have tested in both Firefox and Chromium and experienced the same thing.

How to reproduce (see attached images):

 1. Login to the dashboard, selecting any one of the regions (image 01).
 2. Select a region from the dropdown in the top right corner and click on the region name (image 02).
 3. Notice the form elements appear in the bottom left corner (image 03).
 4. (And again) Scroll to the top of the page, select a region from the dropdown in the top right corner again and notice additional form elements appear (image 04).

What I expect (suggestion):

I expect the form elements to display "correctly". Perhaps as a rendered login dialog overlayed on the current page?

System(s) Information:

Client system:

    $ dpkg-query --show 'firefox' 'chromium-browser'
    chromium-browser 18.0.1025.168~r134367-0ubuntu0.12.04.1
    firefox 14.0.1+build1-0ubuntu0.12.04.1

    $ cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"

Server system:

    $ dpkg-query --show *dashboard*
    openstack-dashboard 2012.1-0ubuntu8.1
    openstack-dashboard-ubuntu-theme 2012.1-0ubuntu8.1

    $ cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"

Andrew Glen-Young (aglenyoung) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu):
status: New → Confirmed
James Page (james-page) on 2012-08-30
Changed in horizon (Ubuntu):
importance: Undecided → High
Gabriel Hurley (gabriel-hurley) wrote :

This definitely does not affect current Horizon master. In general this problem is the result of a template failing to extend from the "modal form" base template, or not using the ModalFormView class. I'm not sure what's going on in the downstream package to cause this behavior currently.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers