Ubuntu

Laptop Fails to Hibernate Correctly

Reported by PC on 2011-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hibernate (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hibernate

My laptop does not hibernate correctly. It does suspend correctly.

When hibernating:
  a) Black screen for about 8 secs
  b) Lots of random flikering on the screen for about 12 secs
  c) PC then turns off
On re-starting:
  a) Grub screen appears
  b) Followed by usual Ubuntu log in page
  c) When logged in are in a fresh (nothing open) session

The system is a fresh install of 11.04, that involved re-partitioning the disk, so the swap partition was also created afresh. The encrypted /home partition option was selected.

Followed instructions at:
DebuggingKernelSuspendHibernateResume
https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume

This mentioned an issue with encrypted swap space causing hibernation to fail. So following the instructions at: http://www.logilab.org/blogentry/29155
I changed the swap partition over from encrypted to unencrypted. The old and new entries in the /etc/fstab are shown below:

#/dev/mapper/cryptswap1 none swap sw 0 0
#/dev/sda9: UUID="64198743-6a35-4d69-b9cd-47b7726c7ef9"
#/dev/sda9 none swap sw 0 0
UUID=64198743-6a35-4d69-b9cd-47b7726c7ef9 none swap sw 0 0

Is encrypted swap space still an issue with hibernation? Did I need to do this?

After changing to unencrypted swap the hibernation behaviour was still the same.

I then followed the instructions from:
https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume

"pm-hibernate"
Exactly the same behaviour as when hibernating from the graphical desktop

The I followed each of the three sets of tests. The first 2 tests in each set always ran and nothing seemed to apparently happen. However, in all three cases the third "echo disk . ..." test caused a brief blank screen and then lots of random flickering as before, but this time the laptop did not switch off. A hard power off button had to be used in each case. This meant that I could not follow the "dmesg > ..." command as requested.
What I then did was repeat the tests, but in each group after the second test I ran the "dmesg > ..." command and saved the file. I then ran the third test.

The instructions also said to "cat /sys/power/pm_test and cat /sys/power/disk", this was done and the results saved to files.

I will attach the various fails created to this ticket.

If I can run any other tests to help with this issue please post.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: hibernate (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Mon Jun 20 21:04:48 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: hibernate
UpgradeStatus: No upgrade log present (probably fresh install)

PC (pc101) wrote :
PC (pc101) wrote :
PC (pc101) wrote :
PC (pc101) wrote :
PC (pc101) wrote :
PC (pc101) wrote :
PC (pc101) wrote :

For completeness the three sets of tests used from the page:

https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume

were

    # echo devices > /sys/power/pm_test
    # echo platform > /sys/power/disk
    # echo disk > /sys/power/state
    # dmesg > /tmp/dmesg-devices-platform.txt

    # echo core > /sys/power/pm_test
    # echo platform > /sys/power/disk
    # echo disk > /sys/power/state
    # dmesg > /tmp/dmesg-core-platform.txt

    # echo core > /sys/power/pm_test
    # echo reboot > /sys/power/disk
    # echo disk > /sys/power/state
    # dmesg > /tmp/dmesg-core-reboot.txt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers