Suspend/hibernate breaks network and triggers itself.

Bug #524565 reported by pererik87 on 2010-02-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
hibernate (Ubuntu)
Undecided
Unassigned

Bug Description

Lucid Lynx
Binary package hint: hibernate

The network is enabled but finds no networks after suspend.
Suspend/hibernate also triggers itself.

i ran this test:
Suspend/hibernate

""
Click Test to switch to another virtual terminal and then back to X. Your screen will change temporarily to a text console and then switch back to your current session.
Note that this test may require you to enter your password.
Did the screen change temporarily to a text console?
""
It did temporary and then it suspended/hibernated, then it broke my network. This happens every time i Suspend/hibernate.

pererik87 (pererik87) wrote :
pererik87 (pererik87) on 2010-02-19
description: updated
description: updated
crysys (crysysone) wrote :

I think my issue is related. I attempted to use suspend to disk in Kubuntu Lucid on my laptop and could not recover. After a hard reboot my Network Management is disabled, my internal wireless will not turn on. KNetworkManager will not start and plugging in to a wired connection does not automatically bring up a connection.

After adding settings for eth0 to /etc/network/interfaces(only lo was present) and restarting /etc/init.d/networking I get lights on the wired connection, can ping the router but still do not have internet connectivity.

crysys (crysysone) wrote :

Disreguard the last bit, once manual networking has been set up I do have connectivity, I was pinging a server that did not respond to pings. Doh!

crysys (crysysone) wrote :

http://osdir.com/ml/debian-bugs-dist/2010-01/msg07864.html

That bug explained my problem and this solution worked with one caveat:

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

I had to restart the computer because network manager still acted like it was disabled. A session restart probably would have sufficed.

I don't know if this is KDE specific or not.

pererik87 (pererik87) wrote :

i use gnome.
I had a lot of bugs, most was reported duplicate of newer answered, so i just stopped testing. I'll rather wait.

Davor Cubranic (cubranic) wrote :

Can this be linked to Debian issue 566891: Network Management disabled after "suspend to ram", as identified in comment 4?

olksy (noface) wrote :

I was also affected with this bug and spend about 2 days googling, why suddently NetworkManager stopped detecting eth0.

I believe, this bug must be treated with high importance. Its obvious case, that anyone will not able to get help from Ubuntu community, while his/her network connection is down. :(

pererik87 (pererik87) wrote :

I reinstalled and disabled every option in power management (without removing it).

I also killed the screen saver. Now everything works great, but I shouldn't have to modify my system like that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments