Manpage for mkefs.hfsplus refers to pdisk, which is not packaged

Bug #234749 reported by Lars Noodén on 2008-05-25
4
Affects Status Importance Assigned to Milestone
hfsprogs (Debian)
Fix Released
Unknown
hfsprogs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hfsprogs

The manpage for mke.hfsplus has a SEE ALSO section which refers to pdisk(8)

There is no man page for pdisk or pdisk(8)
apt-cache cannot find 'pdisk'

This is from Kubuntu 8.04 KDE4 as provided by kubuntu-kde4-8.04-alternate-amd64.iso and subsequent updates

Related branches

Milan Bouchet-Valat (nalimilan) wrote :

Thansk for reporting bugs, but this one does not appear to be in Ubuntu. The newfs_hfs command is not part of the hfsprogs package, and actually I don't think you can find it in Ubuntu packages: it's from Apple's HFS+. So the bug is not from Ubuntu, I close it.

As a sidenote, it seems pdisk is not shipped by Ubuntu nor by Debian. So the needed tool would be pmac-fdisk (hope this helps).

Changed in hfsprogs:
status: New → Invalid

Sorry. I was thinking 'mkfs.hfsplus' but wrote instead 'newfs_hfs'. mkfs.hfsplus is definitely part of Ubuntu, at least as of Hardy:

 $ dpkg -S mkfs.hfsplus
 hfsprogs: /usr/share/man/man8/mkfs.hfsplus.8.gz
 hfsprogs: /sbin/mkfs.hfsplus

 $ lsb_release -rc
 Release: 8.04
 Codename: hardy

pdisk is mentioned in the manpage for mkfs.hfsplus:

   "SEE ALSO
        mount(8), pdisk(8)"

You're right about pdisk not being in debian, though:

http://packages.debian.org/search?searchon=contents&keywords=pdisk&mode=exactfilename&suite=unstable&arch=any

So the solution is to either remove the mention of pdisk, to add it to ubuntu, or to point to where it can be downloaded.

Changed in hfsprogs:
status: Invalid → New

This should be reported to Debian, no need to make a Ubuntu-only fix. Would you do this? Else I'm afraid nothing will happen...

Changed in hfsprogs:
status: New → Confirmed
description: updated

Hmmm. The package 'reportbug' is reliant on an SMTP connection, which is not common any more. A new version should have the option for HTTP-POST or GET.

Ok. Now I will get more spam because of Bill Gates' botnets harvesting the unobfuscated addresses from the Debian bug tracker:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=482868

Milan Bouchet-Valat (nalimilan) wrote :

Thanks. Sorry for the spam, but that's how Debian works, and you see they are more efficient than us in that area. ;-)

Changed in hfsprogs:
status: Unknown → New
Changed in hfsprogs:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hfsprogs - 332.14-5

---------------
hfsprogs (332.14-5) unstable; urgency=low

  * debian/patches: break-up the Gentoo patch into smaller patches.
  * debian/patches: reorder the patches.
  * debian/patches: refresh the patches.
  * debian/patches: remove mention of pdisk (Closes: #482868) (LP: #234749).
  * debian/control: include Homepage field.
  * debian/control: update Standards-Version to 3.8.0. No changes required.
  * debian/control: include DM-Upload-Allowed, as I am a DM now.
  * debian/control: remove statement about using journals (LP: #164151).
  * debian/rules: add -Wextra compilation flag.
  * debian/rules: use quilt.make and remove home-brew solution.
  * debian/watch: create watch file (lintian warning).

 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 04 Nov 2008 21:25:54 +0000

Changed in hfsprogs:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.