highlighting multiple channels results in the closing of one of them

Bug #1756402 reported by Paul White on 2018-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HexChat
Fix Released
Unknown
hexchat (Ubuntu)
Undecided
Mattia Rizzolo

Bug Description

I wanted to close a couple of channels and thought that if I highlighted more than one then a right-click option might be available to close them simultaneously.

Unfortunately the lowest channel in the tree was immediately closed upon highlighting two channels. The other channel remained open.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: hexchat 2.14.1-1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Mar 16 17:40:13 2018
InstallationDate: Installed on 2017-11-07 (129 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
SourcePackage: hexchat
UpgradeStatus: Upgraded to bionic on 2018-02-21 (23 days ago)

Paul White (paulw2u) wrote :
Changed in hexchat-irc:
status: Unknown → New
TingPing (tingping) wrote :

As in the upstream bug report this was a feature not a bug.

I agreed it was a strange feature though and have removed it for the next release.

Changed in hexchat (Ubuntu):
status: New → Invalid
Changed in hexchat-irc:
status: New → Fix Released
Mattia Rizzolo (mapreri) wrote :

Thanks to TingPing, I'll cherry-pick the change into ubuntu soon (as I also agree).

Changed in hexchat (Ubuntu):
status: Invalid → In Progress
assignee: nobody → Mattia Rizzolo (mapreri)
Mattia Rizzolo (mapreri) wrote :

uploaded to debian, will sync later.

Changed in hexchat (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hexchat - 2.14.1-2

---------------
hexchat (2.14.1-2) unstable; urgency=medium

  * Add some patches from upstream:
    + upstream/0003-Remove-shift-click-to-close-tab-binding.patch
      - LP: #1756402
    + upstream/0004-build-Add-metainfo-files-for-addons.patch
    + upstream/0005-build-Fix-id-in-plugin-metainfo-files.patch
    + upstream/0006-build-Correctly-set-plugin-licenses.patch
    + upstream/0007-build-Re-add-support-for-the-legacy-perl-api.patch
    + upstream/0008-Deiconify-window-on-tray-click.-Closes-2136.patch
  * Fixup our py2+py3 patch after the above patches have been applied.
  * Install the new metainfo files representing the various plugins.

 -- Mattia Rizzolo <email address hidden> Tue, 20 Mar 2018 16:10:27 +0100

Changed in hexchat (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.