heimdal-kdc should depend on some inetd

Bug #123782 reported by Jamie Strandboge on 2007-07-03
2
Affects Status Importance Assigned to Milestone
heimdal (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: heimdal-kdc

heimdal-kdc on Feisty should either Depends on openbsd-inetd (or other inetd), or a note should be given to the user stating that the default configuration requires it. Installing heimdal-kdc on Feisty server (which doesn't install an inetd by default) results in a broken configuration, since it is by default configured to run via inetd.

Related branches

description: updated
Rick Clark (dendrobates) wrote :

Thanks for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. [WWW] https://answers.launchpad.net/ubuntu

heimdal-kdc depends netbase, which provides inetd.

Changed in heimdal:
status: New → Invalid
Jamie Strandboge (jdstrand) wrote :

A fresh install of Feisty did not come with inetd. Checking netbase reveals:

$ apt-cache search -f netbase
Package: netbase
Priority: important
Section: base
Installed-Size: 156
Maintainer: Ubuntu Core Developers <email address hidden>
Original-Maintainer: Marco d'Itri <email address hidden>
Architecture: all
Version: 4.27ubuntu2
Depends: ifupdown (>= 0.6.4-4.9), iputils-ping | ping, lsb-base (>= 3.0-6), debconf (>= 0.5) | debconf-2.0, update-inetd
Conflicts: openbsd-inetd (<< 0.20050402-3), inetutils-inetd (<< 2:1.4.3+20060719-3), xinetd (<= 2.2.1-8), netstd (<< 3.00), nfs-common (<< 1:0.3.2-1), nfs-user-server (<< 2.2beta47-9), nis (<= 3.6-2), rstatd (<= 3.03-3), rwalld (<= 0.16-1), rusersd (<= 0.17-1), ugidd (<< 2.2beta47-9)
Filename: pool/main/n/netbase/netbase_4.27ubuntu2_all.deb
Size: 38178
MD5sum: 8ae154263c5ed68d4f388c33d3f3ba9d
SHA1: 6defd7bf0fb2c98bbf89150bbec3da4bb54f82e2
SHA256: 28e3fcdda172a6204937531ecb9a4401613ce6d2bcc27aa1e50d937d2106c4bc
Description: Basic TCP/IP networking system
 This package provides the necessary infrastructure for basic TCP/IP based
 networking.
Bugs: mailto:<email address hidden>
Origin: Ubuntu
Task: minimal

It depends on update-inetd, but not another inetd. It also does not Provide inetd, or give the binary for it:
dpkg -L netbase
/.
/etc
/etc/network
/etc/protocols
/etc/rpc
/etc/services
/etc/init.d
/etc/init.d/networking
/usr
/usr/share
/usr/share/doc
/usr/share/doc/netbase
/usr/share/doc/netbase/README.Debian
/usr/share/doc/netbase/copyright
/usr/share/doc/netbase/changelog.gz

Jamie Strandboge (jdstrand) wrote :

based on your comment, this sounds more like a problem with netbase. Maybe it should move there?

Rick Clark (dendrobates) wrote :

Mistake on my part. I have verified this in Feisty and Gutsy.

Changed in heimdal:
importance: Undecided → Low
status: Invalid → Confirmed
Rick Clark (dendrobates) wrote :

heimdal (0.7.2.dfsg.1-10ubuntu2) gutsy; urgency=low

  * debian/control:
    - Actually added openbsd-inetd | inet-superserver to heimdal-servers'
      dependencies (LP: #123782).
    - DebainMaintainerField foo

 -- Rick Clark <email address hidden> Tue, 03 Jul 2007 19:58:47 -0400

Changed in heimdal:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers