Clicking "Associate file extensions" in options menu fails

Bug #811770 reported by Christopher Kyle Horton
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hedgewars (Debian)
Fix Committed
Undecided
Unassigned
hedgewars (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

When clicking the "Associate file extensions" button in the options menu, a window just pops up saying "File association failed." When running Hedgewars in a terminal, it outputs the following:

christopher@Zyx:~$ hedgewars
there is no soundcard
cp: cannot stat `/usr/share/games/hedgewars/Data/misc/hwengine.desktop': No such file or directory

Note that the 3rd line in the above output appears immediately after clicking the aforementioned button. Using the current version from the Ubuntu Software center, on Ubuntu 11.04 64-bit.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: hedgewars 0.9.15-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
Architecture: amd64
Date: Sun Jul 17 01:01:12 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: hedgewars
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :
Revision history for this message
Paul Wise (Debian) (pabs) wrote :

I've confirmed that this is an issue on Debian too.

I've committed a fix for this change to the Debian/Ubuntu games team's git repository.

Changed in hedgewars (Debian):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hedgewars - 0.9.17-1

---------------
hedgewars (0.9.17-1) unstable; urgency=low

  * [Paul Wise]
   * Mention the homing bee in the package description (Closes: #577092)
   * Also install the hwengine desktop file (LP: #811770)
   * Depend on ttf-dejavu-core since it is smaller
   * Depend on ttf-wqy-zenhei instead of embedding a copy of it
  * [Dmitry E. Oboukhov]
   * New upstream version.

 -- Dmitry E. Oboukhov <email address hidden> Sun, 20 Nov 2011 18:31:17 +0400

Changed in hedgewars (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers