does not honor LC_MESSAGES

Bug #1435643 reported by Rolf Leggewie on 2015-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hedgewars
Unknown
Unknown
hedgewars (Ubuntu)
Undecided
Unassigned

Bug Description

just the same as bug 1404947

LC_ALL="" LANG=de_DE.UTF-8 LC_MESSAGES=C hedgewars

that should run the standard english version of the program interface but in fact the German version is shown. Check "man 7 locale" for the hierarchy of locale-related environment variables.

Changed in hedgewars (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

Thanks, Locutus.

Thanks to you, unfortunately I looked at the code but this seems an upstream issue, so we can fix in the next release, if upstream looks at it. thanks for the report

mmm seems that there is no bug...

do you have language-pack-de-base installed?
I guess the package is needed to set the locale.

After moving my .hedgewars config dir I tried to reproduce and I can switch correctly between italian end english (the two locale I use on my machine)

Changed in hedgewars (Ubuntu):
status: Confirmed → Incomplete
Rolf Leggewie (r0lf) wrote :

I think you misunderstand the bug. My "complaint" is apparently the opposite of what you think it is. Please re-read my initial report.

Changed in hedgewars (Ubuntu):
status: Incomplete → New
Rolf Leggewie (r0lf) wrote :

should run the standard ENGLISH version

oops yes indeed! can you please followup on the google issue?

Rolf Leggewie (r0lf) wrote :

looks like upstream doesn't care much about delivering quality software, more concerned with closing tickets prematurely.

I don't think so, they always reopen when there is really a bug ;)

Changed in hedgewars (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.