Gameplay cannot start in Hedgewars 0.9.18-0.2ubuntu1

Bug #1171825 reported by Žygimantas Beručka
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hedgewars (Ubuntu)
Fix Released
Undecided
Unassigned
Raring
Fix Released
Undecided
Unassigned

Bug Description

Hedgewars gameplay cannot start in Ubuntu 13.04. Whatever game type is chosen, one just gets a stuck string "In game..." and some fullscreen background, and that's it. It doesn't go as far as to load any level, therefore nothing works. The only option left is just closing it with ALT+F4.

There are no error or warning messages when launching from a terminal so I have no idea what's happening.

I've tried running it on two machines, one with Intel 965 and another with HD3000. I assume SNA acceleration is enabled on both machines as per Raring Ringtail's default policy.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: hedgewars 0.9.18-0.2ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-18.28-generic 3.8.6
Uname: Linux 3.8.0-18-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Tue Apr 23 14:21:20 2013
InstallationDate: Installed on 2011-11-12 (527 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
SourcePackage: hedgewars
UpgradeStatus: Upgraded to raring on 2013-03-11 (42 days ago)

[Impact]
User that don't have freeglut3 instaleld through other package dependencies won't able to play hedgewars as it just freezes when starting a game.

[Test Case]
Make sure hedgewars depends on freeglut3 and you are able to start a game.

[Regression Potential]
Very low, the only change is to add a dependency.

Revision history for this message
Žygimantas Beručka (zygis) wrote :
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

could you run totem or maybe supertuxkart?
I think the problem is in your videocard driver, I'm experiencing a really similar bug too on 12.10

Revision history for this message
Žygimantas Beručka (zygis) wrote : Re: [Bug 1171825] Re: Gameplay cannot start in Hedgewars 0.9.18-0.2ubuntu1

Yes, I can run both Totem and Supertuxkart flawlessly on 13.04 (they ran
fine on 12.10 and 12.04 too). In fact, Hedgewars ran just fine on 12.10 on
the very same machines too so I'm not convinced it's related in any way to
your bug.

2013/4/23 LocutusOfBorg <email address hidden>

> could you run totem or maybe supertuxkart?
> I think the problem is in your videocard driver, I'm experiencing a really
> similar bug too on 12.10
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1171825
>
> Title:
> Gameplay cannot start in Hedgewars 0.9.18-0.2ubuntu1
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/hedgewars/+bug/1171825/+subscriptions
>

Revision history for this message
Kamil Markiewicz (kamarkiewicz) wrote :

It is caused by unselected dependences in this package.
After instaling followed packages game started to work :)
Install: libav-tools:i386 (0.8.6-1ubuntu2, automatic), ffmpeg:i386 (0.8.6-1ubuntu2, automatic), libavfilter2:i386 (0.8.6-1ubuntu2, automatic), freeglut3:i386 (2.6.0-4ubuntu1, automatic), libavdevice53:i386 (0.8.6-1ubuntu2, automatic)
End-Date: 2013-04-27 21:39:21

sudo apt-get install libav-tools ffmpeg libavfilter2 freeglut3 libavdevice53

Revision history for this message
Kamil Markiewicz (kamarkiewicz) wrote :

Add libav-tools ffmpeg libavfilter2 freeglut3 libavdevice53 packages as dependences.

Changed in hedgewars (Ubuntu):
status: New → Confirmed
Revision history for this message
Felix Geyer (debfx) wrote :

Before uploading a fix I'd want to understand which of them is really needed and why it's not added automatically.
My guess is that freeglut3 is the one that's required.

Revision history for this message
Darlan Alves (darlan) wrote :

Yep. freeglut3 did the trick for me. Pobably adding it to list of required packates will solve the case.
Fresh install of 13.04, used to play on 12.10.

Revision history for this message
Kamil Markiewicz (kamarkiewicz) wrote :

I don't exacly know for what this are used, I've get depslist from Ubuntu package from hedgewars.org.

hedgewars_0.9.18-1~getdeb2_i386.deb contains:
Depends: libavcodec53 (>= 4:0.8-1~) | libavcodec-extra-53 (>= 4:0.8-1~), libavformat53 (>= 4:0.8-1~) | libavformat-extra-53 (>= 4:0.8-1~), libavutil51 (>= 4:0.8-1~) | libavutil-extra-51 (>= 4:0.8-1~), libc6 (>= 2.15), libffi6 (>= 3.0.4), libgcc1 (>= 1:4.1.1), libgmp10, liblua5.1-0, libpng12-0 (>= 1.2.13-4), libqt4-network (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.2), libsdl-image1.2 (>= 1.2.10), libsdl-mixer1.2, libsdl-net1.2, libsdl-ttf2.0-0, libsdl1.2debian (>= 1.2.10-1), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.2.0), ttf-dejavu-core, ttf-wqy-zenhei, ffmpeg, freeglut3, hedgewars-data (>= 0.9.18)

Revision history for this message
Žygimantas Beručka (zygis) wrote :

I can confirm that installing freeglut3 solved the issue.

2013/5/1 Kamil Markiewicz <email address hidden>

> I don't exacly know for what this are used, I've get depslist from
> Ubuntu package from hedgewars.org.
>
> hedgewars_0.9.18-1~getdeb2_i386.deb contains:
> Depends: libavcodec53 (>= 4:0.8-1~) | libavcodec-extra-53 (>= 4:0.8-1~),
> libavformat53 (>= 4:0.8-1~) | libavformat-extra-53 (>= 4:0.8-1~),
> libavutil51 (>= 4:0.8-1~) | libavutil-extra-51 (>= 4:0.8-1~), libc6 (>=
> 2.15), libffi6 (>= 3.0.4), libgcc1 (>= 1:4.1.1), libgmp10, liblua5.1-0,
> libpng12-0 (>= 1.2.13-4), libqt4-network (>= 4:4.5.3), libqtcore4 (>=
> 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.2), libsdl-image1.2 (>= 1.2.10),
> libsdl-mixer1.2, libsdl-net1.2, libsdl-ttf2.0-0, libsdl1.2debian (>=
> 1.2.10-1), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.2.0), ttf-dejavu-core,
> ttf-wqy-zenhei, ffmpeg, freeglut3, hedgewars-data (>= 0.9.18)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1171825
>
> Title:
> Gameplay cannot start in Hedgewars 0.9.18-0.2ubuntu1
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/hedgewars/+bug/1171825/+subscriptions
>

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hedgewars - 0.9.18-0.3

---------------
hedgewars (0.9.18-0.3) experimental; urgency=low

  * Non-maintainer upload.

  [ Felix Geyer ]
  * Add missing dependency on freeglut3. (LP: #1171825)

  [ Colin Watson ]
  * Build-depend on ghc and libghc-* rather than the transitional ghc6 and
    libghc6-*. (Closes: #705125)

  [ Gianfranco Costamagna ]
  * Updated debian/rules file, the SERVER disable string has changed.

 -- Felix Geyer <email address hidden> Thu, 02 May 2013 17:55:31 +0200

Changed in hedgewars (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Felix Geyer (debfx)
description: updated
Revision history for this message
Felix Geyer (debfx) wrote :

Uploaded the same fix to raring-proposed, pending approval.

Changed in hedgewars (Ubuntu Raring):
status: New → In Progress
Revision history for this message
Scott Kitterman (kitterman) wrote : Please test proposed package

Hello Žygimantas, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in hedgewars (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Jonathan Riddell (jr) wrote :

The Blue Systems sprint has spent a lot of time confirming this fix allows you to again play the game

tags: added: verification-done
removed: verification-needed
Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hedgewars - 0.9.18-0.2ubuntu1.1

---------------
hedgewars (0.9.18-0.2ubuntu1.1) raring-proposed; urgency=low

  * Add missing dependency on freeglut3. It's needed to start playing a game.
    (LP: #1171825)
 -- Felix Geyer <email address hidden> Sat, 04 May 2013 10:39:24 +0200

Changed in hedgewars (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers