[FFe] Please sync heartbeat 1:3.0.2+hg12555-2 (universe) from debian (unstable)

Bug #562711 reported by Andres Rodriguez on 2010-04-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
heartbeat (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: heartbeat

Please sync heartbeat from debian unstable:

heartbeat (1:3.0.2+hg12555-2) unstable; urgency=low

  * Removed 01_docbook_path.dpatch from debian/patches as it's useless

 -- Martin Loschwitz <email address hidden> Tue, 30 Mar 2010 11:08:39 +0000

heartbeat (1:3.0.2+hg12555-1) unstable; urgency=low

  * New Mercurial checkout
  * Adopt patch by Florian Haas to delete libnet build dependency

 -- Martin Loschwitz <email address hidden> Tue, 30 Mar 2010 07:40:29 +0000

heartbeat (1:3.0.2+hg12547-2) unstable; urgency=low

  [ Martin Loschwitz ]
  * Re-add dh_installinit but delete heartbeat.init
  * Deleted some ancient files from debian-subdirectory

 -- Martin Loschwitz <email address hidden> Wed, 03 Mar 2010 08:49:00 +0100

heartbeat (1:3.0.2+hg12547-1) unstable; urgency=low

  [ Martin Loschwitz ]
  * Update to latest HG version
  * New copyright-file by Ante Karamatic
  * Use heartbeat standard init script instead of the old one

 -- Martin Loschwitz <email address hidden> Tue, 02 Mar 2010 17:11:00 +0100

heartbeat (1:3.0.2-2) UNRELEASED; urgency=low

  [ Simon Horman ]
  * Build-depend on libsensors4-dev | libsensors-dev.
  * remove ldconfig from heartbeat.{postrm,postinst}.

  [ Frederik Schüler ]
  * Add myself to uploaders.
  * Drop duplicate priority and section fields from debian/control.
  * Bump standards version to 3.8.4, no changes needed.
  * Switch to debhelper 7.
  * Switch to source version 3.0 "quilt", drop dpatch dependency.
  * Use dh_prep instead of dh_clean -k.
  * Depend on cluster-agents.

 -- Frederik Schüler <email address hidden> Fri, 26 Feb 2010 19:20:44 +0100

heartbeat (1:3.0.2-1) unstable; urgency=low

  * New upstream release.

 -- Martin Loschwitz <email address hidden> Wed, 03 Feb 2010 08:05:00 +0100

The Ubuntu Cluster Stack [1] packages have been updated with the latest versions. This new packages contain various fixes in both upstream and packaging that we need in Ubuntu. These packages contain some of the Ubuntu changes already, however, some others have not yet reached the packages but are in the debian-ha mercurial repositories.

Build logs:
http://launchpadlibrarian.net/44109664/buildlog_ubuntu-lucid-amd64.heartbeat_1:3.0.2%2Bhg12555-2ubuntu1_FULLYBUILT.txt.gz
http://launchpadlibrarian.net/44109672/buildlog_ubuntu-lucid-i386.heartbeat_1:3.0.2%2Bhg12555-2ubuntu1_FULLYBUILT.txt.gz

[1]: https://blueprints.launchpad.net/ubuntu/+spec/server-lucid-cluster-stack

Related branches

Changed in heartbeat (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
status: New → In Progress
importance: Undecided → Medium
Andres Rodriguez (andreserl) wrote :

This package has been tested and installs/upgrades correctly.

Changed in heartbeat (Ubuntu):
assignee: Andres Rodriguez (andreserl) → nobody
status: In Progress → New
summary: - [FFe] Please sync heartbeat from Ubuntu-HA PPA
+ [FFe] Please sync heartbeat from debian (unstable)
description: updated
summary: - [FFe] Please sync heartbeat from debian (unstable)
+ [FFe] Please sync heartbeat 1:3.0.2+hg12555-2 (universe) from debian
+ (unstable)
Scott Kitterman (kitterman) wrote :

Why is disabling fatal warnings OK/a good idea?

Changed in heartbeat (Ubuntu):
status: New → Incomplete
Andres Rodriguez (andreserl) wrote :

We are disabling fatal warnings because heartbeat wont build otherwise, so yes is a good idea to do so. See [1]. This delta is a change that we are keeping from the current heartbeat package in archive. I will be submitting this changes to debian anytime.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577550

Changed in heartbeat (Ubuntu):
status: Incomplete → New

Generally tests failing means you should fix the package. What testing has been done to make sure the package works despite the test failures?

Andres Rodriguez (andreserl) wrote :

I've just been pointed out by Debian maintainer and heartbeat upstream Martin Loschwitz - Madkiss, that this build error is a glib problem and does not have anything to do with the heartbeat package:

<Madkiss> RoAkSoAx: I know some details about it as LINBIT is heartbeat upstream. The problem is not in Heartbeat, it's in glib.
<Madkiss> RoAkSoAx: fixed in http://git.gnome.org/browse/glib/commit/?id=37dbc09080ac280ff7a552d03869c8afa745f15a and re-introduced in http://git.gnome.org/browse/glib/commit/?id=c8e37b63e74fafdc1f299ec139677ad0e37676c3 -- also see https://bugzilla.gnome.org/show_bug.cgi?id=457641

So, after talking to him. We are keeping fatal warnings disabled. :)

Scott Kitterman (kitterman) wrote :

OK. What testing has been done?

Andres Rodriguez (andreserl) wrote :

Install/upgrade and I configured a two node test cluster. Everything works as expected.

Andres Rodriguez (andreserl) wrote :

<ScottK> RoAkSoAx: I'm good for your 4 FFe requests now (just got back from a $WORK thing). Please just copy/paste this into the bugs and go ahead.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heartbeat - 1:3.0.2+hg12555-2ubuntu1

---------------
heartbeat (1:3.0.2+hg12555-2ubuntu1) lucid; urgency=low

  * Sync from debian unstable (LP: #562711).
  * debian/control: Remove duplicated uuid-dev Build-Depends.
  * debian/rules: Add '--disable-fatal-warnings' to configure.
 -- Andres Rodriguez <email address hidden> Wed, 14 Apr 2010 00:21:06 -0400

Changed in heartbeat (Ubuntu):
status: New → Fix Released
mgiammarco (mgiammarco) wrote :

Yesterday heartbeat maintainer has added to heartbeat the script to start sbd daemon at boot. This script is needed to use external/sbd fencing.

Please add to ubuntu package.

mgiammarco (mgiammarco) wrote :

Please also note that also corosync needs the sbd start script.

Andres Rodriguez (andreserl) wrote :

Hi mgiammarco,

Unfortunately, we are syncing this package from debian and not from upstream. However changes are made in upstream, will first hit debian and them we will sync/merge. However, since we are almost to the end of the release cycle, we are not gonna make any other uploads to this packages unless its for serious bugfixes.

On the other hand, we are going to keep updated packages in the ubuntu-ha-maintainers PPA, and backport some whenever we feel they are good enough. Please, if you wish to have the latest packages as they become available in debian, please feel free to use the PPA. However, they are not available just yet.

Cheers,

mgiammarco (mgiammarco) wrote :

If you ask pacemaker devel they will say that fencing devices are mandatory for pacemaker/corosync/heartbeat real world use. So a missing external/sbd fencing device start script is critical if you want a production quality pacemaker for ubuntu server 10.04.

In linux-ha irc they asked me to let you know this problem. I have done it. I can use ppa but is ubuntu 10.04 stable that people will use.

Thanks,

Mario

Scott Kitterman (kitterman) wrote :

Please file a new bug about this. This bug is done.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.