Heartbeat not configured: /etc/ha.d/ha.cf not found. Heartbeat failure [rc=1]. Failed.

Bug #54782 reported by boricua on 2006-08-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
heartbeat (Debian)
Fix Released
Unknown
heartbeat (Ubuntu)
Undecided
Unassigned
Nominated for Edgy by Kai Kasurinen

Bug Description

Binary package hint: heartbeat

Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
  heartbeat
0 upgraded, 1 newly installed, 0 to remove and 19 not upgraded.
Need to get 0B/487kB of archives.
After unpacking 1638kB of additional disk space will be used.
Selecting previously deselected package heartbeat.
(Reading database ... 96469 files and directories currently installed.)
Unpacking heartbeat (from .../heartbeat_1.2.4-2ubuntu0.1_i386.deb) ...
Setting up heartbeat (1.2.4-2ubuntu0.1) ...
Heartbeat not configured: /etc/ha.d/ha.cf not found.
 Heartbeat failure [rc=1]. Failed.

Brandon Holtsclaw (imbrandon) wrote :

confirmed in a clean dapper chroot ( pbuilder login ) same output as original poster

Changed in heartbeat:
status: Unconfirmed → Confirmed
Kai Kasurinen (kai-kasurinen) wrote :

Thanks for the bug report.

I'm closing this bug because it has been fixed in Feisty.

 heartbeat (1.2.4-5) unstable; urgency=low
 .
   * Don't try and stop heartbeat in preinst on the first install
     (closes: #355806)

Changed in heartbeat:
status: Confirmed → Fix Released
Changed in heartbeat:
status: Unknown → Fix Released
Björn Felten (bjorn-felten) wrote :

Isn't Feisty unstable/experimental?

I suggest you fix the bug in the latest stable dist, Edgy, as well.

Kai Kasurinen (kai-kasurinen) wrote :

(Ups) Fixed in Edgy. There is heartbeat 1.2.4-14build1 in Edgy (>=1.2.4-5).

Björn Felten (bjorn-felten) wrote :

Aptitude doesn´t seem to agree. This is what I get with an 'aptitude reinstall'. Sorry for the Swedish, but I hope you get the picture just the same.

Läser paketlistor...
Bygger beroendeträd...
Läser in tillståndsinformation...
Initierar pakettillstånd...
Bygger taggdatabas...
Följande paket kommer att bli OMINSTALLERADE:
  heartbeat
0 paket uppgraderade, 0 nyinstallerade. 1 ominstallerade, 0 att ta bort och 0 inte uppgraderade.
Behöver hämta 0B/489kB arkiv. Efter uppackning kommer 0B diskplats att användas.
Skriver utökad tillståndsinformation...
(Läser databasen ... 84693 filer och kataloger installerade.)
Förbereder att ersätta heartbeat 1.2.4-14build1 (med .../heartbeat_1.2.4-14build1_i386.deb) ...
Heartbeat not configured: /etc/ha.d/ha.cf not found.
 Heartbeat failure [rc=1]. Failed.
Packar upp ersättande heartbeat ...
Ställer in heartbeat (1.2.4-14build1) ...
Heartbeat not configured: /etc/ha.d/ha.cf not found.
 Heartbeat failure [rc=1]. Failed.

Kai Kasurinen (kai-kasurinen) wrote :

(reopen) ominstallerade == reinstalled? Does pre- or postinstall fail? Or are those messages just only warnings? I can't reproduce this in Edgy chroot.

Changed in heartbeat:
status: Fix Released → Needs Info
Kai Kasurinen (kai-kasurinen) wrote :

Those messages are just warnings (coming from init-script) and are informational message stating that you have to do something.

# /etc/init.d/heartbeat start
Heartbeat not configured: /etc/ha.d/ha.cf not found.
 Heartbeat failure [rc=1]. Failed.

/etc/ha.d/README.config says:
"You need three configuration files to make heartbeat happy,
and they all go in this directory."

Björn Felten (bjorn-felten) wrote :

Yes, 'ominstallerade' means reinstalled -- as in 'aptitude reinstall' . :)

And yes, they are only warning messages, but they warn me that Hearbeat did not start (or rather they did in previous dists). And since evmsn/evmsgui gives me an error #19 on setup_evms_plugin() in Linux_HA, I assume that EVMS does not work properly, but maybe I'm wrong?

Most other packages install default configs, or assist in making them, so that the program will at least start properly, shouldn't Heartbeat do that too? I've tried to copy the files mentioned in the README to /etc/ha.d/, but no go; then I get all kinds of other errors/warnings.

Have you tried a live install in order to try to reproduce the error?

Kai Kasurinen (kai-kasurinen) wrote :

Thanks for your comments. This does not appear to be a bug report as such. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. <http://launchpad.net/support>

"As heartbeat is not controlled by debconf (yet) it will
not start until you configure it. Sample configurations
are available in /usr/share/doc/heartbeat" [1]

"For more info on Linux-HA, I recommend you read the Linux-HA web page.
It can be found at:
        http://linux-ha.org/" [2]

[1] <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=313356>
[2] /usr/share/doc/heartbeat/README
[3] <http://linux-ha.org/ConfiguringHeartbeat>

Changed in heartbeat:
status: Needs Info → Rejected
boricua (boricua) wrote :

says who?
this bug is very well alive.... fixed right please and stop dancing around

Get:3 http://archive.ubuntu.com edgy/main libstonith0 1.2.4-14build1 [91.0kB]
Get:4 http://archive.ubuntu.com edgy/main heartbeat 1.2.4-14build1 [489kB]
Fetched 679kB in 1s (367kB/s)
Selecting previously deselected package libnet1.
(Reading database ... 128981 files and directories currently installed.)
Unpacking libnet1 (from .../libnet1_1.1.2.1-2_i386.deb) ...
Selecting previously deselected package libpils0.
Unpacking libpils0 (from .../libpils0_1.2.4-14build1_i386.deb) ...
Selecting previously deselected package libstonith0.
Unpacking libstonith0 (from .../libstonith0_1.2.4-14build1_i386.deb) ...
Selecting previously deselected package heartbeat.
Unpacking heartbeat (from .../heartbeat_1.2.4-14build1_i386.deb) ...
Setting up libnet1 (1.1.2.1-2) ...

Setting up libpils0 (1.2.4-14build1) ...

Setting up libstonith0 (1.2.4-14build1) ...

Setting up heartbeat (1.2.4-14build1) ...
Heartbeat not configured: /etc/ha.d/ha.cf not found.
 Heartbeat failure [rc=1]. Failed.

boricua (boricua) wrote :

fails on both server and laptop

0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
Need to get 489kB of archives.
After unpacking 1630kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com edgy/main heartbeat 1.2.4-14build1 [489kB]
Fetched 489kB in 10s (46.8kB/s)
Selecting previously deselected package heartbeat.
(Reading database ... 127274 files and directories currently installed.)
Unpacking heartbeat (from .../heartbeat_1.2.4-14build1_i386.deb) ...
Setting up heartbeat (1.2.4-14build1) ...
Installing new version of config file /etc/ha.d/resource.d/portblock ...
Heartbeat not configured: /etc/ha.d/ha.cf not found.
 Heartbeat failure [rc=1]. Failed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.