ImportError: No module named xmlproc.xmldtd

Bug #306185 reported by Laurent Bigonville on 2008-12-08
10
Affects Status Importance Assigned to Milestone
heartbeat (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: heartbeat

hb_gui doesn't start anymore in jaunty

Traceback (most recent call last):
  File "/usr/bin/hb_gui", line 30, in <module>
    from xml.parsers.xmlproc.xmldtd import load_dtd_string
ImportError: No module named xmlproc.xmldtd

Changed in heartbeat:
importance: Undecided → Medium
Laurent Bigonville (bigon) wrote :

python-xml issue

Changed in heartbeat:
status: New → Invalid
Laurent Bigonville (bigon) wrote :

reopening

Changed in heartbeat:
status: Invalid → New
Chuck Short (zulcss) wrote :

I was able to reproduce this.

Changed in heartbeat:
status: New → Confirmed
James Hogarth (james-hogarth) wrote :

Same - reproducible on an up to date system as of this message in jaunty....

Tracking it down there appears to be a search path issue for the module...

Following the instructions for freevo here:

http://ubuntuforums.org/archive/index.php/t-731013.html

Which had a similar issue results in a working system...

Specifically:

cd /usr/lib/python2.5/site-packages/
sudo ln -s oldxml/_xmlplus/

So this is probably a python-xml issue (and other modules that now install in oldxml/_xmlplus will probably be the same) where either the sys.path default path needs fixing or this symlink in place by default.

After putting the symlink in place I was able to use hb_gui as per intrepid - at least from initial testing.

James Hogarth (james-hogarth) wrote :

Hmm according to the last notes in python-xml:

python-xml (0.8.4-10.1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #????)
    - Explicitely remove /usr/lib/python2.[345]/site-packages/_xmlplus,
      likely be left by an earlier python-central version. LP: #212917.
    - Install the files outside of sys.path, so that the package
      does not overlay the xml code as found in the core python packages.
      This package should be removed once all rdepends are gone. For
      now, packages have to add this path before the first xml import:
      sys.path.append('/usr/lib/python%s/site-packages/oldxml' %
      sys.version[:3])

Has anyone been able to get this running using the core xml and skipping python-xml?

Meantime it would be sensible to patch this to include the sys.path.append where appropriate at the start.

Seems to me like it's starting again properly. I see an updated version of python-xml in the repos, and hb_gui is starting just fine for me...

Andres Rodriguez (andreserl) wrote :

Thank you for reporting bugs and trying to make Ubuntu better!

Given that Ubuntu Jaunty 9.04 has hit it's End of Life (EOL), I'm closing this bug report. For more information about the EOL please refer to [1].

[1]: https://wiki.ubuntu.com/Releases

Changed in heartbeat (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions