Ubuntu

udev 60-persistent-storage.rules vol_id cancels hdd spin-down

Reported by phoenix on 2009-06-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hdparm (Ubuntu)
Undecided
Unassigned
udev (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: udev

My secondary hdd (not mounted) did not go into standby and spun up again right after a "hdparm -y /dev/sdb" command.

the cause is /lib/udev/vol_id beeing executed on a change action caused by this rule in /lib/udev/rules.d/60-persistent-storage.rules:

# probe filesystem metadata of disks
KERNEL!="sr*", IMPORT{program}="vol_id --export $tempnode"

which causes an access to the hdd _after_ a spin-down event -> hdd spins up again
(My hdd model: SAMSUNG HD103UJ (Spinpoint F1, 1TB))

quick fix for me:
KERNEL!="sr*", ACTION=="add", IMPORT{program}="vol_id --export $tempnode"

This is not a duplicate, but is a known bug caused by hdparm opening the block device for writing; it is not clear that it needs to do so.

Changed in udev (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
jpkotta (jpkotta) wrote :

Indeed, hdparm does not need to open the file RW. I have only tested RO hdparm with -t, -T, -y, -Y, -i, -I, and -C, and not very thoroughly.

jpkotta (jpkotta) wrote :

hdparm-9.15 fixes this issue (it opens the file RO).

Great, looks like 9.15 is in karmic already

Changed in udev (Ubuntu):
status: Triaged → Invalid
Changed in hdparm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers