udev rules only for hd[a-z], not sd[a-z]

Bug #156893 reported by Daniel Hahler on 2007-10-25
34
Affects Status Importance Assigned to Milestone
hdparm (Debian)
Fix Released
Unknown
hdparm (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: hdparm

/etc/udev/rules.d/85-hdparm.rules only seems to handle hd devices, but not sd ones, e.g. sata.

Is the following patch sane?

diff -u hdparm-7.5/debian/hdparm.rules hdparm-7.5/debian/hdparm.rules
--- hdparm-7.5/debian/hdparm.rules
+++ hdparm-7.5/debian/hdparm.rules
@@ -1,2 +1,2 @@
-ACTION=="add", SUBSYSTEM=="block", KERNEL=="hd[a-z]", \
+ACTION=="add", SUBSYSTEM=="block", KERNEL=="[hs]d[a-z]", \
        RUN+="/lib/udev/hdparm"

Related branches

Artyom Pervukhin (logus) wrote :

I confirm that on Hardy alpha 6 (03/17/2008). Settings in /etc/hdparm.conf ignored for my sata drive, /lib/udev/hdparm doesn't even start without this patch.

Artyom Pervukhin (logus) on 2008-03-17
Changed in hdparm:
status: New → Confirmed
Artyom Pervukhin (logus) wrote :

Just submitting Daniel Hahler's patch as attach/patch.

Daniel Hahler (blueyed) wrote :

Marking "High", because "SATA" is quite common these days.

Changed in hdparm:
importance: Undecided → High
status: Confirmed → Triaged
Daniel Hahler (blueyed) wrote :

Providing proper Debdiff and subscribed u-m-s.

Changed in hdparm:
status: Unknown → Fix Released
Jakob Unterwurzacher (jakobunt) wrote :

The patch restores the APM level after suspend/resume, addressing bug 199094 (which is important for bug 59695 ).

The hdparm -I output is still different though after suspend/resume (cold booted before). But that's 1) probably irrelevant 2) a different problem. But still, here is the diff:

diff hdparm-I_before.txt hdparm-I_after.txt
26c26
< R/W multiple sector transfer: Max = 16 Current = 16
---
> R/W multiple sector transfer: Max = 16 Current = 0
48c48
< * SET_MAX security extension
---
> SET_MAX security extension
71c71
< frozen
---
> not frozen

Daniel Hahler (blueyed) wrote :

I think this fix should get added for the beta release.

btw: this would also get fixed by merging hdparm from Debian. Debdiff and request for FeatureFreeze exception are provided at bug 203736.

Changed in hdparm:
milestone: none → ubuntu-8.04-beta
Colin Watson (cjwatson) wrote :

This is going to have to be for final now, and isn't beta-critical.

Changed in hdparm:
milestone: ubuntu-8.04-beta → ubuntu-8.04
James Westby (james-w) wrote :

Hi,

Just to update the status of this bug:

The bug 203736 FFe has been acked and is just waiting for
u-m-s to upload the change, which will then solve this
bug.

Should this bug be marked a duplicate of that one so
that we don't need to track this one separately? Would
that break the milestone tracking for this one?

Thanks,

James

Steve Langasek (vorlon) wrote :

Marking this as a duplicate would break milestone tracking, yes. Please track this bug separately - given that 203736 is a merge, it should be straightforward to mark this bug as fixed in the changelog.

Daniel Hahler (blueyed) wrote :

Done.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hdparm - 8.6-1ubuntu1

---------------
hdparm (8.6-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable (LP: #203736). Remaining Ubuntu changes:
    - remove init script, install udev rules instead
    - set Ubuntu maintainer address.
    - debian/control: Do not depend on lsb-base
  * Fixes "udev rules only for hd[a-z], not sd[a-z]" (LP: #156893)
  * Remove hdparm init script and make it not re-appear in next merges
    - debian/rules: add "--onlyscripts" to DEB_DH_INSTALLINIT_ARGS, so that the
      init script does not get installed
    - debian/preinst: bump version in rm_conffile call

hdparm (8.6-1) unstable; urgency=low

  * New upstream version
  * Udev rule can also match for sata devices (closes: #471401)

hdparm (8.3-1) unstable; urgency=low

  * New upstream release
  * easier config of spindown time (closes: #462766)
  * Update Standards-Version (no changes)

 -- Daniel Hahler <email address hidden> Fri, 28 Mar 2008 21:44:38 +0100

Changed in hdparm:
status: Triaged → Fix Released
Mosab (mosabama-hotmail) on 2010-03-29
Changed in hdparm (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.