time-controlled spindown with hdparm

Bug #1073137 reported by igelhorst5000 on 2012-10-30
88
This bug affects 15 people
Affects Status Importance Assigned to Milestone
hdparm (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using a fresh Xubuntu 12.10 AMD64 on Lenovo Thinkpad with HDD in Ultrabay. The Ultrabay drive should spindown with hdparm. But in cas of using "hdparm -S" it doesn't work. Only the manual way with "hdparm -y" works.
In Xubuntu 12.04 works correctly and some users can confirm that it works with Ubuntu 12.10.

look here:
http://forum.ubuntuusers.de/topic/kein-standby-der-festplatte-mit-hdparm-oder-tl/

thanks!

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1073137/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
igelhorst5000 (rkaiser) wrote :

I don't know which package is the problem. On Ubuntu 12.10 it works on Xubuntu 12.10 it doesn't work!

affects: ubuntu → hdparm (Ubuntu)
Ismo Puustinen (ismo-puustinen) wrote :

I have the same problem, except that I'm running Ubuntu 12.10. The disk in question is Hitachi HDT721010SLA360 connected to ASUS P8H77-I motherboard. The disk goes to standby with hdparm -y , but hdparm -S 1 (or any other number I tried) has no effect. I have a feeling that this might be related to having the system configured in BIOS to AHCI mode instead of PATA, but I haven't examined that further.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hdparm (Ubuntu):
status: New → Confirmed
Rafał Ochmański (rmopl) wrote :
igelhorst5000 (rkaiser) wrote :

I think it is an other bug.
If the hdd is spindown manually, then start the hdd only by user-access.

Jens (c-jens) wrote :

I can confirm that!
On Xubuntu 12.04 hdparm time spindown was working but after the distributions update to xubuntu 12.10 no longer works.
hdparm -y /dev/sdx is still working. Than the hd only wake up when an user have access to the hd.

phoenix (phoenix-jobob) wrote :

confirmed regression after upgrading regular ubuntu to 12.10 (worked on 12.04 and earlier versions).
2TB WD Green (WDC_WD20EARS, different revisions) are affected.
An older 1TB Samsung F1 still spin's down by itself (only with additional -B 127 adjustment, like already in 12.04)

Marc Fasel (m-fasel) wrote :

confirmed.

WDC_WD20EARS also doesnt spindown here. Ubuntu 12.10 Server Edition

Peter (peterastre007) wrote :

same here with a Western Digital D2502ABYS-01B7A0 either in desktop and server edition of Ubuntu 12.10.

hdparm -y and hdparm -S 12 on the command line spins down the drive, but the entry in hdpram.conf does not. The entry is

/dev/disk/by-uuid/222C6A972C6A65AF {
        spindown_time = 12
}

Peter (peterastre007) wrote :

...sorry, of course I meant the entry in hdparm.conf (just a literal)

John Littleton (jelittleton) wrote :

I can confirm the same behavior for Ubuntu 12.10 AMD64 on an ASUS P8B75-V. My boot drive, sda, is an ssd.

The four mechanical drives run through a single pci/IDE interface.

 sda: OCZ-VERTEX4 (1.5) (ssd, not an issue)
 sdb: Seagate ST380011A
 sdc: Maxtor 6L020L1
 sdd: Maxtor 6E020L0
 sde: Hitachi HDS724040KLAT80

All mechanical drives spindown 60 seconds after signon, as configured in the 'Disks' gui (ver 3.6.1).
All mechanical drives reliably respond to 'sudo hdparm -S 12 /dev/sdb' (as do sdc,sdd,and sde).
All mechanical drives remain asleep until user or program access.

When NOT configured to spindown in 'Disks', all mechanical drives do not recognize/respond to commands in /etc/hdparm.conf:

 /dev/sdb {spindown_time=12}
 /dev/sdc {spindown_time=12}
 /dev/sdd {spindown_time=12}
 /dev/sde {spindown_time=12}

Also, after a suspend/resume powerdown, all mechanical drives no longer spindown again unless commanded to in terminal or the 'Disks' gui.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions