Haxelib error "Uncaught Exception" and cannot run

Bug #1251221 reported by Hai Phaikawl on 2013-11-14
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
haxe (Ubuntu)
Undecided
Andy Li

Bug Description

I installed haxe on ubuntu 13.10 (sudo apt-get install haxe).
When I try to run haxelib, it errors out with the message
"Called from [./haxe/std/neko/_std/Array.hx,247]
Called from 2372768
Uncaught exception - Invalid array access" and it just couldn't run.
Tried removing, reinstalling haxe and neko but no luck.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: haxe (not installed)
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic i686
ApportVersion: 2.12.5-0ubuntu2
Architecture: i386
Date: Thu Nov 14 19:21:27 2013
InstallationDate: Installed on 2013-11-14 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MarkForUpload: True
SourcePackage: haxe
UpgradeStatus: No upgrade log present (probably fresh install)

Hai Phaikawl (phaikawl) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in haxe (Ubuntu):
status: New → Confirmed
olivm (matheret) wrote :

Seen also on a binary that works perfectly on a Windows environment.
The error appears as soon as I use haxe.Resource or sys.db.Manager

Andy Li (onthewings) wrote :

This is a bug in the neko JIT, which is enabled only on i386.
The bug has been fixed upstream already, see https://github.com/HaxeFoundation/neko/commit/ccc78c29deab7971e1369f4fe3dedd14cf9f3128.

I've updated the debian neko package to include the upstream fix.
The version of the updated package is 2.0.0-4.
Both neko and libneko0 should be upgraded to get this fix. They can be found at:
 * https://packages.debian.org/sid/neko
 * https://packages.debian.org/sid/libneko0
Just download and install the i386 deb files of both packages.

Changed in haxe (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Andy Li (onthewings)
Andy Li (onthewings) wrote :

Xenial ships with neko 2.0.0-4, which contains the required fix.
Users of earlier Ubuntu versions may use Haxe Foundation's PPA: https://launchpad.net/~haxe/+archive/ubuntu/releases

Changed in haxe (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments