Ubuntu

Broken Haskell Platform in 11.04 Depends: ghc6 (< 6.12.1+)

Reported by Gatlin Johnson on 2011-03-24
380
This bug affects 72 people
Affects Status Importance Assigned to Milestone
haskell-platform (Ubuntu)
Medium
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: haskell-platform

I am running Narwhal and as of now, attempting to install the haskell-platform package yields the following:

The following packages have unmet dependencies:
 haskell-platform : Depends: ghc6 (< 6.12.1+) but 6.12.3-1ubuntu6 is to be installed
E: Broken packages

Encountered this bug while trying to install packages for xmonad. Please fix.

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue!

I get the same error message when attempting to install haskell-platform on Ubuntu Natty.

Changed in haskell-platform (Ubuntu):
status: New → Confirmed
tags: added: unmetdeps
description: updated
rylklee (rylklee) wrote :

Same issue when trying to install haskell-platform on 11.04 Beta

Yrogirg (sargrigory) wrote :

still broken, I guess I'm on beta2, updated.

Johan Van den Neste (jvdneste) wrote :

Also, the latest version is haskell-platform-2011.2.0.1 and is based on ghc7

Johan: The update is covered in bug 711366.

summary: - Broken package in 11.04
+ Broken package in 11.04 Depends: ghc6 (< 6.12.1+)
Marcus Sundman (sundman) wrote :

Well, we certainly need some working version of haskell-platform in natty. Of course 2011.x would be nice (GHC7 has been in debian since January), but I guess that will only show up in natty-backports. We still need a working version in non-backport-natty as well, though, so we can't wait for #711366 if that would mean waiting for half a year.

Changed in haskell-platform (Ubuntu):
milestone: none → natty-updates
summary: - Broken package in 11.04 Depends: ghc6 (< 6.12.1+)
+ Broken Haskell Platform in 11.04 Depends: ghc6 (< 6.12.1+)

This bug is still present in the final version of natty:

haskell-platform : Depends: ghc6 (< 6.12.1+) but 6.12.3-1ubuntu7 is to be installed

sajith (sajith.sasidharan) wrote :

Why would haskell-platform depend on ghc6 (>= 6.12.1) as well as ghc6 (<< 6.12.1+)?

bartek (equinxp) wrote :

please fix it immediately

Philip Muškovac (yofel) on 2011-05-14
Changed in haskell-platform (Ubuntu):
importance: Undecided → Medium
tags: added: natty
Egor Tensin (egor-tensin) wrote :

Wouldn't be setting haskell-platform dependency to a proper version of GHC an obvious fix? At least, just to allow users to get their haskell-platform installed properly. I mean, it's been more than a month. Have any unexpected difficulties arisen while fixing this annoying dependency bug?

Jaime Chen (chenz) wrote :

Workaround: use vi edit the file /var/cache/apt/pkgcache.bin, find the string ' 6.12.1+' and change it to ' 6.12.4+', save

'sudo apt-get install haskell-platform' will still fail while calling some post-install-script, but it seems that haskell-platform is usable now.

Changed in haskell-platform (Ubuntu):
assignee: nobody → laozhen.s@gmail.com (laozhen-s)
assignee: laozhen.s@gmail.com (laozhen-s) → nobody
Levi Campbell (levicc00123) wrote :

I'm not that familiar with building packages, but from looking at the control file, it looks like a simple issue to fix and I've attached a patch. Please test and let me know if it works. Thank you.

tags: added: patch
Filip Brcic (brcha) wrote :

I downloaded haskell-platform 2010.2.0.0 and changed the debian's package so that the packages versions match the versions distributed with that version of haskell-platform. Newer versions require ghc7 which is not in ubuntu (it is in debian unstable, so their haskell-platform package is newer, but unapplicable to ubuntu).

You can download it from my PPA:

https://launchpad.net/~brcha/+archive/ppa

Paweł Prażak (pawel-prazak) wrote :

The bug is still there, why it takes so long to fix this? It's not funny, some people actually _need_ haskell. Please fix it.

palmeira (ruipalmeira) wrote :

thanks for the ppa @Filip Brcic ...

Natty is available for like 2/3 months and this wasn't yet updated :|

kemiisto (kemiisto) wrote :

Recent Haskell Platform (2011.2.0.1) with GHC 7 is available in Debian Wheezy. http://packages.debian.org/testing/haskell/haskell-platform

Yes, and it’s also available in Ubuntu oneiric; that was bug 711366, not this bug. This bug is about the uninstallable package in natty.

kemiisto (kemiisto) wrote :

@Anders Kaseorg: so, why not to fix it in natty?

Ben Kraft (benjaminjkraft) wrote :

I'd like to +1 the need for a natty backport or some such.

nh2 (nh2) wrote :

This looks like a simple fix. Why isn't it applied yet?

Iain Lane (laney) wrote :

I uploaded a fixed package which just removes the version restriction on ghc6 completely. Sorry for the inconvenience.

To test:

 1) Verify the natty haskell-platform package does not install
 2) Verify the natty-proposed one does

No risk of regressions; this is only a meta package.

Changed in haskell-platform (Ubuntu):
status: Confirmed → Fix Released
Changed in haskell-platform (Ubuntu Natty):
status: New → Confirmed
Iain Lane (laney) wrote :

Oh, and the _darcs stuff in the diff shouldn't have been there in the first place. It's irrelevant. Please ignore it. :-)

nh2 (nh2) wrote :

Can't find it in natty-proposed - should it show up on https://launchpad.net/ubuntu/+source/haskell-platform or am I doing something wrong?

On Sun, Jul 31, 2011 at 08:44:24PM -0000, nh2 wrote:
> Can't find it in natty-proposed - should it show up on
> https://launchpad.net/ubuntu/+source/haskell-platform or am I doing
> something wrong?

It isn't accepted yet. Someone will announce on this bug when it is.

nh2 (nh2) wrote :

All right, thanks!

Hello Gatlin, or anyone else affected,

Accepted haskell-platform into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in haskell-platform (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Eugene Crosser (crosser) wrote :

I confirm that the version from -proposed installs all right.

ogunden (ogunden) wrote :

Me too! I got it installed and fired up ghci with the -proposed version.

tags: added: verification-done
removed: verification-needed
Leonid Podolny (leonidp-lists) wrote :

So, what now? When will it make its way from the proposed to an ordinary repository?

Iain Lane (laney) wrote :

yes, next time someone looks at the pending updates, it will be copied into natty-updates, which is enabled by default.

Martin Pitt (pitti) wrote :

Copied to -updates. This fell off the radar, and wasn't auto-closed, as apparently the sources.changes was misbuilt (missing the Launchpad-Fixes header)

Changed in haskell-platform (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions