Ubuntu

xemacs21 compilation fails: 'Wrong number of arguments: require, 3'; 'Invalid read syntax: "#"'

Reported by Yrogirg on 2011-08-14
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
haskell-mode (Debian)
Fix Released
Unknown
haskell-mode (Ubuntu)
Undecided
Unassigned

Bug Description

I was just installing xemacs from synaptic and got the error message.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: xemacs21-mule 21.4.22-3.1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Aug 14 10:21:49 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
SourcePackage: xemacs21
Title: package xemacs21-mule 21.4.22-3.1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Yrogirg (sargrigory) wrote :
era (era) wrote :
Download full text (3.2 KiB)

The error appears to be in the package haskell-mode. Reassigning.

Quoting the attached DpkgTerminalLog.txt:
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-c.el...
> #<compiled-function nil "...(4)" [values t] 2>
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haskell-mode/haskell-c.el:
> !! Invalid read syntax (("#"))
> >>Error occurred processing haskell-c.el:
> Invalid read syntax: "#"
>
>
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-cabal.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-cabal.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-decl-scan.el...
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haskell-mode/haskell-decl-scan.el:
> !! Wrong number of arguments ((require 3))
> >>Error occurred processing haskell-decl-scan.el:
> Wrong number of arguments: require, 3
>
>
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-doc.el...
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haskell-mode/haskell-doc.el:
> !! Wrong number of arguments ((require 3))
> >>Error occurred processing haskell-doc.el:
> Wrong number of arguments: require, 3
>
>
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-font-lock.el...
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haskell-mode/haskell-font-lock.el:
> !! Invalid read syntax (("#"))
> >>Error occurred processing haskell-font-lock.el:
> Invalid read syntax: "#"
>
>
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-ghci.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-ghci.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-hugs.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-hugs.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-indent.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-indent.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-indentation.el...
> While compiling toplevel forms in file /usr/share/xemacs21/site-lisp/haskell-mode/haskell-indentation.el:
> !! Wrong number of arguments ((require 3))
> >>Error occurred processing haskell-indentation.el:
> Wrong number of arguments: require, 3
>
>
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-mode.el...
> #<compiled-function nil "...(3)" [t] 2>
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-mode.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-simple-indent.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-simple-indent.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/haskell-site-file.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/haskell-site-file.elc
> Compiling /usr/share/xemacs21/site-lisp/haskell-mode/inf-haskell.el...
> Wrote /usr/share/xemacs21/site-lisp/haskell-mode/inf-haskell.elc
> Done
> emacs-install: /usr/lib/emacsen-common/packages/install/haskell-mode xemacs21 emacs-snapshot emacs23 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 7.
> dpkg: error processing xemacs21-mu...

Read more...

affects: xemacs21 (Ubuntu) → haskell-mode (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in haskell-mode (Ubuntu):
status: New → Confirmed
era (era) on 2011-09-30
summary: - package xemacs21-mule 21.4.22-3.1ubuntu1 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 1
+ Emacs compilation fails: 'Wrong number of arguments: require, 3';
+ 'Invalid read syntax: "#"'
summary: - Emacs compilation fails: 'Wrong number of arguments: require, 3';
+ xemacs21 compilation fails: 'Wrong number of arguments: require, 3';
'Invalid read syntax: "#"'
Changed in haskell-mode (Debian):
status: Unknown → Fix Released
Iain Lane (laney) wrote :

This should be fixed in Oneiric and greater. Thanks for the report :-).

Changed in haskell-mode (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.