Ubuntu

haskell-gtk fails to build against glib 2.32

Reported by Anders Kaseorg on 2012-06-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
haskell-gtk (Debian)
Fix Released
Unknown
haskell-gtk (Ubuntu)
Undecided
Unassigned

Bug Description

https://launchpadlibrarian.net/106054714/buildlog_ubuntu-quantal-i386.haskell-gtk_0.12.3-1_FAILEDTOBUILD.txt.gz

In file included from Graphics/UI/Gtk/General/hsgthread.c:29:0:

/usr/include/glib-2.0/glib/gthread.h:28:2:
     error: #error "Only <glib.h> can be included directly."
Graphics/UI/Gtk/General/hsgthread.c: In function 'gtk2hs_threads_initialise':

Graphics/UI/Gtk/General/hsgthread.c:64:5:
     warning: 'g_static_mutex_init' is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:145): Use 'g_mutex_init' instead [-Wdeprecated-declarations]

Graphics/UI/Gtk/General/hsgthread.c:66:5:
     warning: 'g_thread_init' is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:259) [-Wdeprecated-declarations]
make: *** [build-ghc-stamp] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Changed in haskell-gtk (Debian):
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in haskell-gtk (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2012-07-16
tags: added: ftbfs
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package haskell-gtk - 0.12.3-1ubuntu1

---------------
haskell-gtk (0.12.3-1ubuntu1) quantal; urgency=low

  * debian/patches/glib-single-include.patch:
    - Fix FTBFS with glib 2.32 (LP: #1014932)
 -- Jeremy Bicha <email address hidden> Mon, 16 Jul 2012 22:18:28 -0400

Changed in haskell-gtk (Ubuntu):
status: Confirmed → Fix Released
Changed in haskell-gtk (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.