Dependencies are broken

Bug #231099 reported by danieroux on 2008-05-16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
haskell-cabal (Ubuntu)

Bug Description

Binary package hint: libghc6-cabal-dev

The dependencies for this package are:

Depends: ghc6 (>= 6.6.1), ghc6 (<< 6.6.1+)

Confirmed by

Trying to install it gives this error:

The following packages have unmet dependencies:
  libghc6-cabal-dev: Depends: ghc6 (< 6.6.1+) but 6.8.2-2ubuntu1 is installed.

Ralph Janke (txwikinger) wrote :

I can confirm this problem

Changed in haskell-cabal:
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → In Progress
assignee: nobody → txwikinger
Ralph Janke (txwikinger) on 2008-05-18
Changed in haskell-cabal:
assignee: txwikinger → nobody
status: In Progress → Triaged
gwern (gwern0) wrote :

This cabal package should probably just be updated entirely. Cabal 1.1.3 is old, very old. To give you an idea, Hackage doesn't even have a version that old ( So this package should be updated to 1.1.6, 1.2.1,,, and soon enough 1.4 will be released.

It's particularly important that we get up to 1.2 at least, since that introduced the Flag configuration syntax which Haskell packages are increasingly commonly using.

Peter Berry (pwberry) wrote :

Importance should be 'high' since it makes the package unusable, right??

Peter Berry (pwberry) wrote :

Actually ghc seems to be bundled with Cabal 1.2.3 so probably this package is just redundant and should be removed.

gwern (gwern0) wrote :

Peter: I didn't want to be presumptuous, since it was possible that this was deliberate (I know the situation with Cabal can be confusing, sometimes it's included in GHC, sometimes it's not, sometimes it's not but this leads to bugs later on, and so on).

Offhand, I don't think it's entirely redundant, as I think you're supposed to be able to upgrade Cabal separately from GHC. I still have GHC 6.8.2 from Ubuntu, but locally I have 4 or 5 Cabals of different versions - this doesn't usually cause a problem like with the Bytestring upgrades/diamond dependency problem.

Zooko Wilcox-O'Hearn (zooko) wrote :

I get this on Hardy:

$ sudo apt-get install libghc6-cabal-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libghc6-cabal-dev: Depends: ghc6 (< 6.6.1+) but 6.8.2-2ubuntu1 is to be installed
E: Broken packages

old and fixed years ago

Changed in haskell-cabal (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for haskell-cabal (Ubuntu) because there has been no activity for 60 days.]

Changed in haskell-cabal (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers