Please update harpia to the latest version 1.1

Bug #579747 reported by Bhavani Shankar on 2010-05-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
harpia (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Clovis Peruchi Scotti

Bug Description

Binary package hint: harpia

please update the package to the latest version

Related branches

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Changed in harpia (Ubuntu):
status: New → Confirmed

Thanks very much for generating this patch but there is another necessary change, on the "debian/control" file.
As discussed in https://bugs.launchpad.net/harpia/+bug/480772

Depends: ${python:Depends}, python-gobject, python-gnome2, python-glade2, python-4suite-xml, libcvaux-dev, libhighgui-dev, libcv-dev, libc6-dev, gcc, python (>= 2.5), ${misc:Depends}

should turn to:

Depends: ${python:Depends}, python-gobject, python-gnome2, python-glade2, python-4suite-xml, libcv-dev, libc6-dev, gcc, python (>= 2.5), ${misc:Depends}

should be:

Depends: ${python:Depends}, python-gobject, python-gnome2, python-glade2, python-4suite-xml, libcvaux-dev, libhighgui-dev, libcv-dev, libc6-dev, gcc, python (>= 2.5), ${misc:Depends}

Can you update your patch so we can SRU this finally?

Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :

done clovis =)

Regards

The "Standards-Version: 3.8.4" is the correct for lucid also or only for the maverick?

Its for both lucid and maverick :)

On Thu, May 13, 2010 at 8:00 PM, Clovis Peruchi Scotti <<email address hidden>
> wrote:

> The "Standards-Version: 3.8.4" is the correct for lucid also or only for
> the maverick?
>
> --
> Please update harpia to the latest version 1.1
> https://bugs.launchpad.net/bugs/579747
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “harpia” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: harpia
>
> please update the package to the latest version
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/harpia/+bug/579747/+subscribe
>

--
Bhavani Shankar.R
https://launchpad.net/~bhavi, a proud ubuntu community member.
What matters in life is application of mind!,
It makes great sense to have some common sense..!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package harpia - 1.1-0ubuntu1

---------------
harpia (1.1-0ubuntu1) maverick; urgency=low

  * New upstream release LP: #579747
  * Bump standards version to 3.8.4. No other changes
  * Switch to dpkg-source 3.0 (quilt) format
  * Change dependencies as per maintainer request
 -- Bhavani Shankar <email address hidden> Thu, 13 May 2010 19:26:48 +0530

Changed in harpia (Ubuntu):
status: Confirmed → Fix Released
Changed in harpia (Ubuntu):
assignee: nobody → Ubuntu Stable Release Updates Team (ubuntu-sru)

This package should be SRU'ed.
Rationale:
*Version 1.0 is incompatible with the current OpenCV version (2.0, which is in the ubuntu repositories).

*OpenCV dependencies scheme changed in lucid (see post #6 at this page)
*OpenCV 2.0 widely uses c++ coding and is backwards compatible if the users compiles programs passing "-x c++" to gcc. Harpia generates C code and internally compiles it. Changing ONLY this compile time parameter, everything works ok. (See also Bug LP: #480772)

*patch linked in this thread

*A simple test case is to try running any of the embedded examples (Found on "Help>Examples>*") will trigger a compile problem

*I can't see any regression potential since: a) no packages use harpia, b) the package is unusable as it is now, c) the changes are minimal and only "additive" in a sense.

Changed in harpia (Ubuntu):
assignee: Ubuntu Stable Release Updates Team (ubuntu-sru) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers