hardinfo does not show type of new interfaces as ethernet

Bug #1504682 reported by Brendan Perrine on 2015-10-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
hardinfo (Ubuntu)
Undecided
Unassigned

Bug Description

To reproduce on a fresh install of wily instalal lubuntu desktop amd 64. Then install and run system profiler and benchmark from system tools and click on interfaces it shows unkown for both interfaces on my network type when I have an onbaord and pci network inteface. ifconfig shows the the interfaces as ethernet on the command line. The ouput of ifconfig on the command line is.
 enp0s25 Link encap:Ethernet HWaddr d0:50:99:26:7d:31
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          Interrupt:20 Memory:efd00000-efd20000

enp3s1 Link encap:Ethernet HWaddr 08:74:08:74:08:74
          inet addr:192.168.88.249 Bcast:192.168.88.255 Mask:255.255.255.0
          inet6 addr: fe80::a74:8ff:fe74:874/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:30726 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20096 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:41543334 (41.5 MB) TX bytes:2022211 (2.0 MB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:1070 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1070 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:122568 (122.5 KB) TX bytes:122568 (122.5 KB)

The interfaces tab under network shows this as unkown interface type I expected it to show as etherenet like in ifconfig. INstead it shouwed my there connectoins as unkwon. nmcli c for connections lists these connections as ethernet so I am this seems like hardinfo is not solving them.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: hardinfo 0.5.1-1.4ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-15.18-generic 4.2.3
Uname: Linux 4.2.0-15-generic x86_64
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
CurrentDesktop: LXDE
Date: Fri Oct 9 14:36:58 2015
InstallationDate: Installed on 2015-10-09 (0 days ago)
InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151009)
SourcePackage: hardinfo
UpgradeStatus: No upgrade log present (probably fresh install)

Brendan Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1504682

tags: added: iso-testing
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hardinfo (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

This bug affects the live session of Lubuntu i386 too.

Simon Quigley (tsimonq2) wrote :

This seems to be fixed in the live session of Lubuntu Xenial amd64 on Sunday, November 29, 2015.

Changed in hardinfo (Ubuntu):
status: Confirmed → Fix Released
Brendan Perrine (walterorlin) wrote :

I can still reproduce this if my ethernet nic is not named the way it was in 15.04 and earlier with say eth 0, eth1 and instead ens3 or enp0s25 So this can be a likely suspect of being mistakenly marked fix released.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers