sh: 1: /lib/libc.so.6: not found

Bug #1473142 reported by LAZA
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
hardinfo (Ubuntu)
Fix Released
Low
Unassigned
Yakkety
Fix Released
Low
Unassigned
Zesty
Fix Released
Low
Unassigned

Bug Description

Starting "hardinfo" from the common line i get this error:

sh: 1: /lib/libc.so.6: not found

Hardinfo works as expected, cold not find a error.
Some internet search got me, that this is a problem of multiarch since 11.04, so i added this tag.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: hardinfo 0.5.1-1.2ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-22.22~14.04.1-generic 3.19.8-ckt1
Uname: Linux 3.19.0-22-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
Date: Thu Jul 9 18:35:47 2015
InstallationDate: Installed on 2015-06-25 (14 days ago)
InstallationMedia: Xubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
SourcePackage: hardinfo
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
LAZA (laza74) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hardinfo (Ubuntu):
status: New → Confirmed
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1473142

tags: added: iso-testing
Revision history for this message
sudodus (nio-wiklund) wrote :

hardinfo crashes on 'Filesystems'

Revision history for this message
Simon Quigley (tsimonq2) wrote :

This has been fixed thanks to some help from Mathieu Trudel-Lapierre.

Changed in hardinfo (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Simon Quigley (tsimonq2) wrote :

Sorry, I misread the bug report.

Can somebody confirm this on a Trusty install? If you can confirm it, we just need to backport Mathieu's fix to Trusty, I assume.

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

This isn't fixed yet, still in the yakkety queue.

Changed in hardinfo (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello LAZA, or anyone else affected,

Accepted hardinfo into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hardinfo/0.5.1-1.4ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Revision history for this message
Adam Bolte (boltronics) wrote :

Confirming the fix works for me. Tested 0.5.1-1.4ubuntu3 from the yakkety-proposed repository. Tag updated.

tags: added: verification-done
removed: verification-needed
Mathew Hodson (mhodson)
Changed in hardinfo (Ubuntu Yakkety):
importance: Undecided → Low
Changed in hardinfo (Ubuntu Zesty):
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in hardinfo (Ubuntu Zesty):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hardinfo - 0.5.1-1.4ubuntu3

---------------
hardinfo (0.5.1-1.4ubuntu3) yakkety; urgency=medium

  * debian/patches/04-fix-ftbfs-shared-symbols.diff: also un-inline other
    functions called by the modules: remove_linefeeds, remove_quotes, and
    size_human_readable.
  * debian/patches/glibc-version.patch: fix checking for GLIBC version, use
    ldconfig -V instead of trying to call libc.so.6 directly, and update the
    string mangling in the process. (LP: #1473142)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 12 Oct 2016 16:17:18 -0400

Changed in hardinfo (Ubuntu Zesty):
status: Confirmed → Fix Released
Changed in hardinfo (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote : Update Released

The verification of the Stable Release Update for hardinfo has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
WinEunuchs2Unix (ricklee518) wrote :

Doesn't appear to be a big deal other than Battery information doesn't appear but, this error still occurs in Ubuntu 16.04.5 LTS when calling `hardinfo` from the command line:

$ hardinfo
sh: 1: /lib/libc.so.6: not found
sh: 1: gnome-about: not found
sh: 0: -c requires an argument
sh: 0: -c requires an argument
sh: 0: -c requires an argument

< Last line repeats many times >

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers