Activity log for bug #1755061

Date Who What changed Old value New value Message
2018-03-12 01:36:50 Paul Collins bug added bug
2018-03-12 01:37:06 Paul Collins bug added subscriber The Canonical Sysadmins
2018-03-12 01:37:23 Paul Collins bug task added charm-cinder
2018-03-12 01:37:41 Paul Collins bug task added charm-glance
2018-03-12 01:38:03 Paul Collins bug task added charm-keystone
2018-03-12 01:38:16 Paul Collins bug task added charm-neutron-api
2018-03-12 01:38:32 Paul Collins bug task added charm-nova-cloud-controller
2018-03-12 01:38:45 Paul Collins bug task added charm-swift-proxy
2018-03-15 11:32:57 James Page charm-helpers: status New Triaged
2018-03-15 11:32:59 James Page charm-cinder: status New Triaged
2018-03-15 11:33:00 James Page charm-glance: status New Triaged
2018-03-15 11:33:02 James Page charm-keystone: status New Triaged
2018-03-15 11:33:04 James Page charm-neutron-api: status New Triaged
2018-03-15 11:33:06 James Page charm-nova-cloud-controller: status New Triaged
2018-03-15 11:33:08 James Page charm-swift-proxy: status New Triaged
2018-03-15 11:33:11 James Page charm-helpers: importance Undecided High
2018-03-15 11:33:13 James Page charm-cinder: importance Undecided High
2018-03-15 11:33:15 James Page charm-glance: importance Undecided High
2018-03-15 11:33:18 James Page charm-keystone: importance Undecided High
2018-03-15 11:33:20 James Page charm-neutron-api: importance Undecided High
2018-03-15 11:33:21 James Page charm-nova-cloud-controller: importance Undecided High
2018-03-15 11:33:23 James Page charm-swift-proxy: importance Undecided High
2018-05-18 08:59:14 James Page bug task added haproxy (Ubuntu)
2018-05-18 08:59:21 James Page haproxy (Ubuntu): status New Triaged
2018-05-18 08:59:23 James Page haproxy (Ubuntu): importance Undecided High
2018-05-18 08:59:25 James Page charm-swift-proxy: status Triaged Invalid
2018-05-18 08:59:27 James Page charm-nova-cloud-controller: status Triaged Invalid
2018-05-18 08:59:29 James Page charm-neutron-api: status Triaged Invalid
2018-05-18 08:59:31 James Page charm-keystone: status Triaged Invalid
2018-05-18 08:59:33 James Page charm-glance: status Triaged Invalid
2018-05-18 08:59:34 James Page charm-cinder: status Triaged Invalid
2018-05-18 08:59:36 James Page charm-helpers: status Triaged Invalid
2018-05-18 09:06:13 James Page nominated for series Ubuntu Trusty
2018-05-18 09:06:13 James Page bug task added haproxy (Ubuntu Trusty)
2018-05-18 09:06:23 James Page haproxy (Ubuntu): status Triaged Fix Released
2018-05-18 09:06:35 James Page haproxy (Ubuntu Trusty): importance Undecided High
2018-05-18 09:06:35 James Page haproxy (Ubuntu Trusty): status New In Progress
2018-05-18 09:06:55 James Page haproxy (Ubuntu Trusty): assignee James Page (james-page)
2018-05-18 09:09:25 James Page description While testing upgrades of an Ubuntu 14.04 deployment of OpenStack from ~15.04 to 17.11 charms, I noticed that a number of the OpenStack charmed services failed to start haproxy when I rebooted their units: cinder, glance, keystone, neutron-api, nova-cloud-controller, and swift-proxy. The following was in /var/log/boot.log: [ALERT] 069/225906 (1100) : cannot bind socket for UNIX listener (/var/run/haproxy/admin.sock). Aborting. [ALERT] 069/225906 (1100) : [/usr/sbin/haproxy.main()] Some protocols failed to start their listeners! Exiting. * Starting haproxy haproxy [fail] The charm created /var/run/haproxy, but since /var/run (really /run) is a tmpfs, this did not survive the reboot and so haproxy could not create the socket. I compared the haproxy.cfg the charm creates with the default config shipped by the Ubuntu 16.04 haproxy package, and it seems that charmhelpers/contrib/openstack/templates/haproxy.cfg is closely based on the package, including the admin.sock directive. However, on Ubuntu 16.04, /etc/init.d/haproxy ensures that /var/run/haproxy exists before it starts haproxy: [agnew(work)] diff -u haproxy-1.4.24/debian/haproxy.init haproxy-1.6.3/debian/haproxy.init --- haproxy-1.4.24/debian/haproxy.init 2015-12-16 03:55:29.000000000 +1300 +++ haproxy-1.6.3/debian/haproxy.init 2015-12-31 20:10:38.000000000 +1300 [...] @@ -50,6 +41,10 @@ haproxy_start() { + [ -d "$RUNDIR" ] || mkdir "$RUNDIR" + chown haproxy:haproxy "$RUNDIR" + chmod 2775 "$RUNDIR" + check_haproxy_config start-stop-daemon --quiet --oknodo --start --pidfile "$PIDFILE" \ [...] charm-helpers or the OpenStack charms or both should be updated so that haproxy will start on boot when running on Ubuntu 14.04. [Impact] Valid haproxy configuration directives don't work on trusty as /run/haproxy does not survive reboots and is not-recreated on daemon start. [Test Case] sudo apt install haproxy configure /etc/haproxy.cfg with a admin socket in /run/haproxy: global log /var/lib/haproxy/dev/log local0 log /var/lib/haproxy/dev/log local1 notice maxconn 20000 user haproxy group haproxy spread-checks 0 stats socket /var/run/haproxy/admin.sock mode 600 level admin stats timeout 2m Restart haproxy (will fail as /{,var/}run/haproxy does not exist) [Regression Potential] Minimal - same fix is in later package revisions [Original Bug Report] While testing upgrades of an Ubuntu 14.04 deployment of OpenStack from ~15.04 to 17.11 charms, I noticed that a number of the OpenStack charmed services failed to start haproxy when I rebooted their units: cinder, glance, keystone, neutron-api, nova-cloud-controller, and swift-proxy. The following was in /var/log/boot.log: [ALERT] 069/225906 (1100) : cannot bind socket for UNIX listener (/var/run/haproxy/admin.sock). Aborting. [ALERT] 069/225906 (1100) : [/usr/sbin/haproxy.main()] Some protocols failed to start their listeners! Exiting.  * Starting haproxy haproxy [fail] The charm created /var/run/haproxy, but since /var/run (really /run) is a tmpfs, this did not survive the reboot and so haproxy could not create the socket. I compared the haproxy.cfg the charm creates with the default config shipped by the Ubuntu 16.04 haproxy package, and it seems that charmhelpers/contrib/openstack/templates/haproxy.cfg is closely based on the package, including the admin.sock directive. However, on Ubuntu 16.04, /etc/init.d/haproxy ensures that /var/run/haproxy exists before it starts haproxy: [agnew(work)] diff -u haproxy-1.4.24/debian/haproxy.init haproxy-1.6.3/debian/haproxy.init --- haproxy-1.4.24/debian/haproxy.init 2015-12-16 03:55:29.000000000 +1300 +++ haproxy-1.6.3/debian/haproxy.init 2015-12-31 20:10:38.000000000 +1300 [...] @@ -50,6 +41,10 @@  haproxy_start()  { + [ -d "$RUNDIR" ] || mkdir "$RUNDIR" + chown haproxy:haproxy "$RUNDIR" + chmod 2775 "$RUNDIR" +         check_haproxy_config         start-stop-daemon --quiet --oknodo --start --pidfile "$PIDFILE" \ [...] charm-helpers or the OpenStack charms or both should be updated so that haproxy will start on boot when running on Ubuntu 14.04.
2018-05-18 09:09:32 James Page bug added subscriber Ubuntu Stable Release Updates Team
2018-05-24 20:15:17 Brian Murray haproxy (Ubuntu Trusty): status In Progress Fix Committed
2018-05-24 20:15:21 Brian Murray bug added subscriber SRU Verification
2018-05-24 20:15:26 Brian Murray tags canonical-is-ps45-1711-upgrade canonical-is-ps45-1711-upgrade verification-needed verification-needed-trusty
2018-11-03 21:38:33 Mathew Hodson affects charm-helpers ubuntu-translations
2018-11-03 21:38:50 Mathew Hodson bug task deleted ubuntu-translations
2018-11-03 21:39:09 Mathew Hodson affects charm-swift-proxy ubuntu-translations
2018-11-03 21:39:36 Mathew Hodson bug task deleted ubuntu-translations
2018-11-03 21:39:52 Mathew Hodson affects charm-neutron-api ubuntu-translations
2018-11-03 21:40:09 Mathew Hodson bug task deleted ubuntu-translations
2018-11-03 21:40:22 Mathew Hodson affects charm-keystone ubuntu-translations
2018-11-03 21:40:44 Mathew Hodson bug task deleted ubuntu-translations
2018-11-03 21:40:59 Mathew Hodson affects charm-cinder ubuntu-translations
2018-11-03 21:41:09 Mathew Hodson bug task deleted ubuntu-translations
2018-11-03 21:41:30 Mathew Hodson affects charm-glance ubuntu-translations
2018-11-03 21:41:39 Mathew Hodson bug task deleted ubuntu-translations
2018-11-03 21:41:59 Mathew Hodson affects charm-nova-cloud-controller ubuntu-translations
2018-11-03 21:42:08 Mathew Hodson bug task deleted ubuntu-translations
2018-11-13 18:47:20 Brian Murray tags canonical-is-ps45-1711-upgrade verification-needed verification-needed-trusty canonical-is-ps45-1711-upgrade removal-candidate verification-needed verification-needed-trusty
2019-01-28 09:40:10 Łukasz Zemczak tags canonical-is-ps45-1711-upgrade removal-candidate verification-needed verification-needed-trusty canonical-is-ps45-1711-upgrade removal-candidate verification-needed
2019-01-28 09:40:12 Łukasz Zemczak haproxy (Ubuntu Trusty): status Fix Committed Won't Fix
2019-01-28 09:40:14 Łukasz Zemczak removed subscriber Ubuntu Stable Release Updates Team
2019-01-28 09:40:15 Łukasz Zemczak tags canonical-is-ps45-1711-upgrade removal-candidate verification-needed canonical-is-ps45-1711-upgrade removal-candidate