Sync haproxy 1.8.3-1 (main) from Debian experimental (main)

Bug #1748210 reported by Neil Wilson on 2018-02-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
haproxy (Ubuntu)
Undecided
Andreas Hasenack

Bug Description

Please sync haproxy 1.8.3-1 (main) from Debian experimental (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Backport of -x option from upstream haproxy to enable seamless
    reloading of haproxy without dropping connections. This is enabled
    by adding
    " stats socket <stats file> expose-fd listeners
      stats bind-process 1 "
    to the global section of your haproxy config, and
    setting HAPROXY_STATS_SOCKET in the haproxy.service unit file.
    (LP: #1712925)
  * Backport of -x option from upstream haproxy to enable seamless
    reloading of haproxy without dropping connections. This is enabled
    by adding
    " stats socket <stats file> expose-fd listeners
      stats bind-process 1 "
    to the global section of your haproxy config, and
    setting HAPROXY_STATS_SOCKET in the haproxy.service unit file.
    (LP: #1712925)

1.8 version includes this backported change, is a the current stable
haproxy version and will be mainline throughout the bionic release
cycle. It should be in the LTS version, rather than maintaining the
current delta for five years.

Changelog entries since current bionic version 1.7.9-1ubuntu2:

haproxy (1.8.3-1) experimental; urgency=medium

  * New upstream stable release.
  * Change default configuration of stats socket to support hitless
    reload.

 -- Vincent Bernat <email address hidden> Tue, 02 Jan 2018 18:48:24 +0100

haproxy (1.8.2-1) experimental; urgency=medium

  * New upstream stable release
  * Refresh patches
  * Bump Standards-Version to 4.1.2; no changes needed

 -- Apollon Oikonomopoulos <email address hidden> Sun, 24 Dec 2017 14:28:28 +0200

haproxy (1.8.1-1) experimental; urgency=medium

  * New upstream stable release.
  * Enable PCRE JIT.
  * systemd: replace Wants/After=syslog.service with After=rsyslog.service
    (Closes: #882610)

 -- Apollon Oikonomopoulos <email address hidden> Sun, 03 Dec 2017 23:59:03 +0200

haproxy (1.8.0-2) experimental; urgency=medium

  * Use libatomic on platforms without 64-bit atomics. Fixes FTBFS on armel,
    mips, mipsel, powerpc, powerpcspe, sh4 and m68k.
  * d/rules: use variables defined in architecture.mk and buildflags.mk
  * d/rules: drop unreachable else case.

 -- Apollon Oikonomopoulos <email address hidden> Wed, 29 Nov 2017 01:21:40 +0200

haproxy (1.8.0-1) experimental; urgency=medium

  * New upstream stable series. Notable new features include:
    + HTTP/2 support
    + Support for multiple worker threads to allow scalability across CPUs
      (e.g. for SSL termination)
    + Seamless reloads
    + HTTP small object caching
    + Dynamic backend server configuration
    See https://www.haproxy.com/blog/whats-new-haproxy-1-8/ and
    https://<email address hidden>/msg28004.html for more
    detailed descriptions of the new features.
  * Upload to experimental
  * Refresh all patches.
  * d/watch: switch to the 1.8.x upstream stable series
  * Bump Standards to 4.1.1
    + Switch haproxy-doc to Priority: optional from extra.
  * Bump compat to 10:
    + B-D on debhelper (>= 10)
    + Drop explicit dh-systemd dependency and invocation
    + Replace --no-restart-on-upgrade with --no-restart-after-upgrade
      --no-stop-on-upgrade to make up for DH 10 defaults.
  * B-D on libsystemd-dev and enable sd_notify() support on Linux.
  * B-D on python3-sphinx instead of python-sphinx.
  * d/rules: do not call dpkg-parsechangelog directly.
  * d/copyright: drop obsolete section.
  * Drop obsolete lintian overrides.
  * Do a full-service restart when upgrading from pre-1.8 versions and running
    under systemd, to migrate to the new process model and service type.
    + Document this in d/NEWS as well.

 -- Apollon Oikonomopoulos <email address hidden> Tue, 28 Nov 2017 22:25:11 +0200

Hi Neil,
I agree in general but I'm not an haproxy expert.
I would prefer to have someone else look over it and/or sync with the Debian maintainers why it still is in experimental.
I kicked that off and will get back to you once I have that feedback.

Changed in haproxy (Ubuntu):
status: New → Confirmed
Changed in haproxy (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
status: Confirmed → In Progress
Andreas Hasenack (ahasenack) wrote :

It looks like this can become a sync indeed. I'm testing a package I built on this ppa: https://launchpad.net/~ahasenack/+archive/ubuntu/haproxy-18-merge-1748210/+packages

It still has the "ubuntu" suffix, just because that's what I arrived at after doing the merge, but it has no delta.

Andreas Hasenack (ahasenack) wrote :

I performed the following tests so far:
- used a charm bundle to deploy a complex application that uses haproxy as the frontend, with and without ssl (landscape-server). Added backends after the deployment as well. Worked as expected
- tried reload while there were ongoing live connections to the backends via haproxy. Saw the new -x option be automatically used, and once the connections ended, the old haproxy processes disappeared.
- tried an upgrade from 1.7.x to 1.8.4 with a simple app (haproxy as the fe, one apache server as the be)

Andreas Hasenack (ahasenack) wrote :

Other tests I just finished:
- deploy large app with charms, haproxy on bionic. Verify app works. Upgrade haproxy to 1.8.4. app still works. Add new backend to app, works.
- upgrade xenial to bionic, with the ppa for haproxy 1.8.4 enabled. Tested simple config (haproxy as fe, one apache as backend to see the hello ubuntu page). Also worked.

I'm +1 for the sync.

Download full text (3.4 KiB)

Thanks for the thorough checks Andreas.
Per former statement sync started.
Lets track it on migration the next few days now ...

syncpackage: D: Source package haproxy is temporarily blacklisted (blacklisted_current). Ubuntu ignores these for now. See also LP: #841372
syncpackage: Source haproxy -> bionic/Proposed: current version 1.7.9-1ubuntu2, new version 1.8.4-1
syncpackage: I: Good signature by Vincent Bernat <email address hidden> (0x95A42FE8353525F9)
syncpackage: I: Good signature by Dimitri John Ledkov <email address hidden> (0xCAC2D8B9CD2CA5F9)
syncpackage: New changes:
haproxy (1.8.4-1) experimental; urgency=medium

  * New upstream stable release.
  * d/patches: document why dconv patch is not in series.
  * d/docs: ship NOTICE file in haproxy-doc.

 -- Vincent Bernat <email address hidden> Sat, 10 Feb 2018 08:43:36 +0100

haproxy (1.8.3-1) experimental; urgency=medium

  * New upstream stable release.
  * Change default configuration of stats socket to support hitless
    reload.

 -- Vincent Bernat <email address hidden> Tue, 02 Jan 2018 18:48:24 +0100

haproxy (1.8.2-1) experimental; urgency=medium

  * New upstream stable release
  * Refresh patches
  * Bump Standards-Version to 4.1.2; no changes needed

 -- Apollon Oikonomopoulos <email address hidden> Sun, 24 Dec 2017 14:28:28 +0200

haproxy (1.8.1-1) experimental; urgency=medium

  * New upstream stable release.
  * Enable PCRE JIT.
  * systemd: replace Wants/After=syslog.service with After=rsyslog.service
    (Closes: #882610)

 -- Apollon Oikonomopoulos <email address hidden> Sun, 03 Dec 2017 23:59:03 +0200

haproxy (1.8.0-2) experimental; urgency=medium

  * Use libatomic on platforms without 64-bit atomics. Fixes FTBFS on armel,
    mips, mipsel, powerpc, powerpcspe, sh4 and m68k.
  * d/rules: use variables defined in architecture.mk and buildflags.mk
  * d/rules: drop unreachable else case.

 -- Apollon Oikonomopoulos <email address hidden> Wed, 29 Nov 2017 01:21:40 +0200

haproxy (1.8.0-1) experimental; urgency=medium

  * New upstream stable series. Notable new features include:
    + HTTP/2 support
    + Support for multiple worker threads to allow scalability across CPUs
      (e.g. for SSL termination)
    + Seamless reloads
    + HTTP small object caching
    + Dynamic backend server configuration
    See https://www.haproxy.com/blog/whats-new-haproxy-1-8/ and
    https://<email address hidden>/msg28004.html for more
    detailed descriptions of the new features.
  * Upload to experimental
  * Refresh all patches.
  * d/watch: switch to the 1.8.x upstream stable series
  * Bump Standards to 4.1.1
    + Switch haproxy-doc to Priority: optional from extra.
  * Bump compat to 10:
    + B-D on debhelper (>= 10)
    + Drop explicit dh-systemd dependency and invocation
    + Replace --no-restart-on-upgrade with --no-restart-after-upgrade
      --no-stop-on-upgrade to make up for DH 10 defaults.
  * B-D on libsystemd-dev and enable sd_notify() support on Linux.
  * B-D on python3-sphinx instead of python-sphinx.
  * d/rules: do not call dpkg-parsechangelog directly.
  * d/copyright: drop obsolete section.
  * Drop obsolete lintian overrides.
  * Do a full-s...

Read more...

Andreas Hasenack (ahasenack) wrote :

haproxy 1.8.4 has hit the bionic archive. Since it's now a sync, there is no mention of this bug in its changelog, so I'm closing this bug manually.

Changed in haproxy (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers