hamster-time-tracker crashed with TypeError: can't compare datetime.datetime to NoneType

Bug #926481 reported by Neal McBurnett on 2012-02-04
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Project Hamster
Expired
Medium
hamster-applet (Ubuntu)
Undecided
Jamie Strandboge

Bug Description

I was fooling around on precise with hamster 2.91.3+git20110714.9aefd7-2ubuntu2

I started and stopped a few tasks, then edited one, dragging the graphical extent to make it start earlier, as I recall. I might have done other stuff too. Then it crashed and offered to send in a bug report, so I said yes. Here it is. This was in the terminal window where I started it.

/usr/lib/python2.7/dist-packages/hamster/configuration.py:153: GtkWarning: IA__gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
  ui.add_from_file(os.path.join(runtime.data_dir, name))
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/hamster/widgets/dayline.py", line 186, in on_click
    if start_time > dt.datetime.now():
TypeError: can't compare datetime.datetime to NoneType

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: hamster-applet 2.91.3+git20110714.9aefd7-2ubuntu2
Uname: Linux 3.1.0-030100-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Fri Feb 3 15:46:07 2012
ExecutablePath: /usr/bin/hamster-time-tracker
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/bin/hamster-time-tracker
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/hamster-time-tracker']
SourcePackage: hamster-applet
Title: hamster-time-tracker crashed with TypeError in on_click(): can't compare datetime.datetime to NoneType
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/hamster/widgets/dayline.py", line 186, in on_click
     if start_time > dt.datetime.now():
 TypeError: can't compare datetime.datetime to NoneType
UpgradeStatus: Upgraded to precise on 2012-01-29 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Neal McBurnett (nealmcb) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Changed in hamster-applet:
importance: Unknown → Medium
status: Unknown → New
Jamie Strandboge (jdstrand) wrote :

I can confirm this. The way to reproduce seems to be to modify an entry, then click/drag on the range bar, then go left to right such that the times are the same, then unclick.

Changed in hamster-applet (Ubuntu):
status: New → Confirmed
Changed in hamster-applet (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hamster-applet - 2.91.3+git20110714.9aefd7-2ubuntu3

---------------
hamster-applet (2.91.3+git20110714.9aefd7-2ubuntu3) precise; urgency=low

  * debian/patches/04-lp926481.patch: if we somehow got a click with no
    selected start_time, then reset the selection but don't update the widget
    (LP: #926481)
 -- Jamie Strandboge <email address hidden> Mon, 06 Feb 2012 07:56:53 -0600

Changed in hamster-applet (Ubuntu):
status: In Progress → Fix Released
Changed in hamster-applet:
status: New → In Progress
Changed in hamster-applet:
status: In Progress → Expired
Neal McBurnett (nealmcb) wrote :

Hamster is now using github to track bugs.
Rather than being "expired", this issue is now also fixed upstream:
https://github.com/projecthamster/hamster/issues/24

Because of bug 878413, I can't simply enter that above in launchpad as a new upstream bug url for this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.