hamster-applet failed to install on Oneiric: hamster-applet (= 2.32.1-0ubuntu1) depends on missing python-gnomeapplet (>= 2.10.0)

Bug #801477 reported by Rex Tsai on 2011-06-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hamster-applet (Ubuntu)
High
Unassigned

Bug Description

In oneiric, python-gnomeapplet has been dropped since 2.32.0-0ubuntu4[1].

[1] https://launchpad.net/ubuntu/+source/gnome-python-desktop/2.32.0-0ubuntu4

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: hamster-applet (not installed)
ProcVersionSignature: Ubuntu 3.0-1.2-generic 3.0.0-rc3
Uname: Linux 3.0-1-generic x86_64
Architecture: amd64
Date: Fri Jun 24 17:05:54 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
ProcEnviron:
 LANGUAGE=zh_TW:en
 PATH=(custom, user)
 LANG=zh_TW.utf8
 LC_MESSAGES=zh_TW.UTF-8
 SHELL=/bin/bash
SourcePackage: hamster-applet
UpgradeStatus: No upgrade log present (probably fresh install)

Rex Tsai (chihchun) on 2011-06-24
description: updated
description: updated
description: updated
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Confirmed in oneiric.

hamster-applet (= 2.32.1-0ubuntu1): FAILED
  hamster-applet (= 2.32.1-0ubuntu1) depends on missing:
  - python-gnomeapplet (>= 2.10.0)

Changed in hamster-applet (Ubuntu):
importance: Undecided → High
status: New → Triaged
summary: - hamster-applet can not be installed due to missing python-gnomeapplet
+ hamster-applet failed to install on Oneiric: hamster-applet (=
+ 2.32.1-0ubuntu1) depends on missing python-gnomeapplet (>= 2.10.0)
Sebastien Bacher (seb128) wrote :

the software is using outdated technologies and should be ported or dropped

Jamie Strandboge (jdstrand) wrote :

*Sigh* this program is essential to my work and has been for more than 2 years....

Jamie Strandboge (jdstrand) wrote :

hamster works fine standalone. I'll upload a version that loses the dependency and doesn't ship the applet-dependent binary.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hamster-applet - 2.32.1-0ubuntu2

---------------
hamster-applet (2.32.1-0ubuntu2) oneiric; urgency=low

  * make hamster-applet installable again. It works fine in standalone mode.
    This should all be undone once upstream has a version that works with
    gnome3.
    - debian/control*:
      + remove Depends on python-gnomeapplet
      + update to describe hamster as an application, not an applet. Of
        course, there is still the name...
    - debian/patches/03-dont-install-applet.patch: don't install
      src/hamster-applet, bonobo files, or its desktop file
    - LP: #801477
 -- Jamie Strandboge <email address hidden> Fri, 22 Jul 2011 16:14:31 -0500

Changed in hamster-applet (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers