USB flash drive shown twice on the desktop

Bug #96905 reported by David Balažic on 2007-03-27
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

i386 desktop CD - Feisty beta
$ cat /cdrom/.disk/info
Ubuntu 7.04 "Feisty Fawn" - Beta i386 (20070322.1)

live boot - all default options

I inserted an U3 Sandisk Cruzer Titanium USB flash drive (U3 doft removed from it).
Then I booted ubuntu.

When loaded, on the desktop there were two icons for it, both labeled "disk".
Both appear to work (open when double clicked).

Reproducible on my system (desktop PC, Athlon XP2200+)

PS: USB drives were labeled as "usb disk" before Herd5, why are they now just "disk" ?
Why isn't their volume label used ?

Chris Rose (chris-vault5) wrote :

Thank you for your bug report.

From what I remember, some Cruzer USB flash drives have a small switch on to disable this. They appear as two drives, one of which under Windows shows up as a cdrom to autorun to install some software.

The two drives that come up, do they both have the same icon? If you write files to one, do they show up on the other?

David Balažic (xerces8) wrote :

There is no switch, I "killed" U3 with software ("U3 Uninstall" or something like that).

The both icons are the same, they both open the same directories. The icon is the same for both.

This started happening with the beta, in Herd5 this problem was not present. It probably has nothing to do with U3.

Chris Rose (chris-vault5) wrote :

Thank you.

patbernier (pat-tzone) wrote :

I am seeing a similar problem here on Feisty, perhaps with the same cause.

I have a portable USB hard drive with two partitions, one vfat and one ext3 (which contains a full bootable Ubuntu environment, but that not the one being used in this case, the computer was booted from its internal drive).

Both partitions are usually automounted at login and appear on the desktop with their volume labels. But once in a while (like right now), TWO icons appear for the vfat partition.

They are functionally identical. If I unmount ("eject") any of the two icons, the first one dissapears. If I then try to open the remaining one, I get "The folder contents could not be displayed. "BERNIER_120" couldn't be found. Perhaps it has recently been deleted."

It's not a big problem, but it does clutter the desktop ^_^

Gurubie (gurubie) wrote :

No. I have several flash drives; all singular partitions/standard and each one pulls up two (ANNOYING) file manager windows, even after I purged Dolphin (on Kubuntu) in favor of Konqueror. The second windows COMPLAINS about already being mounted. This happens almost at the same time. The newest one is a transflash/MicroSD in it's USB adapter. It is tiny and I do not think U3 or anything else is added. The others are NOT in any type of adapter but USB 2.0. I tried turning off auto file view pop-ups and it still show two each time.

Matthew D. Mower (mdmower) wrote :

I also experience this problem, patbernier's setup most closely matches my own.

With an external hard drive partitioned as: 1 Fat32, 1 NTFS, and 1 Ext3, the NTFS drive shows up duplicated on the desktop. Unmounting the drive results in a successful message, and one icon disappearing. The other icon becomes non-functional.

For me, the duplicate icons only appear if the external drive was already connected and turned on during bootup.

Ubuntu 7.10 with updates as of 1/24/08.
Dell Inspiron 1520 (Centrino Duo chipset)

Dick Dunbar (redunbar) wrote :

This is a common problem. I see it with USB drive that I keep permanently connected, as do others. Here's a thread where
many people are talking about experiencing this same problem: http://ubuntuforums.org/showthread.php?t=25104
This is definitely a bug. I first noticed it in Gutsy, but it may have been in Feisty as well. It's a definite annoyance.

Chris (bridgeriver) wrote :

I'm seeing this kind of behavior on Hardy as well: multiple icons show up for a single partition on a hotpluggable drive. But for me they are not functionally identical: Starting with two mounted icons in the Nautilus sidebar, both of which refer to the same partition in an SD card (my laptop has a built-in SD reader), I unmount one instance by right-clicking and selecting Unmount. The other one stays mounted! And attempting to unmount it the same way fails silently (no error message). I sudo -s and umount it manually, which works and causes the extra icon to disappear.

This behavior may be getting triggered when the laptop is suspended and resumed with the card in the slot.

I haven't seen that particular problem. In my case, it has always been
a stand-alone USB hard drive that has come up with dual icons. If I
unmount it, one goes away, and I'm unable to do anything with the
remaining one. But so far, it has never happened on successive boots,
so if it happens, I just reboot. I recently upgraded two of my systems
to Hardy, and did a clean install on another one, and so far, I haven't
seen this problem on any of the three systems running Hardy. The one
where I see it most frequently (which is my laptop) is still on Gutsy,
but I plan on upgrading it soon. We'll see what happens then.
Suspend/resume isn't a consideration on this system, as I have never
done that. For me, it always happens when booting.
--
Richard E."Dick" Dunbar
<email address hidden>
Home:651-528-6026
Cell:612-382-3604
http://www.towboatgallery.com

-----Original Message-----
From: Chris <email address hidden>
Reply-To: Bug 96905 <email address hidden>
To: <email address hidden>
Subject: [Bug 96905] Re: USB flash drive shown twice on the desktop
Date: Sat, 17 May 2008 22:56:46 -0000

I'm seeing this kind of behavior on Hardy as well: multiple icons show
up for a single partition on a hotpluggable drive. But for me they are
not functionally identical: Starting with two mounted icons in the
Nautilus sidebar, both of which refer to the same partition in an SD
card (my laptop has a built-in SD reader), I unmount one instance by
right-clicking and selecting Unmount. The other one stays mounted! And
attempting to unmount it the same way fails silently (no error message).
I sudo -s and umount it manually, which works and causes the extra icon
to disappear.

This behavior may be getting triggered when the laptop is suspended and
resumed with the card in the slot.

Dick Dunbar (redunbar) wrote :

An update to my earlier postings: I now have all my systems running Hardy, and have yet to see the duplicate usb drive icon occur since the switch to Hardy. Something in Hardy appears to have corrected at least the variation of this problem that I was seeing.

Hardy on T41: some files are opened with vim or gedit from usb-disk, do the suspend, wake up - there is second "2.1 GB Media" icon on desktop. Mounts are disk for first one, disk-1 for second. Opened files are not accessible anymore, You have to close all of them, because "disk" is now empty, only "disk-1" works. You can unmount only disk-1, unmounting disk will not work.

There is no such behavior if You close all files from this disk before suspending.

That sucks, if I may say so.

btw, stale mount, mentioned in previous post, can be unmounted as root

PS. is anybody working on this bug, seems like many months old and not too much happening here?

Shawn vega (svega85-gmail) wrote :

this now appears to be a problem in intrepid ibex. I plug in a thumb drive and two icons appear on the desktop.

fmhoyt (fmhoyt) wrote :

I have a version of this problem in Hardy. I have a Lacie 60GB USB hard drive attached to my Thinkpad T61.

When I wake the computer from sleep/suspension, two icons appear on the desktop. Only one of them will unmount, and I am unable to search the volume or to display its contents. I have to reboot to get the extra icon to go away and to be able to use the drive properly.

I did not have this problem with Gutsy, and it appeared within the last two weeks or so, after I had upgraded to Hardy.

Linux ubuntu 2.6.24-21-generic
AMD64
8.04.1

Savvas Radevic (medigeek) wrote :

Can someone test this on Ubuntu Intrepid Ibex 8.10 (with its updates)?

$ apt-cache policy linux-generic
linux-generic:
  Installed: 2.6.27.9.13
  Candidate: 2.6.27.9.13
  Version table:
 *** 2.6.27.9.13 0
        500 http://security.ubuntu.com intrepid-security/restricted Packages
        500 http://de.archive.ubuntu.com intrepid-updates/restricted Packages
        100 /var/lib/dpkg/status
     2.6.27.7.11 0
        500 http://de.archive.ubuntu.com intrepid/restricted Packages

Shawn vega (svega85-gmail) wrote :

it works fine now.

$ apt-cache policy linux-generic
linux-generic:
  Installed: (none)
  Candidate: 2.6.27.11.14

Savvas Radevic (medigeek) wrote :

Marking as "Fix released" as per the last comment.
If you stumble upon the same bug again, don't hesitate to provide information and set its status to "new":
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/96905/+editstatus

Changed in hal:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments