[Kubuntu Feisty data dvd automount not working] many data dvd do not get automounted with kubuntu 7.04 beta

Bug #95868 reported by Davide R (gatewayasteroid) on 2007-03-25
42
Affects Status Importance Assigned to Milestone
hal (Debian)
Fix Released
Unknown
hal (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: hal

Almost any data DVDs I have do not get automounted with kubuntu 7.04 beta.

The bug seems the same as the following in debian etch:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370186

And it got fixed with the following patch:

http://packages.debian.org/changelogs/pool/main/h/hal/hal_0.5.8.1-9/changelog

~~~
* debian/patches/30_cdrom_bogus_tocinfo.patch
- Added. Some cdrom drives/discs report a wrong start of the session in he TOC, causing hal to not detect the filesystem. Work around this by rescanning at offset 0 for discs when filesystem detection fails.
~~~

So, if this patch isn't already in Feisty hal package, I think it should be included.

Thanks

description: updated
ShaunS (shauns) wrote :

Hi,

I have installed Kubuntu Feisty Beta on three machines. Two of the machines do not display the message 'A new medium has been detected ...' and do not get automounted, when a DVD is inserted. They both display the message when a CD is inserted.

Thanks
Sygin

Rajeev Nair (rajeev) wrote :

I have a similar problem

The system automounts dvd and data cd but fails to mount video cd disks.

I had to manually add a /dev/scdo mounted on /dev/cdrom in the fstab file

Rajeev Nair (rajeev) wrote :

Forgot to mention

iam on feisty beta and its a sony dvd/cd rw model CRX 320 EE

UPDATE: It seems a KDE related bug, since I tried my DVDs on Xubuntu 7.04 RC and they work fine.

I think it's a very important Kubuntu bug (especially for new users). Anyway, luckily, the patch is there.

David Nemeskey (nemeskeyd) wrote :

I can confirm this in 7.04 Final. Manual mounting works, so this really must be a KDE bug.

Gianfranco Liporace (dr.kabuto) wrote :

I've the same bug with my work PC and a Samsung DVD burner. With my laptop at home no problem at all both with an internal DVD burner and an external one (Philips SCD-3000). On both machine I've Ubuntu 7.04 final.
HAL is the culprit for sure!

Gianfranco Liporace (dr.kabuto) wrote :

Hi,
tried the above patch, and worked for me.
Here a little guide with all the steps I done:

1. create a work directory:
$ mkdir builddir; cd builddir
1. download hal source package:
$ apt-get source hal
2. get the patch file attached in this comment and put it in builddir/hal/hal-0.5.8.1/debian/patches
3. rebuild hal:
$ cd hal/hal-0.5.8.1
$ dpkg-buildpackage -rfakeroot
4. install hal:
$ sudo dpkg -i *.deb

5. Test if is all ok.

Hi Gianfranco, can you mail me the .deb package of the patched hal daemon?

I can't get it to work on my kubuntu feisty..

Yes, Gianfranco, it's exactly the same Debian Etch patch I put in the bug report. However I'm not that convinced it's a hal related (or hal only) issue, since as I said on Xubuntu 7.04 this bug doesn't exist (on the same hardware of course).

I think will stick with Etch for the moment, until someone will change the status of this bug to "confirmed".

@Matteo:
in this <a href="http://digilander.libero.it/dr_kabuto/hal/">page</a> you should find the packages I've build.

@Davide:
I'll try xfce with a dvd disk when i'm at work.

Tried with xfce, and the result for me is almost the same as in Gnome, an icon popup on the desktop, but double-clicking on it an error appears.
Installing hal with the patch, all is working fine.

Bob (b-o-b-1962) wrote :

I recently installed Feisty and I use Gnome (so I think this is not just a Kubuntu bug). I see something similar to this. When I put in a data DVD it is mounted and a nautilus window appears with its contents. But it does not show up on the desktop or in the Nautilus sidebar (and thus I have to push the button on the drive to eject it). If I put in a data CD it does show up and I do not have this problem. I am sure it is not caused by any settings I have because I tried it on a totally stock new account and I still see the problem. I suspect it may be this same bug but I have not tried the Hal patch discussed above. Perhaps I will and report back.

kernowyon (kernowyon) wrote :

Three separate systems running Kubuntu 7.04 here, all had the same problem - no automounting of data DVDs, although I could manually mount them.
The Hal patch mentioned above fixed the issue on all machines here. I suggest the patched Hal is issued as soon as possible - having to manually mount data DVDs is a real problem for new users and a nuisance for the more experienced.

Basing on my experience, my opinion is that this bug will stay there for a long time.

So, if you want to stick with kubuntu, I posted a workaround here:

http://ubuntuforums.org/showthread.php?t=414825

hope it helps

FYI

Pardus Linux [http://www.pardus.org.tr/eng/] development team fixed this bug in a few days:

http://bugs.pardus.org.tr/show_bug.cgi?id=5633

Aljoša Vidmar (typhon) on 2007-07-01
Changed in hal:
assignee: nobody → typhon
status: New → Confirmed
kernowyon (kernowyon) wrote :

Good to see the problem is now confirmed and assigned.

Henrik Nilsen Omma (henrik) wrote :

Could someone who has experienced this problem test if it is fixed in Gutsy?

Thanks!

Changed in hal:
importance: Undecided → Medium

The bug is fixed if you install hal 0.5.9 from feisty backports repository.

Changed in hal:
assignee: typhon → nobody
status: Confirmed → Triaged
Fabián Rodríguez (magicfab) wrote :

The following command will give you a short listing and description of all your drives, including hard disks, external storage, card readers, etc for use while writing a custom /etc/fstab for manual configuration of mount points:
lshw -short -C disk

When run with sudo, you will get a detailed listing of partitions too.

sudo lshw -short -C disk

Changed in hal:
status: Unknown → Fix Released

Is this still an issue on gutsy and/or hardy?

Changed in hal:
status: Triaged → Incomplete
Dragomir Minkovski (dejuren) wrote :

I'm using Kubuntu Gusty and data DVD is mounting automatically, but there is no "eject" or "umount" entries in right-click drop-down menu.

Kurt von Finck (mneptok) wrote :

This is the behavior I see on 7.10 i386, current as this comment.

- DVDs inserted prior to KDE launch do not get auto-mounted. They are visible from the "Storage Media" pane in the System menu, and may be mounted or ejected from the right-click Actions menu. Once mounted, they appear on the desktop normally, and may be ejected with a right-click.

- DVDs inserted during a KDE session present the "New medium" dialog which allows a mount. Again, they may be ejected with a right-click.

I think it's confusing to the average user to have media inserted early in the boot process that they then must navigate the KDE System menu to actually mount. It would be nice to have the same "New medium" dialog during KDE startup. I have not tested with Hardy yet, so I can't actually propose this feature request.

Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Well, honestly I just gave up using internal optical units...when I need it (very seldom) I just use my USB connected one, which works 100%.

bye!

Davide

Connor Imes (ckimes) wrote :

Reading up in the comment list it sounds like a fix was released, and since the Debian portion of the bug is marked as so, it must have made its way downstream by now. I will mark the bug as Fix Released, thank you for reporting it.

Changed in hal:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.