Add Tablet PC support (patch included)

Bug #90451 reported by Andrew Lofthouse on 2007-03-07
14
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Wishlist
Martin Pitt
Declined for Gutsy by Henrik Nilsen Omma
Nominated for Hardy by Justin Dugger

Bug Description

Binary package hint: hal

OpenSUSE has a patch that adds some specific support to hal for Tablet PCs. One of those features is the addition of a new key (system.formfactor.subtype) and sets it to "tabletpc". This key is required to enable other features important to the use of a Tablet PC (such as rotation of the wacom pointers when using krandrtray, or showing a virtual keyboard when trying to unlock the screen). I'll be submitting patches to enable those features in other bug reports.

Attached is the patch downloaded from http://beta.suse.com/private/dkukawka. I've rebuilt the feisty hal package (hal-0.5.8.1-4ubuntu8) and verified that this patch applies and builds cleanly.

Related branches

Andrew Lofthouse (loftyhauser) wrote :

Here is the patch file...

Andrew Lofthouse (loftyhauser) wrote :

Bug #90455 requires this patch so if a tablet pc is detected by hal, a virtual keyboard is shown when the unlock display dialog is shown in KDE (so a user can input a password using the stylus).

Christian Kellner (gicmo) wrote :

Seconded!
From looking at the patch that would also have the very positive effect to make the wacom work withouth having to install the wacom tools package so a default installation would have a working tablet.
Also one wouldn't need the setserial package anymore.

Changed in hal:
status: Unconfirmed → Confirmed
Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.
According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .
The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage .

Changed in hal:
importance: Undecided → Wishlist
Changed in hal:
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

Forwarded to upstream MLfor commenting.

Martin,

I raised a bug a long time ago and seems I cannot unsubscribe from hal in ubuntu.
I'm desperate - is there any way I can unsubscribe please?

Thanks in advance :-)

--
petri c piton

----- Message d'origine ----
De : Martin Pitt <email address hidden>
À : <email address hidden>
Envoyé le : Mercredi, 5 Mars 2008, 20h14mn 40s
Objet : [Bug 90451] Re: Add Tablet PC support (patch included)

Forwarded to upstream MLfor commenting.

--
Add Tablet PC support (patch included)
https://bugs.launchpad.net/bugs/90451
You received this bug notification because you are subscribed to hal in
ubuntu.

      _____________________________________________________________________________
Ne gardez plus qu'une seule adresse mail ! Copiez vos mails vers Yahoo! Mail http://mail.yahoo.fr

Martin Pitt (pitti) wrote :

Hi Petri,

petri piton [2008-03-05 12:31 -0000]:
> I raised a bug a long time ago and seems I cannot unsubscribe from hal in ubuntu.
> I'm desperate - is there any way I can unsubscribe please?

You can do that on https://launchpad.net/ubuntu/+source/hal/+subscribe
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

My 5 today: #198295 (hal), #191725 (hal), #181832 (jockey), #154214
(language-pack-ru), #193978 (gnome-control-center, jockey)
Do 5 a day - every day! https://wiki.ubuntu.com/5-A-Day

Justin Dugger (jldugger) wrote :

http://lists.freedesktop.org/archives/hal/2008-March/011125.html

Given that upstream has accepted the patch, is it possible to accept it into Ubuntu in time for Hardy?

 status inprogress
 assignee pitti

Justin Dugger [2008-03-13 10:10 -0000]:
> Given that upstream has accepted the patch, is it possible to accept it
> into Ubuntu in time for Hardy?

Yes, that's the plan. I recently pushed upstream to include it,
and they are currently preparing hal 0.5.11. I'll update to this new
release (after Hardy beta, but well in time).

In the event that 0.5.11 won't land in time, I'll pull the patch
manually.

Changed in hal:
assignee: nobody → pitti
status: Triaged → In Progress
Martin Pitt (pitti) on 2008-03-21
Changed in hal:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal - 0.5.11~rc2-1ubuntu1

---------------
hal (0.5.11~rc2-1ubuntu1) hardy; urgency=low

  * Update our git snapshot from March 01 to current 0.5.11-RC2, which brings
    a few bug fixes.
    - Adds properties for tablet PCs (LP: #90451)
    - Fixes operation on MacBookPro third generation. (LP: #129869)
  * Remove patches applied upstream:
    - 02_allow_ufs_ufstype.patch
    - 05_fix_dell_brightness.patch
  * Adapt patches to new upstream version:
    - 96_uinput_device_support.patch
    - 96_uinput_device_support.patch
  * Merge with Debian unstable; see 0.5.10+git20080301-1ubuntu1 for remaining
    Ubuntu changes.
  * Replace 88_change_pm_quirk_policy.patch with
    01_default_suspend_quirks.patch: Only set the default suspend quirks for
    kernel problem workarounds if hal-info does not define any quirks at all
    for the hardware. (LP: #198808)

hal (0.5.11~rc2-1) unstable; urgency=low

  * New upstream release candidate
  * debian/libhal-storage1.{symbols,shlibs}, debian/libhal1.{symbols,shlibs}:
    - Updated symbols and shlibs

 -- Martin Pitt <email address hidden> Fri, 21 Mar 2008 13:39:03 +0100

Changed in hal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers