Ubuntu

HAL device manager does not produce portable output

Reported by Carthik Sharma on 2007-02-19
6
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Wishlist
Unassigned

Bug Description

The HAL device manager in System->Administration does not seem to produce any form of portable output. By portable output I mean a text file, a spreadsheet, a webpage or any data file that has all the information about the hardware on my computer.

See the output of the lshw command (at http://carthik.net/files/acer-5003.html ) for an example of how it could be.

I submitted the details to the Ubuntu Hardware Database, the url is http://hwdb.ubuntu.com/?xml=1113b141ddb5a45e05235134dd13a87a

The page has no details about my hardware, though the device manager reported success in submitting my hardware details correctly.

Oliver Grawert (ogra) wrote :

please use the hwdb-xml command if you want to produce local output, hwdb-client is a hardware database submission tool and not indended to create spreadsheets locally

Changed in hwdb-client:
status: Unconfirmed → Rejected
Matthew Paul Thomas (mpt) wrote :

Ah, this bug report was on the wrong package. The problem is that there is no way of invoking hwdb-xml from the menus. This would probably take the form of a "Save As..." command in the Device Manager's File menu.

Changed in hwdb-client:
status: Rejected → Unconfirmed
Martin Pitt (pitti) wrote :

A 'Save as...' could just invoke lshal and save its output.

Changed in hal:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Raptor Ramjet (ramjet) wrote :

I second the request to add a menu item to enable "Device Manager" to write the output to some sort of text file.

Personally I find it most frustrating to keep finding useful utilities that don't allow me to export the text ! Being able to do this from the command line is all well and good... but the GUI tool is supposed to make using the underlying commands easier !

Then again I think that all visible text in a desktop environment should be copy & pastable. And yes I do mean all text ! If I can read it, I should be able to copy it whether the text is on a control, button, window title, status bar, text area, browser window etc. etc.

Shawn (ogarro) wrote :

I'm wondering is any further effort has been put into this request ... with an ever increasing selection of hardware that is encountered from day to day working out what information is available from a "casual user" point of view can useful.

Another program that could be used as a very good example of a useful application is the "Unknown Devices" (http://www.halfdone.com/ukd/). It is currently a Windows Only application but I have all hopes that the author would be willing to share his insight with regards to what he has done.

dino99 (9d9) wrote :
Changed in hal (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers