Ubuntu

hal need to allowed utf8 option for ntfs fs

Reported by Florent Mertens on 2007-01-06
4
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: hal

In feisty, we use the hal mount backend to mount locale & removable device.
Ntfs partition & device are mount with the utf8 option, but this option is not
allowed in hal since it is not in volume.mount.valid_options, and so mounting
ntfs device is impossible.

/usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
need to allow the utf8 option for ntfs fs (just like for vfat fs)

Fredrik Schön (fredrikschon) wrote :

I second this problem. I have an USB drive with an NTFS partition that I have been unable to mount in Feisty. The attached patch against hal-0.5.8.1 works for me.

Caveat: Only tested by patching /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
live, but the attached patch against the source package should be equivalent.

Martin Pitt (pitti) on 2007-01-09
Changed in hal:
assignee: nobody → pitti
importance: Undecided → Medium
status: Unconfirmed → In Progress
Martin Pitt (pitti) on 2007-01-12
Changed in hal:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 hal (0.5.8.1-4ubuntu3) feisty; urgency=low
 .
   * debian/patches/30-mp3-player-fdi.patch: Clean up a bit.
   * Add debian/patches/17_hdm_bus_type.patch: Fix 'bus type' display in
     hal-device-manager. Closes: LP#26362
   * Add debian/patches/18_set-brightness_bashism.patch: Fix bashism in
     tools/linux/hal-system-lcd-get-brightness-linux to make brightness setting
     on Sony Vaio laptops work again. Closes: LP#68617
   * debian/hal-device-manager.desktop{,.in}: Since hal-device-manager does not
     actually manage anything, rename it to 'Hardware information'.
     Closes: LP#45247
   * debian/patches/30-mp3-player-fdi.patch: Add iAudio F2. Closes: LP#78546
   * debian/control: Add alternative build dependency 'libvolumeid-dev' for
     backportability.
   * Rename debian/patches/16_ntfs_allow_local_mount_option.patch to
     16_ntfs_allowed_mount_options.patch and add 'utf8'. Closes: LP#78142

Changed in hal:
status: Fix Committed → Fix Released
Fredrik Schön (fredrikschon) wrote :

Verified fixed in 0.5.8.1-4ubuntu3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers