Firewire/IEEE1394 conflict with Synaptics Touchpad and Synaptics Pointstick

Bug #74426 reported by Nicola Jelmorini on 2006-12-04
10
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Low
Unassigned

Bug Description

Hi,

I use Ubuntu Edgy on my HP Compaq nw9440 laptop. This laptop offer a Synaptics Touchpad (2 buttons) and a Synaptics Pointstick (3 buttons).

By chance I have discovered that when I want to use an external HD with Firewire connection, this is in conflict with the Touchpad and the Pointstick.

First situation (the laptop is turned off):
=======================
1) I turn on my laptop without external peripherals connected
2) I can use the Touchpad and the Pointstick normally without problems
3) now I connect an external HD with the Firewire/IEEE1394 cable and ... no automounting happen. No way to mount the HD.

Second situation (the laptop is turned off)
========================
1) I connect an external HD with the Firewire/IEEE1394 cable
2) I turn on my laptop
3) After login the external firewire HD is recognized and correctly automounted. This time I can use the HD normally without problems.
4) The Touchpad function well, but is no more possible to inhibit the double click
5) The Pointstick don't function at all. Only the buttons function, but the Pointstick itself no more.

I believe that this is a conflict.
If I turn on my laptop with the HD connected, I can use it, but I have problems with Synaptics hardware; to the contrary, if I turn on the laptop without the HD connected, I can use Synaptics hardware, but the HD is not recognized.

This issue don't happen with the USB interface.

Nicola Jelmorini (jelmorini) wrote :

I have just downloaded the last LiveCD Feisty Herd3 for testing, and I can say you that this problem is always present.

Nicola Jelmorini (jelmorini) wrote :

I have upgraded to Feisty and I can confirm that the problem is still present.
No way to mount an external firewire HDD with the laptop already turned on.
Instead I can mount an external firewire HDD connecting it before turning on the laptop.

Nicola Jelmorini (jelmorini) wrote :

If this can help, the theme of this bug is similar to these other bugs:

https://bugs.launchpad.net/hal/+bug/36274
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/110247

Peter Funk (pf-artcom-gmbh) wrote :

I had the same problem with Feisty.
But I found a workaround:

As Superuser I typed:
   rmmod sbp2
   modprobe sbp2
This had no effect at all. Than I tried:
   rmmod ohci1394
   modprobe ohci1394
Suddenly my firewire disk was recognized and the gnome
volume manager happily created all the icons for every partition on
that disk. After umounting them I tried to unplug and
replug the disk: now everything worked normally.
Side note: On my previous notebook (a Dell Inspiron 8000
with P III, on which I was running Debian 3.1 sarge until the
display cable broke), firewire was never an issue. Mysterious.

Nicola Jelmorini (jelmorini) wrote :

Hi Peter,

many thanks for your advice.
This workaround funtion for me too.

This can be a clue for look into this bug

mercutio22 (macabro22) wrote :

Peter.

Your workaround works for me as well

Thanks a lot!

mercutio22 (macabro22) wrote :

When starting the computer with the extenal Hard drive powered on, Nautilus can't automount its partitions (though it will if I turn it on AFTER logging in).

I would like to report this bug persists in Hardy Heron and Peter's workaround still works:

htorres@GLaDOS:~$ sudo rmmod ohci1394
htorres@GLaDOS:~$ sudo modprobe ohci1394

mercutio22 (macabro22) wrote :

Maybe Peter's workaround can give a clue on whats going wrong.

Changed in hal:
assignee: nobody → macabro22
status: New → Confirmed
assignee: macabro22 → nobody
Emmet Hikory (persia) on 2008-04-28
Changed in hal:
importance: Undecided → Low
Jo (jo-r) wrote :

Thanks Peter, just upgraded to Hardy and bug persists, but at least I can access my drive now.

Can you still reproduce this with supported Ubuntu versions?

Changed in hal (Ubuntu):
status: Confirmed → Incomplete
Nicola Jelmorini (jelmorini) wrote :

Hi Thomas,

no, I'm sorry, I don't use no Firewire device anymore.

I am closing this bug. Please feel free to report any problem you encounter in Ubuntu. Thank you!

Changed in hal (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers