Users do not have permission to open files in DVDs burnt in a Mac

Bug #72872 reported by Timothy Miller on 2006-11-22
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
hal (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by Mat Tomaszewski

Bug Description

11/06/09: I wanted to add to the description of this bug as someone who has just begun using Ubuntu.

I burnt DVDs of all the files I wanted to work with on my Mac and was unable to access them in Ubuntu, although I can see the folders. Ubuntu says I don't have permission to see the files. I think this is a huge barrier to use. If we are aiming to get people to switch, many people will back up their files on CD/DVD and wish to access them within Ubuntu. If they then can't access them and there is no way to fix this, this will be a major source of frustration.

Alejandra

Original description:

There may be something quirky about this DVDROM in the way that it was burned, although I was not aware that UNIX file permissions were part of the file format. However, the situation I'm observing should never happen, regardless of what permissions are actually on the disc.

When I insert this disc, the system finds it automatically, and I can browse the directories. But when I try to copy a file, it tells me that I don't have permission to do so. When I type 'ls /media/cdrom0/...', I find that the permissions on all files is -rwx------.

If I use 'sudo cp ...' to copy a file from it, it works just fine. It's just that the logged-in user cannot access the files.

Carthik Sharma (carthik) wrote :

Could you please upload your /etc/fstab file? Maybe when the cdrom is mounted, it is mounted with the wrong permissions.

You can try to remount the cdrom with the correct permissions - check the man page for mount for details.

Timothy Miller (theosib) wrote :

There's nothing special in my /etc/fstab file. Here's the relevant line:

/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0

And in addition, other DVDs and CDs don't have this problem. Just that one that I burned on a Mac.

So, basically, the Mac put the wrong permissions on all of the files on the DVD.

Don't dismiss this, however, as "just a bad disc." It makes absolutely no sense to burn a CDROM with permissions so that you can't read the files, and so therefore, it makes no sense to mount one that way. This absurd situation is one that should be worked around via, perhaps, mount options (which don't seem to exist).

In other words, the OS should not allow stupid but preventable things to happen, evne when it's not technically the OS's fault. Aside from, perhaps, the execute flag, all other permissions flags on CDROMs are meaningless and should therefore be treated that way (ignored).

Omar Shami (bigfox) wrote :

I have also noticed this problem. Also with disks burned on the Mac.

I have noticed this problem on thumb drives with files written by the Mac as well.

It seams that Ubuntu is respecting the permissions that Mac put on the disk.

It might be a good idea to ignore permissions on all removable media as it is pointless to forbid access to something the user has physical control over.

Timothy Miller (theosib) wrote :

Note that I've submitted a complementary bug report to Apple. Don't count on them fixing it, though -- you know how it is with the proprietary vendors. So Ubuntu should take the high ground on this one.

Timothy Miller (theosib) wrote :

I've been in contact with someone at macfixit.com about this. They track MacOS bugs. They did some experiments and couldn't reproduce the problem. Could someone else try to see if, for instance, the original permissions of the files being burned are consistent with what's on the disk and that the burner on the Mac is just preserving them? If so, then the problem really is just Ubuntu, respecting permissions that make no sense under the circumstances.

Yeah, I appear to be having this problem as well (but have no idea if the CD was burnt on a Mac). Standard /etc/fstab entry, but CD mounts with all files permissions 700, and with userid and group 501 and dialout on all files. Very annoying.

But is this really just a wishlist item? Surely this is a classic "will completely flummox a non-technical user" type problem which goes against the core Ubuntu philosophy. The *importance* is obviously related to the proportion of CDs/DVDs that may have this problem (doesn't seem that clear yet), but I don't see how this can be wishlist only?

Any comments from bug maintainer(s)?

Timothy Miller (theosib) wrote :

I'm definitely an experienced user, but this one definitely flummoxed me for longer than I would like to admit. I would never have expected something like this would happen, so it stumped me. It doesn't seem logical that a read-only removable device would show up with permissions like this.

Mat Tomaszewski (mat.t.) wrote :

This is a serious bug that prevents users from achieving a simple goal for no apparent reason. It also lowers compatibility marks for Ubuntu. I think this is a high-priority fix.

Changed in hal (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Confirmed
summary: - Insert CD -- mounts with all file permissions -rwx------
+ Users do not have permission to open files in DVDs burnt in a Mac
description: updated
description: updated
Alejandro Vidal (mancvso) wrote :

not only on MAC, confirmed on Windows too

on virus files, (that I have to delete via sudo) and ext formatted external hard disk, so Linux too.

sighK (staxjp) wrote :

Before you go to burn the disk, make sure the file permissions have other as read write execute. This worked for me. Linux is doing what is is supposed to do. Security is only good on the system as long as you keep permissions.

Timothy Miller (theosib) wrote :

In my case, the DVD was burned on a Mac, and there were no odd permissions on the files. It may be that the Mac did the wrong thing when it created the ISO. In that case, this comes down to a compatibility issue. Sometimes, you have to bite the bullet and work around someone else's bug.

Alan Bell (alanbell) wrote :

would such a CD be readable on another Mac or by another user on the same Mac? It would seem possible to have a CD with different files on it owned by different users so different files would be available to different users. Maybe on mount of a CD with file permissions there could be an option to not respect the permissions on the CD.

I'm not an expert on CD/DVD file systems, but it seems to me that we need to nail down the real technical issues here (and whether this is actually a bug -- see below). From my (limited) understanding:

-- CDs/DVDs are typically burnt with ISO 9660 filesystems and most OSs support (some aspects of) the Joliet and Rock Ridge extensions

-- the Rock Ridge extensions include UNIX file permission details

-- Mac OS X, in some circumstances, burns an HFS Plus (Mac OS Extended) / ISO 9660 hybrid format. See http://support.apple.com/kb/TA21176?viewlocale=en_US :

"With Mac OS X 10.2.8 or earlier, DVD-R discs burned in the Finder are Mac OS Extended format (HFS Plus). With Mac OS X 10.3 or later, they are a HFS Plus/ISO 9660 hybrid format, which can be read by most computer systems, including Microsoft Windows. The disc contains these filesystems: HFS+, ISO-9660 with Rock Ridge, and Joliet with Rock Ridge."

I don't know/understand the full details of Linux Rock Ridge support, but doesn't this bug depend on an understanding of this? Either:

a) the disc is Rock Ridge with permissions which Linux is *correctly* honouring
(i.e. not a bug; this assumes that this is how Rock Ridge is supposed to work, both in general and on Linux)

b) as (a) but Linux should not honour them in certain cases and this represents one of those cases (i.e. an incorrect/incomplete support of the Rock Ridge standards; question is what's specific about these discs to cause this not to work)

c) the disc has permissions reflected in some other way (e.g. the hybrid mentioned earlier) and Linux is correctly honouring them (e.g. as per HFS Plus or whatever). *Possibly* no bug, unless it's taken that this honouring is non-sensical in this case (e.g. for Mac OS X specific permissions when you're not reading it on OS X)

d) Linux is incorrectly interpreting some file system data as implying permissions when it doesn't (so issue is a deeper file system interpretation and standards support one, and question as in (b) applies)

e) something else (OK, I copped out here!)

Hope this might help others progress this. Unfortunately, I don't have/remember which disc caused me this problem originally....

Just to add that common sense would suggest that any permissions are purely to enable them to be reconstructed when copying/restoring from the media (and not to actually affect access on the disc, since this becomes meaningless on other physical machines and can easily be bypassed).

But, as I said, I'm no expert on the original intentions of these various standards and their implementations. It's not so clear cut when you think about the grey area of removable HDDs (one could argue that CD/DVD enforced permissions make sense in scenarios where this is control over physical access to the media e.g. disc can't leave a certain room with one PC, where you may *want* to enforce permissions).

Sorry, perhaps a little philosophical, but just stressing the point that a clear understanding/statement of the technical requirements (and their interpretation by Linux/Ubuntu) is needed.

Timothy Miller (theosib) wrote :

I can verify that the DVD I burned was in fact readable on other Macs.

ThePhilips (thephilips) wrote :

> I can verify that the DVD I burned was in fact readable on other Macs.

That is not surprising: Mac OS X ignores permissions on all external media. It's simple as that.

I had this problem in past and not only with content from Mac OS X. E.g. if would you make external hard drive with Ext2 file system, you will have problems sharing files on it between Linux desktops as user/group ids on different desktops are not guaranteed to match.

Solution - file systems need a special mount option to allow to ignore permission for case of external storage. Then mount command needs to be updated with the option (and obviously mount syscall with the new flag).

Only serious problem is how in Linux to differentiate between external and internal storage. Last thing I'd want is for permissions on my local hard drive to stop working.

Torsten Landschoff (torsten) wrote :

This problem has also bugged me, albeit on Debian. And I spent an hour or two to do it "the right way" and get UDF (in that case) to ignore the permissions on the filesystem.

After playing with mount options to no avail, I finally gave up and became root to get the discs content copied.

I think it really sucks to enter an optical disc and be unable to read it because of permission problems. There should be a mount option to ignore permissions for udf and iso9660 and this should be enabled per default in fstab. The thing is: This will probably need kernel changes...

I don't have a mac DVD at hand, but have all the options for iso 9660 in "man mount" been tried?

Can we try "norock", "nojoliet" and "uid=" and "gid=" (putting these one at a time in /etc/fstab or remounting manually. I don't know if plain "uid=" without specific UID will replace with current will work automatically. gid=cdrom might be a solution.

I also can't believe that this problem exists and hasn't been solved somewhere before on LInux.

Sorry for spamming, but for those affected, in gconf-editor go to the following directory of configuration keys:

system -> storage -> default_options

What do iso9660 and udf say? mine say plain uid= (presumably replaced by current uid), which sounds like it should work.

Ctbeiser (ctbeiser) wrote :

I've experienced this with an ISO file that was on a flash drive.

yoda2031 (yoda2031-hotmail) wrote :

Workaround:
sudo mount /dev/cdrom /media/cdrom -o rw,uid=`id -u USERNAME`,gid=`id -g USERNAME`,loop

If necessary, add -t iso9660 (but I've found that actually -breaks- the command sometimes!).

Note: replace USERNAME with your user name (obviously); I've provided gid's equivalent for reference but you needn't include it for this workaround (if all you need is access to the files).

Ron Johnson (ron-l-johnson) wrote :

This affects me, a Debian Sid user, on DVD-R disks burned with a Toshiba DVR, but not on real DVDs burned at the factory.

Attached is an example of how the DVD-R looks when mounted as ls'ed from root and then ls'ed from a $USER.

$ uname -a
Linux haggis 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux

I'm closing the paper cut task here since this is not an issue that is going to affect the majority of Ubuntu users, nor does it appear to be trivially fixable.

Changed in hundredpapercuts:
status: Confirmed → Invalid
importance: High → Undecided
dino99 (9d9) wrote :
Changed in hal (Ubuntu):
status: Confirmed → Invalid
Mike (0x656b694d) wrote :

Ubuntu 14.10 cannot read DVD recorded on a DVD recorder:
/media/papa$ ls -la
total 10
drwxr-x---+ 3 root root 4096 апр. 3 23:29 .
drwxr-xr-x 5 root root 4096 окт. 1 2014 ..
dr-------- 3 papa papa 152 дек. 12 2010 DVR5000

$ mount
/dev/sr0 on /media/papa/DVR5000 type udf (ro,nodev,nosuid,uid=1001,gid=1001,iocharset=utf8,umask=0077,uhelper=udisks2)

Mike (0x656b694d) wrote :

This makes the files visible:
sudo mount /dev/cdrom /media/cdrom/ -o ro,mode=444,dmode=555

Not sure though if my issue is related to this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers