headphone detection is mangled on powerbook

Bug #59710 reported by Robert Persson on 2006-09-09
6
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Sense Egbert Hofstede

Bug Description

Headphone detection is mangled on my wallstreet II powerbook under alsa in dapper. Headphone detection works on removal, but not on insertion. I believe this to be a known issue with alsa on powerbooks.

The headphone detection button is greyed out in gamix. It appears to work in alsamixer, insofar as pressing "m" changes its state as displayed on the console, but this makes no difference to how headphone detection works in practice.

When a plug is inserted in the headphone/line socket nothing happens.

When a plug is removed from the socket then this is detected, the line output is disabled and, if auto-mute is enabled, the internal speakers are enabled.

Sometimes the machine behaves as if the plug has been removed from the headphone socket after a sleep, even though the plug has not been removed. I have not yet precisely identified the conditions under which this does or does not happen.

Sense Egbert Hofstede (sense) wrote :

Thank you for reporting this bug. However, we still need some more information before we can pass it on to the developpers.
Before you insert the headphone, please execute the command 'lshal -m' in a terminal. This will display all HAL actions. Keep the terminal open and plug now the headphone.
Put the ouput of 'lshal' (another command) in a file.
Now unplug the headphone again and put the output of lshal -m in a file and attach that, with the output of these commands and files:
/var/log/kern.log
cat /proc/asound/cards
uname -r
sudo lspci -vvnn

Thanks in advance
(Please put the results in separate files, it doesn't matter if you have to reply multiple times.)

Changed in hal:
assignee: nobody → qense
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in hal:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers