On Thinkpad X60s and Z60 SD card reader doesn't work

Bug #53268 reported by geos on 2006-07-17
26
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

As reported in this thread:

http://www.ubuntuforums.org/showthread.php?t=214157

the SD card reader appears to work when you boot up with a card in the reader: auto-mounting the card on the desktop from device "mmcblk0p1," as reported in mtab. But when you try to use it by inserting a card after booting it doesn't work. If you look in syslog you get the following error:

Jul 14 08:06:06 localhost kernel: [17181004.392000] mmcblk0: mmc0:4b84 S016B 14560KiB <NULL>
Jul 14 08:06:06 localhost kernel: [17181004.492000] generic_make_request: Trying to access nonexistent block-device mmcblk0 (2892...

Carthik Sharma (carthik) wrote :

Is this related to Bug #48218?

Can you please attach the relavant portion from your syslog?

i am experimented some more...i don't think it is related to the other bug
since nothing bad happens...

if you boot with a sd card in the reader it will automount and work
perfectly. but if you take the sd card and put it back in it will not
make the device /dev/mmcblk0p1 which is what is actually mounted, there
will be a device /dev/mmcblk0. if you then look at syslog the relevant
sections will read

Jul 14 08:06:06 localhost kernel: [17181004.392000] mmcblk0: mmc0:4b84
S016B 14560KiB <NULL>
Jul 14 08:06:06 localhost kernel: [17181004.492000] generic_make_request:
Trying to access nonexistent block-device mmcblk0 (2892...

if you boot without a sd card in the reader it will load the sdhci and
mmc_core modules but it will not create the device /dev/mmcblk0. if you
put in a sd card nothing will happen, however if you remove and reload the
sdhci and mmc_core modules you can insert a card and mount it and it will
work perfectly...

On Mon, 17 Jul 2006, Carthik Sharma wrote:

> Is this related to Bug #48218?
>
> Can you please attach the relavant portion from your syslog?
>
> ** Changed in: Ubuntu
> Status: Unconfirmed => Needs Info
>
> --
> On Thinkpad X60s and Z60 SD card reader doesn't work
> https://launchpad.net/bugs/53268
>

Timo Kosig (tiomo) wrote :

I can confirm the bug as described on my ASUS A6Q00K laptop. The card reader is also a Ricoh.

I also have this problem on dapper amd64: my SD card does not automount (I am using the card reader in my HP PSC 2410 multifunction printer).

**It always worked perfectly on hoary and breezy.** (the only difference is a new 64bit motherboard, but the printer/card reader is the same).

This is the dmesg output (you can see that device /dev/sdd1 is created):

[ 4949.184733] usb 1-1: new full speed USB device using uhci_hcd and address 2
[ 4949.440610] drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x03F0 pid 0x3611
[ 4949.441218] usbcore: registered new driver usblp
[ 4949.441236] drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver[ 4949.470801] Initializing USB Mass Storage driver...
[ 4949.471436] scsi4 : SCSI emulation for USB Mass Storage devices
[ 4949.471737] usb-storage: device found at 2
[ 4949.471740] usb-storage: waiting for device to settle before scanning
[ 4949.471750] usbcore: registered new driver usb-storage
[ 4949.471753] USB Mass Storage support registered.
[ 4954.468734] Vendor: HP Model: psc 2410 Rev: 1.00
[ 4954.468752] Type: Direct-Access ANSI SCSI revision: 02
[ 4954.482739] sd 4:0:0:0: Attached scsi removable disk sdd
[ 4954.482797] sd 4:0:0:0: Attached scsi generic sg3 type 0
[ 4954.483457] usb-storage: device scan complete
[ 4966.724536] SCSI device sdd: 1984000 512-byte hdwr sectors (1016 MB)
[ 4966.727530] sdd: Write Protect is off
[ 4966.727593] sdd: Mode Sense: 17 00 00 08
[ 4966.727655] sdd: assuming drive cache: write through
[ 4966.737516] SCSI device sdd: 1984000 512-byte hdwr sectors (1016 MB)
[ 4966.740508] sdd: Write Protect is off
[ 4966.740570] sdd: Mode Sense: 17 00 00 08
[ 4966.740632] sdd: assuming drive cache: write through
[ 4966.740714] sdd: sdd1
[ 5031.199636] SCSI device sdd: 1984000 512-byte hdwr sectors (1016 MB)
[ 5031.202634] sdd: Write Protect is off
[ 5031.202639] sdd: Mode Sense: 17 00 00 08
[ 5031.202641] sdd: assuming drive cache: write through
[ 5031.207620] SCSI device sdd: 1984000 512-byte hdwr sectors (1016 MB)
[ 5031.210616] sdd: Write Protect is off
[ 5031.210677] sdd: Mode Sense: 17 00 00 08
[ 5031.210740] sdd: assuming drive cache: write through
[ 5031.210820] sdd: sdd1
[ 5071.417453] end_request: I/O error, dev fd0, sector 0

MB (mangoblues) wrote :

To add to my previous post (dapper amd64 with HP PSC 2410) I confirm that the SD card is mounted properly when the card is inserted at boot time.

Please fix this bug; as I said it worked before.

Thanks in advance.

Jonas Ådahl (jadahl) wrote :

I can confirm this behaviour on my BenQ Joybook S61 (intel centrino duo).

Relevant lspci output:
0000:0a:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
0000:0a:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)

Ro (robert-markula) wrote :

Confirmed on an IBM/Lenovo Thinkpad Z61m with edgy.
SD Card doesn't get mounted when inserted after boot-up.

On inserting the card, syslog tells me:
kernel: [17229846.336000] tifm_7xx1: sd card detected in socket 1

On removing the card:
kernel: [17229912.028000] tifm_7xx1: demand removing card from socket 1

---

I found a workaround on the german ubuntu forums: Add the module 'tifm_sd' to /etc/modules and restart. Now this module gets loaded on sys bootup and it works. The card reader is found as /dev/mmcblk0 and mounted automatically on card insert.

syslog now tells me:
kernel: [17180137.452000] tifm_7xx1: sd card detected in socket 1
NetworkManager: <debug info>^I[1165302761.207025] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/pci_104c_803b_mmc_host').
kernel: [17180138.372000] mmcblk0: mmc1:a95c SD128 123008KiB
kernel: [17180138.372000] mmcblk0: p1
NetworkManager: <debug info>^I[1165302762.148697] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/pci_104c_803b_mmc_host_mmc_card_rca43356').
kernel: [17180138.456000] mmcblk0: error 4 sending stop command
kernel: [17180138.456000] end_request: I/O error, dev mmcblk0, sector 246008
kernel: [17180138.456000] Buffer I/O error on device mmcblk0, logical block 30751
kernel: [17180138.460000] mmcblk0: error 4 sending stop command
kernel: [17180138.460000] end_request: I/O error, dev mmcblk0, sector 246008
kernel: [17180138.460000] Buffer I/O error on device mmcblk0, logical block 30751
kernel: [17180138.460000] mmcblk0: error 4 sending stop command
kernel: [17180138.460000] end_request: I/O error, dev mmcblk0, sector 246008
kernel: [17180138.460000] Buffer I/O error on device mmcblk0, logical block 30751
NetworkManager: <debug info>^I[1165302762.321405] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/pci_104c_803b_mmc_host_mmc_card_rca43356_storage').
NetworkManager: <debug info>^I[1165302766.773853] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/volume_part1_size_125910528').

This is the relevant syslog when removing the card:
kernel: [17180238.980000] tifm_7xx1: demand removing card from socket 1
NetworkManager: <debug info>^I[1165302862.713372] nm_hal_device_removed (): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_part1_size_125910528').
NetworkManager: <debug info>^I[1165302862.713947] nm_hal_device_removed (): Device removed (hal udi is '/org/freedesktop/Hal/devices/pci_104c_803b_mmc_host').
NetworkManager: <debug info>^I[1165302862.721159] nm_hal_device_removed (): Device removed (hal udi is '/org/freedesktop/Hal/devices/pci_104c_803b_mmc_host_mmc_card_rca43356').
NetworkManager: <debug info>^I[1165302862.721891] nm_hal_device_removed (): Device removed (hal udi is '/org/freedesktop/Hal/devices/pci_104c_803b_mmc_host_mmc_card_rca43356_storage').

Ian Jackson (ijackson) wrote :

This bug affect my mother's HP Pavilion laptop too.

permafrost91 (permafrost91) wrote :

adding 'tifm_sd' to /etc/modules does not automatically mount the card after reboot on my X60 running Feisty (I can manually mount the card though)

I can confirm this bug exists on ASUS M6VA on Feisty Beta. When I load sdhci or tifm_sd system creates /dev/mmcblk0p1 but automount doesn't work.

root@asus:~# lspci|grep Ric
02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
02:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
02:01.2 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
02:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)
02:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 03)

root@asus:~# lsmod|grep sdhci
sdhci 18700 0
mmc_core 26756 2 sdhci,mmc_block

syslog:
Apr 6 19:17:54 asus kernel: [ 3563.624000] sdhci: Secure Digital Host Controller Interface driver
Apr 6 19:17:54 asus kernel: [ 3563.624000] sdhci: Copyright(c) Pierre Ossman
Apr 6 19:17:54 asus kernel: [ 3563.624000] sdhci: SDHCI controller found at 0000:02:01.2 [1180:0822] (rev 17)
Apr 6 19:17:54 asus kernel: [ 3563.624000] ACPI: PCI Interrupt 0000:02:01.2[C] -> GSI 18 (level, low) -> IRQ 20
Apr 6 19:17:54 asus kernel: [ 3563.628000] mmc0: SDHCI at 0xfeafb400 irq 20 DMA
Apr 6 19:17:54 asus NetworkManager: <debug info>^I[1175876274.345889] nm_hal_device_added (): New device added (hal udi is '/org/freedesktop/Hal/devices/pci_1180_822_mmc_host').
Apr 6 19:17:54 asus kernel: [ 3563.956000] mmcblk0: mmc0:b368 SDC 4020224KiB
Apr 6 19:17:54 asus kernel: [ 3563.956000] mmcblk0: p1

root@asus:~# ls /dev/mmcblk0*
/dev/mmcblk0 /dev/mmcblk0p1

and with timfm_sd

root@asus:~# lsmod|grep mmc
mmc_block 13832 0
mmc_core 26756 2 mmc_block,tifm_sd

Apr 6 15:11:48 asus kernel: [ 105.232000] mmc0: SDHCI at 0xfeafb400 irq 20 DMA
Apr 6 15:11:48 asus kernel: [ 105.252000] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
Apr 6 15:11:48 asus kernel: [ 105.252000] PCI: Setting latency timer of device 0000:00:1b.0 to 64
Apr 6 15:11:48 asus kernel: [ 105.648000] cs: IO port probe 0x100-0x3af: clean.
Apr 6 15:11:48 asus kernel: [ 105.652000] cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
Apr 6 15:11:48 asus kernel: [ 105.652000] cs: IO port probe 0x820-0x8ff: clean.
Apr 6 15:11:48 asus kernel: [ 105.652000] cs: IO port probe 0xc00-0xcf7: clean.
Apr 6 15:11:48 asus kernel: [ 105.652000] cs: IO port probe 0xa00-0xaff: clean.
Apr 6 15:11:48 asus kernel: [ 105.656000] mmcblk0: mmc0:b368 SDC 4020224KiB
Apr 6 15:11:48 asus kernel: [ 105.656000] mmcblk0: p1

Hope this helps

Could it be udev rule problem? Can anyone check 65-persistent-storage.rules?

9johnny (s.j.) wrote :

I am using feisty here, and I am experiencing the same issue. I can mount the device /dev/mmcblk0p1 , but it doesn't get automounted.
I would think this is hal HAL issue, tho, because udev does make the device node for it. Or maybe HAL doesn't automount it because it only looks for /dev/sd* and /dev/hd* devices?

here is some extra information:
$ uname -a
Linux minitux 2.6.20-14-generic #2 SMP Mon Apr 2 20:37:49 UTC 2007 i686 GNU/Linux

$ lspci |grep -i mmc
02:01.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)

syslog relevant info:
when I put the card in, I get these two lines:
Apr 8 17:51:21 minitux kernel: [44810.456000] mmcblk0: mmc0:e239 SQ01G 967680KiB
Apr 8 17:51:21 minitux kernel: [44810.456000] mmcblk0: p1

9johnny (s.j.) wrote :

Also, this is a dell inspiron 640m notebook, and this is happening with an SD card, is it normal that SD cards get the /dev/mmcblk* device nodes?

Ro (robert-markula) wrote :

Can someone set this to a higer priority? Ubuntu is a beginner-friendly distribution, and as such the end-user shouldn't have to be bothered with mounting devices. Alas, SD cards (and the like) are more and more common. Not only in the extremly popular digital camera market, but also on mobile phones, MP3 players and the like. What I want to say is that we can assume a widespread use of SD card reading, and if automount doesn't work, this would be a serious flaw if not fixed in feisty final.

9johnny (s.j.) wrote :

Why does this bug belong to linux-source-2.6.15? This is definitely not a kernel bug, and even if it is, it still happens in feisty, which has 2.6.20. This is not a kernel bug, the drivers are loaded properly and the SD card can be mounted manually. I think this is a HAL/dbus bug.

9johnny (s.j.) wrote :

This bug is surely not in the kernel, as the driver is loaded fine, and the device node is created properly.

zulfajuniadi (zulfajuniadi) wrote :

I'm currently using feisty on my Compaq nx6120. This also happens. My card reader use to work under Dapper and Edgy, so yes, I think this is a bug since it occured after installing Feisty.

I agree, it's not kernel bug. Most likely it's udev rule or hal/dbus bug. Since this bug affected a lot of people, I would change the priority and tell mainteners to see the difference from early versions.

tated13 (tate-dave) wrote :

i can't even mount the sd reader

i get the following in syslog

Apr 12 22:02:20 tated-laptop kernel: [ 1209.920000] mmcblk0: mmc0:45c1 SD01G 1006080KiB
Apr 12 22:02:20 tated-laptop kernel: [ 1209.920000] mmcblk0: p1

9johnny (s.j.) wrote :

You should be able to mount the reader by mounting /dev/mmcblk0p1 , tell me if it worked, as this might be two separate bugs mixed. I am complaining because the card reader doesn't get automatically mounted. If I recall clearly, this is a regression, as in earlier feisty it did mount.

Martin Pitt (pitti) wrote :

Please do the steps in https://wiki.ubuntu.com/DebuggingRemovableDevices and attach the logs. Thank you!

Changed in hal:
status: Confirmed → Needs Info

I can confirm that last updated fixed the issue. I see SD icon on desktop and can access it without any problems. Thank you guys for fast resolution.

Martin Pitt (pitti) wrote :

Thanks for checking again! Closing.

Changed in hal:
status: Needs Info → Fix Released
9johnny (s.j.) wrote :

I can confirm it's fixed. Now I plug in my SD card and get a prompt asking me is I want to import photos, perfect!
Thanks!

monkeytech (jamie-monkeytech) wrote :

I am still having issues with sd card with toshiba M100

log of dmeg

[ 1517.948000] end_request: I/O error, dev mmcblk0, sector 239
[ 1517.948000] mmcblk0: error 1 sending read/write command
[ 1517.948000] end_request: I/O error, dev mmcblk0, sector 240
[ 1518.976000] tifm_7xx1: sd card detected in socket 1
[ 1519.176000] mmcblk0: mmc1:1b37 SD512 500224KiB
[ 1519.176000] mmcblk0: p1

this is the log:

11:01:09.457 [I] osspec.c:232: SEQNUM=2465, ACTION=add, SUBSYSTEM=pcmcia, DEVPATH=/sys/devices/pci0000:00/0000:00:14.4/0000:02:04.0/0.0, DEVNAME=, IFINDEX=0
11:01:09.457 [I] hotplug.c:202: /sys/devices/pci0000:00/0000:00:14.4/0000:02:04.0/0.0 is a bus device (devpath)
11:01:09.457 [I] physdev.c:1511: phys_add: subsys=pcmcia sysfs_path=/sys/devices/pci0000:00/0000:00:14.4/0000:02:04.0/0.0, parent=0x08087b78
11:01:09.457 [E] util.c:469: Cannot read from '/sys/devices/pci0000:00/0000:00:14.4/0000:02:04.0/0.0/prod_id3'
11:01:09.458 [E] util.c:469: Cannot read from '/sys/devices/pci0000:00/0000:00:14.4/0000:02:04.0/0.0/prod_id4'
11:01:09.520 [I] physdev.c:1436: Add callouts completed udi=/org/freedesktop/Hal/devices/pcmcia__1__1
11:01:09.520 [I] hald.c:82: Added device to GDL; udi=/org/freedesktop/Hal/devices/pcmcia__1__1
11:01:09.529 [W] hald_dbus.c:87: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pcmcia__1__1
11:01:09.529 [W] hald_dbus.c:87: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pcmcia__1__1
11:01:09.532 [W] hald_dbus.c:87: No property info.capabilities on device with id /org/freedesktop/Hal/devices/pcmcia__1__1

Medvesonok (design-m) wrote :

Toshiba Portege M100
SD port exist in hardware, but SD insert/remove doesn't make it availiable , and it don't appeared in /dev

By the way, same don't work IRDA port. And it doesn't exist in hardware.

Can I manually to attach it and which commands? I read PCIcntrl, setpci, but don't understand "HOW TO".
Help,please. More detailed instruction by manual mounting SD and IRDa, then in man description.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers