hald-probe-input assert failure: *** glibc detected *** /usr/lib/hal/hald-probe-input: munmap_chunk(): invalid pointer: 0x080492f9 ***

Bug #500723 reported by steubens on 2009-12-27
500
This bug affects 93 people
Affects Status Importance Assigned to Milestone
hal (Debian)
Fix Released
Unknown
hal (Ubuntu)
High
Martin Pitt
Lucid
High
Martin Pitt

Bug Description

Binary package hint: hal

just started doing it after upgrading to 10.04

ProblemType: Crash
Architecture: i386
AssertionMessage: *** glibc detected *** /usr/lib/hal/hald-probe-input: munmap_chunk(): invalid pointer: 0x080492f9 ***
Date: Sun Dec 27 00:15:06 2009
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/hal/hald-probe-input
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
Package: hal 0.5.14-0ubuntu1
ProcCmdline: /usr/lib/hal/hald-probe-input
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
Signal: 6
SourcePackage: hal
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
Tags: ubuntu-unr lucid
Title: hald-probe-input assert failure: *** glibc detected *** /usr/lib/hal/hald-probe-input: munmap_chunk(): invalid pointer: 0x080492f9 ***
Uname: Linux 2.6.32-9-generic i686
UserGroups:

steubens (steubens) wrote :

StacktraceTop:
 __kernel_vsyscall ()
 *__GI_raise (sig=6)
 *__GI_abort () at abort.c:92
 __libc_message (do_abort=2,
 malloc_printerr (action=<value optimized out>,

Changed in hal (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
tags: added: iso-testing
tags: added: bugpattern-needed
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed to public.

visibility: private → public
Changed in hal (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) on 2010-01-18
Changed in hal (Ubuntu):
status: Triaged → In Progress
importance: Medium → High
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Argh, just after I figured it out I noticed that it's already fixed in trunk and Debian.

Changed in hal (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal - 0.5.14-0ubuntu3

---------------
hal (0.5.14-0ubuntu3) lucid; urgency=low

  * Add 00git_probe-input_crash.patch: Fix crash in hald-probe-input.
    (LP: #500723)
 -- Martin Pitt <email address hidden> Tue, 19 Jan 2010 21:20:49 +0100

Changed in hal (Ubuntu Lucid):
status: Fix Committed → Fix Released
Christophe Dumez (hydr0g3n) wrote :

Are you sure this is fixed?

I got *ubuntu3 update of hal today via update. I have rebooted after that and apport still reported a crash on start up.
However, this time, I cannot get crash debug via apport because it says that it crashes on an ASSERT now and it is not meant to report this kind of crash.

I do not think the bug is fixed and I think I hit an assert now.

Christophe Dumez (hydr0g3n) wrote :

Nevermind my previous message. I tried to reboot again and I did not get any crash.

I don't know why I got the apport message before but it was probably outdated. Sorry for the inconvenience.

Phill Whiteside (phillw) wrote :

Can also confirm no longer crashing on re-boot of 10.04 today :-)
Thanks folks !!

Changed in hal (Debian):
status: Unknown → Confirmed

Also working for me.

On Fri, Jan 22, 2010 at 6:33 AM, Bug Watch Updater <
<email address hidden>> wrote:

> ** Changed in: hal (Debian)
> Status: Unknown => Confirmed
>
> --
> hald-probe-input assert failure: *** glibc detected ***
> /usr/lib/hal/hald-probe-input: munmap_chunk(): invalid pointer: 0x080492f9
> ***
> https://bugs.launchpad.net/bugs/500723
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “hal” package in Ubuntu: Fix Released
> Status in “hal” source package in Lucid: Fix Released
> Status in “hal” package in Debian: Confirmed
>
> Bug description:
> Binary package hint: hal
>
> just started doing it after upgrading to 10.04
>
> ProblemType: Crash
> Architecture: i386
> AssertionMessage: *** glibc detected *** /usr/lib/hal/hald-probe-input:
> munmap_chunk(): invalid pointer: 0x080492f9 ***
> Date: Sun Dec 27 00:15:06 2009
> DistroRelease: Ubuntu 10.04
> ExecutablePath: /usr/lib/hal/hald-probe-input
> InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386
> (20091028.4)
> Package: hal 0.5.14-0ubuntu1
> ProcCmdline: /usr/lib/hal/hald-probe-input
> ProcEnviron: PATH=(custom, no user)
> ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
> Signal: 6
> SourcePackage: hal
> StacktraceTop:
> __kernel_vsyscall ()
> raise () from /lib/tls/i686/cmov/libc.so.6
> abort () from /lib/tls/i686/cmov/libc.so.6
> ?? () from /lib/tls/i686/cmov/libc.so.6
> ?? () from /lib/tls/i686/cmov/libc.so.6
> Tags: ubuntu-unr lucid
> Title: hald-probe-input assert failure: *** glibc detected ***
> /usr/lib/hal/hald-probe-input: munmap_chunk(): invalid pointer: 0x080492f9
> ***
> Uname: Linux 2.6.32-9-generic i686
> UserGroups:
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/hal/+bug/500723/+subscribe
>

Changed in hal (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.