Ubuntu

does not pass xkb* settings to xorg server

Reported by Wladimir Mutel on 2009-05-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
High
Martin Pitt
Karmic
High
Martin Pitt
xorg (Ubuntu)
High
Timo Aaltonen
Karmic
High
Timo Aaltonen

Bug Description

Binary package hint: hal

I have certain xkb configuration options in my /etc/default/console-setup . Most important of them for me are :

XKBLAYOUT="us,ru,ua"
XKBOPTIONS="grp:caps_toggle,grp_led:scroll"

I am testing Karmic packages on top of my Jaunty installation.

After upgrade of hal to 0.5.12~rc1+git20090510-0ubuntu2 , I noticed that my keyboard layouts and options are not configured into xorg server anymore. In Xorg.0.log I see xkb_layout configured as only "us". I can not use "ru" and "ua" layouts, and switch them by CapsLock.

Reverting to hal 0.5.12~rc1+git20090403-0ubuntu1 (from Jaunty) helped me to restore former proper behaviour (xkb layouts and options are taken from /etc/default/console-setup, shown in Xorg.0.log and act as they did before and as I liked).

Don't know for sure if this behaviour occured in git20090406.46dc48 versions of hal, as I did not restart my xorg server at these times.

Hope this bug will not be allowed into Karmic release.

My hal-related packages now are looking as follows :

ii hal 0.5.12~rc1+git20090403-0ubuntu1 Hardware Abstraction Layer
ii hal-info 20090407-0ubuntu2 Hardware Abstraction Layer - fdi files
ii libhal-storage1 0.5.12~rc1+git20090510-0ubuntu2 Hardware Abstraction Layer - shared library
ii libhal1 0.5.12~rc1+git20090510-0ubuntu2 Hardware Abstraction Layer - shared library

Wit Wilinski (wit-wilinski) wrote :

Same here with polish (programmer's) layout. xkbmodel = evdev, xkblayout = pl. Xorg sets keyboard to us

Max Bowsher (maxb) wrote :

Confirming

Changed in hal (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2009-05-13
Changed in hal (Ubuntu Karmic):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
milestone: none → karmic-alpha-1
Max Bowsher (maxb) wrote :

Attaching Xorg.0.log.old, broken situation running hal 0.5.12~rc1+git20090510-0ubuntu2

Max Bowsher (maxb) wrote :

Attaching Xorg.0.log, working situation running hal 0.5.12~rc1+git20090510-0ubuntu1

Martin Pitt (pitti) wrote :

Can you please install this into /usr/share/hal/fdi/policy/10osvendor/ and check if it works again?

Martin Pitt (pitti) wrote :

Oh, after installing the fdi you need to restart hal and your session (might be easiest to just reboot)

Martin Pitt (pitti) wrote :

(Debugged in IRC) Installing that as 10-keymap.fdi worked. This was just a first test, however, so please delete that file from your system again.

Now please replace /usr/share/hal/fdi/policy/10osvendor/10-x11-keymap.fdi with the attached variant.

Martin Pitt (pitti) wrote :

That was confirmed to work.

Changed in hal (Ubuntu Karmic):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal - 0.5.12+git20090512-0ubuntu1

---------------
hal (0.5.12+git20090512-0ubuntu1) karmic; urgency=low

  * Final hal 0.5.12 release (no actual changes since our previous git
    snapshot), plus some extra commits from git head to drop some of our
    patches:
    - 02_smart_card_readers_acl.patch
    - 11-direct-hal-set-propery.patch
    - 23_addon_acpi.patch
  * 04_nvidia_brightness.patch: Update for new autoconfiscation.
  * debian/10-x11-keymap.fdi: Do not check for existing input.xkb.layout
    property; this was only set by the previous 10-keymap.fdi, which got
    disabled together with hal-setup-keymap. Directly check for input.keys
    capabilities, to make the fdi independent. This restores proper X.org
    keyboard layout setting from console-setup. (LP: #375618)

 -- Martin Pitt <email address hidden> Wed, 13 May 2009 09:53:30 +0200

Changed in hal (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-06-30
Changed in xorg (Ubuntu Karmic):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: New → In Progress
Max Bowsher (maxb) wrote :

Bug reintroduced by fdi file being moved from hal to xorg, but the version introduced in xorg is an old version still affected by this bug.

Martin Pitt (pitti) wrote :

You can grab the previously working hal FDI from http://bazaar.launchpad.net/~ubuntu-core-dev/hal/ubuntu/revision/336

Changed in xorg (Ubuntu Karmic):
assignee: Martin Pitt (pitti) → Timo Aaltonen (tjaalton)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg - 1:7.4+3ubuntu4

---------------
xorg (1:7.4+3ubuntu4) karmic; urgency=low

  * debian/local/debian-x11-keymap.fdi: Do not check for existing
    input.xkb.layout property; this was only set by the previous
    10-keymap.fdi, which got disabled together with hal-setup-keymap.
    Directly check for input.keys capabilities, to make the fdi
    independent. This restores proper X.org keyboard layout setting
    from console-setup. (LP: #375618, again)

 -- Timo Aaltonen <email address hidden> Wed, 01 Jul 2009 00:19:16 +0300

Changed in xorg (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers