[regression] hald ignores changes to files in /usr/share/hal/fdi and /etc/hal/fdi

Bug #304793 reported by z3non on 2008-12-03
2
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: hal

since one of the last upgrades, the hald isn't configurable anymore.

It ignores changes to or new files in /usr/share/hal/fdi and /etc/hal/fdi

I tried to comment out the
 <!-- merge key="info.ignore" type="bool">true</merge --> in /usr/share/hal/fdi/preprobe/10osvendor/20-broken-usb-sticks.fdi
for my Huawei USB-modem as I want to access the microSD card (which did work fine with earlier versions ..). lshal reports it as ignored even after restarting hal or the whole system. Also creating a file to /etc/hal/fdi/preprobe or adding

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
     <!-- Ignore the Huawei E220/E180 CD emulation -->
     <match key="@storage.originating_device:usb.vendor_id" int="0x12d1">
       <match key="@storage.originating_device:usb.product_id" int="0x1003">
         <merge key="storage.automount_enabled_hint" type="bool">false</merge>
         <match key="storage.drive_type" string="cdrom">
           <merge key="info.ignore" type="bool">true</merge>
         </match>
       </match>
     </match>
   </match>
  </device>
</deviceinfo>

to /etc/hal/fdi/policy/preferences.fdi doesn't show any effect. So I tried to probe hal in a more general way with the following test file (test.fdi):

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
  <device>
    <match key="block.is_volume" bool="true">
      <merge key="volume.ignore" type="bool">true</merge>
    </match>
  </device>
</deviceinfo>

which is ignored in /etc/hal/policy and /usr/share/hal/fdi/policy/20thirdparty/ , usb volumes still show up ...

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: hal 0.5.11-4ubuntu4 [modified: usr/bin/lshal usr/bin/hal-get-property usr/bin/hal-set-property usr/bin/hal-find-by-capability usr/bin/hal-find-by-property usr/bin/hal-device usr/bin/hal-is-caller-locked-out usr/bin/hal-lock usr/bin/hal-disable-polling usr/bin/hal-is-caller-privileged usr/bin/hal-setup-keymap usr/sbin/hald usr/sbin/umount.hal usr/lib/hal/hald-probe-input usr/lib/hal/hald-probe-hiddev usr/lib/hal/hald-probe-storage usr/lib/hal/hald-probe-volume usr/lib/hal/hald-probe-printer usr/lib/hal/hald-probe-pc-floppy usr/lib/hal/hald-probe-smbios usr/lib/hal/hald-probe-serial usr/lib/hal/hald-probe-ieee1394-unit usr/lib/hal/hald-probe-net-bluetooth usr/lib/hal/hald-probe-video4linux usr/lib/hal/hald-addon-hid-ups usr/lib/hal/hald-addon-input usr/lib/hal/hald-addon-storage usr/lib/hal/hald-addon-pmu usr/lib/hal/hald-addon-acpi usr/lib/hal/hald-addon-imac-backlight usr/lib/hal/hald-addon-macbookpro-backlight usr/lib/hal/hald-addon-macbook-backlight usr/lib/hal/hald-addon-cpufreq usr/lib/hal/hald-addon-usb-csr usr/lib/hal/hald-addon-dell-backlight usr/lib/hal/hald-generate-fdi-cache usr/lib/hal/hald-runner usr/lib/hal/hal-ipw-killswitch-linux usr/lib/hal/hal-storage-mount usr/lib/hal/hal-storage-unmount usr/lib/hal/hal-storage-eject usr/lib/hal/hal-storage-closetray usr/lib/hal/hal-storage-cleanup-mountpoint usr/lib/hal/hal-storage-cleanup-all-mountpoints usr/lib/hal/hal-system-setserial usr/lib/hal/hal-system-power-pm-is-supported usr/lib/hal/hal-system-power-pmu usr/lib/hal/hal-system-sonypic usr/lib/hal/hal-acl-tool]
ProcEnviron:
 LANGUAGE=de
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: hal
Uname: Linux 2.6.27-10-generic i686

z3non (tom-uttenthaler) wrote :
z3non (tom-uttenthaler) wrote :

The root of the problem was a future timestamp of the fdi-cache:

-rw-r--r-- 1 root root 1039604 2024-07-20 02:45 fdi-cache

after deleting it, everything works fine again. The future time probably came from a PM_TRACE, which I have activated, since the S2Mem is f*ing instable since intrepid ... nevertheless, I regard this behavior as a bug in hal. It is or has been discussed there for Debian and Ubuntu, so there should:

http://<email address hidden>/msg572726.html
http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/83d30ea7b629e4a4

and here you find a patch (which is secure, as it deletes the fdi-cache on every hal-start, but increases boot-time):

http://groups.google.com/group/linux.debian.bugs.dist/attach/b524a9234fe6547d/hal.fdi-cache.debdiff?part=3

regards,
tom

z3non (tom-uttenthaler) on 2008-12-03
Changed in hal:
assignee: nobody → pitti
Martin Pitt (pitti) on 2008-12-04
Changed in hal:
importance: Undecided → High
status: New → In Progress
Martin Pitt (pitti) wrote :

This was fixed in intrepid in version 0.5.11-4ubuntu1.

Changed in hal:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers