Activity log for bug #275825

Date Who What changed Old value New value Message
2008-09-29 12:47:30 Jonathan Riddell bug added bug
2008-09-29 12:48:23 Jonathan Riddell bug added attachment 'Xorg.0.log' (log)
2008-09-30 20:45:43 Bryce Harrington xorg: status New Confirmed
2008-09-30 20:45:43 Bryce Harrington xorg: title Bug #275825 in xorg (Ubuntu): "X does not detect a keyboard after upgrade" Bug #275825 in hal (Ubuntu): "X does not detect a keyboard after upgrade"
2008-09-30 20:45:43 Bryce Harrington xorg: importance Undecided High
2008-09-30 20:45:43 Bryce Harrington xorg: bugtargetname xorg (Ubuntu) hal (Ubuntu)
2008-09-30 20:45:43 Bryce Harrington xorg: statusexplanation From IRC it sounds like this is a hal caching issue: <ion_> pitti: I was told to bug you about this. After an upgrade from a fresh hardy installation to intrepid, HAL had old information in /var/cache/hald/fdi-cache. It only stat()d most of the FDI files without opening them, and never took /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi into account, which caused X not to find any input devices. I renamed the cache file away and everything works now.
2008-09-30 20:45:43 Bryce Harrington xorg: bugtargetdisplayname xorg (Ubuntu) hal (Ubuntu)
2008-09-30 20:45:43 Bryce Harrington xorg: milestone ubuntu-8.10-beta
2008-10-01 13:23:50 Johan Kiviniemi description Binary package hint: xorg After an upgrade from hardy to intrepid X has stopped responding to the keyboard. Alt-F1 (no Control key) changes to the linux console. The log says "Cannot locate a core keyboard device. The server relies on HAL to provide the list of input devices." But hald is running. After and upgrade from a fresh hardy installation to intrepid, there are changes under /usr/share/hal/fdi/policy, but hald seems to prefer the old information in /var/cache/hald/fdi-cache: it only seems to stat() most of the FDI files without ever reading them. This causes X not to find any input devices, since they are missing input.x11_driver, which would have been set by /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi. Deleting /var/cache/hald/fdi-cache makes X work again.
2008-10-01 13:23:50 Johan Kiviniemi title X does not detect a keyboard after upgrade After an upgrade to intrepid, HAL prefers old fdi-cache to new FDI files
2008-10-01 13:24:29 Johan Kiviniemi hal: assignee pitti
2008-10-01 13:24:29 Johan Kiviniemi hal: statusexplanation From IRC it sounds like this is a hal caching issue: <ion_> pitti: I was told to bug you about this. After an upgrade from a fresh hardy installation to intrepid, HAL had old information in /var/cache/hald/fdi-cache. It only stat()d most of the FDI files without opening them, and never took /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi into account, which caused X not to find any input devices. I renamed the cache file away and everything works now.
2008-10-02 09:46:27 Martin Pitt hal: statusexplanation
2008-10-02 09:46:27 Martin Pitt hal: milestone ubuntu-8.10-beta ubuntu-8.10
2008-10-02 14:11:51 Martin Pitt hal: status Confirmed In Progress
2008-10-02 14:51:30 Martin Pitt hal: status In Progress Fix Committed
2008-10-02 14:51:30 Martin Pitt hal: statusexplanation http://bazaar.launchpad.net/~ubuntu-core-dev/hal/ubuntu/revision/262
2008-10-02 15:15:56 Martin Pitt bug assigned to hal (Debian)
2008-10-03 02:23:46 Launchpad Janitor hal: status Fix Committed Fix Released
2008-10-03 14:33:52 Bug Watch Updater hal: status Unknown New
2008-10-07 07:03:59 Bug Watch Updater hal: status New Fix Released
2010-02-21 06:53:27 Launchpad Janitor branch linked lp:ubuntu/hal