[Hardy] Message: "Suspend Problem. Your computer failed to suspend"

Bug #199088 reported by Liken Otsoa on 2008-03-06
58
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

It suspends to RAM, but when you resume after several hours it shows always this message in a window: "Suspend Problem. Your computer failed to suspend"

IBM Thinkpad X41 Tablet

Liken Otsoa (liken) wrote :

I got this message too (hp compaq 8510p), but suspend worked w/o problem.

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem.Thanks in advance.

Changed in gnome-power-manager:
status: New → Incomplete
Liken Otsoa (liken) wrote :

I suspend my Znote6214w and it seams to go to sleep. But wnen I wake it up I get the same message. I checked the syslog and saw something I find strange, the second thing it does after me waking it up is to "Preparing system for mem sleep".

I'm running a clean install ubuntu-8.04-beta-desktop-i386.iso with Compiz dissabled on a Znote 6214W (2GHz Intel Core2 Duo T7200, 2048MB RAM, nVidia GeForce Go 7600) since the 20th Mars.

If you need more logfiles etc just tell me which and where I find them and I will post them.

aflores (arflobow) wrote :

I got the same error. I've attached the output of gnome-power-bugreport.sh &> gpm.log

Mine is also a clean install of hardy beta, ati restricted driver installed, compiz enabled. My laptop resumed from suspend just fine, but the cpu was at 100% for a few minutes. I only saw this behavior (cpu pegged at 100% for a few minutes) once, other times it resumed just fine without cpu pegged at 100% and without the error message.

Never got this message again, is this bug fixed now in Hardy?

Liken Otsoa (liken) wrote :

No, it's not for me. I get it everyday at morning when I resume my laptop from suspend last night.

-------------
IBM Thinkpad X41 Tablet
Hardy Uptodate

Jerome Lacoste (jerome-lacoste) wrote :

I have the same problem after *hibernation* on a Lenovo 3000 N100. Not sure about suspend.

This didn't happen in the past (in March 2008 or before).

louis (l-jean-richard) wrote :

Same problem with a desktop based on a foxconn motherboard.

Same problem here on a Dell Inspiron 6400/E1505 running Hardy Beta with all updates. Suspends just fine but when resuming I get a beep-beep-beep sound and then after logging in I get this message.

DaveAbrahams (boostpro) wrote :

Why is this bug still marked "incomplete?" It's been confirmed in Hardy by several people (me, too) and all the requested logs have been attached, several times over.

Just changing the status...

Changed in hal:
status: Incomplete → Confirmed
Ivan Noris (deja-vix) wrote :

Hi,

this has just happened to me for the first time. Since Thursday, I used to suspend my Thinkpad R60e at least once a day. Yesterday I suspended it too, everything worked, but now after I have switched it on, gnome-power-manager gave me that error.

Everything seems to be working just as before, just the message is new to me.

Ubuntu Hardy 8.04, Thinkpad R60e, using suspend to memory launched via Fn+F4.

Samant Maharaj (samboneym) wrote :

I can confirm that this also happens on a Dell Optiplex 755. Suspend to ram appears to work fine, however I receive this message on resume. I haven't seen any abnormal CPU usage.

Okko7 (okko7) wrote :

Confirmed here too. Installed Hardy Heron final release last weekend on a T61 Thinkpad.

Tom Bamford (tombamford) wrote :

I'm getting the same message with a ThinkPad X31 running Hardy. The machine is also beeping loudly several times in succession just after coming back from suspend but before X is displayed.

toopi (toopi) wrote :

I confirm this as well. This problem appeared after several suspend/resume processes.

danomatika (danomatika) wrote :

Same here with a Thinkpad T40. Suspend/resume works fine except for this error message and beeping.

Same here with a HP2710p, it works but gives the message and beeps briefly but loudly when resuming. It was silent both message-wise and soundcard-wise earlier in the betas, though I'm not sure exactly when it started misbehaving.

Bart Rose (jbrose3) wrote :

I too have been getting the loud beep and "Suspend Problem" error since a clean install of Hardy Beta on my Thinkpad R52. I'm running the fglrx driver, no compiz, laptop_mode enabled, and on AC power. The suspend/resume seems to work fine and this only happens after being suspend for greater than 4-5 hours. I've attached my gpm.log.

cgarre (cgarre) wrote :

I too have the same problem.

1. Loud beep when i open my laptop. (I use suspend on closing the lid option).
2. The laptop comes to life very fast but usually early morning i get the message "Suspend problem ... ", but no further issues.
3. Suspend also works fine later .. but usually its early morning i get that.

Good call on the long sleep time, I have to verify but I think it may be the same for me - I wondered a bit what it could be that triggered it sometimes and sometimes not, and I think the most common case is when I've left it overnight, but also other cases when I've been away for a longer while.

cgarre (cgarre) wrote :

More so, the sound (beep) is usually since if i have kept my volume at some level, and if volume is at higher level the beep is more loud. It sounds like my fire alarm. I have been waking up my wife early morning due to that sound (she looks scared and asks me if something is on fire .. i have to reassure that its my laptop) .. So now i remember to keep my sound muted.

But funny fact is that suspend seems to have worked, since i dont find my laptop hot nor do i hear any fan from the laptop or see the power led on. So suspend has actually worked but message says something is wrong .. so if its just a message problem, i dont thing i would worry about it a lot :)

Bernhard Gehl (bernhard-gehl) wrote :

I can also confirm the "long sleep time" factor. As soon as my laptop (hardy, fglrx from restricted modules) sleeps for more than a few hours, the error message comes up - plus I cannot shut down from gpm anymore.

Bernhard Gehl (bernhard-gehl) wrote :

Additional observation: Last night, I sent my laptop to hibernate and accidentally switched to console output. For some time, nothing happened (the system looked quite crashed) but then, a few messages popped up on my screen which I was able to quickly grab with (*cough*) my cellphone. Anyways, this is what the system reported before hibernating properly (there could be errors, since my cellphone-camera is quite crappy and I had difficulty reading the text from the image. :

MMC: killing requests for dead queue
**** backup - CPU0 stuck for 11s! [pm-hibernate:15678]
[fglrx_enable_pat] *ERROR* Pat entry 2 is already configured

On resume this morning, there was a beep sound (as mentioned above) but the system came up flawless.

Ivan Noris (deja-vix) wrote :

Confirming the "long sleep time" factor too. If I suspend my notebook for the night, I always get the error message, but everything works. If I suspend my notebook only for a couple of minutes (or an hour or so) when travelling between my office and home, no message, no problem.

On resume, this is in syslog:

May 22 09:19:34 bruce gnome-power-manager: (vix) Resuming computer
May 22 09:19:34 bruce kernel: [ 0.454994] PCI: Setting latency timer of device 0000:00:1b.0 to 64
May 22 09:19:34 bruce kernel: [ 0.542924] PM: Writing back config space on device 0000:00:1c.0 at offset 1 (was 100107, writing 100507)
May 22 09:19:34 bruce kernel: [ 0.542984] PCI: Setting latency timer of device 0000:00:1c.0 to 64
May 22 09:19:34 bruce kernel: [ 0.543019] PM: Writing back config space on device 0000:00:1c.1 at offset 7 (was 3020, writing 20003020)
May 22 09:19:34 bruce kernel: [ 0.543032] PM: Writing back config space on device 0000:00:1c.1 at offset 1 (was 100107, writing 100507)
May 22 09:19:34 bruce gnome-power-manager: (vix) suspend failed

IBM/Lenovo Thinkpad R60e
Ubuntu Hardy

Same here with a HP Compaq 6720s only with "long time factor". I have [URL="http://ubuntuforums.org/showpost.php?p=5058358&postcount=37"]laptop harddrive Load_Cycle_Count issue fix[/URL] applyed, but after such and only such wakeup PM_POWERSAVE settings are lost and hdparm Advanced power manager level becomes 128. Then I need set this manually every time.

Mark Hicks (mhicks) wrote :

My experience on a T42p is slightly different:

(1) This does not happen if all applications are closed when the system suspends. This is very consistent. I've tested the past few days with apps running and apps not running. I must quit all apps, even those running in the background like Pidgen, in order to get a normal resume the next day.

(2) The next day I will get the "[fglrx_enable_pat] *ERROR* Pat entry 2 is already configured" message", the system will appear to hang with a blank screen except for a "-" in upper left corner and then it will shut down. I restart the system (it's then doing a cold boot), it loads okay, and upon restart all the apps that were running from the previous night are loaded and running.

But now suspend awake every time using switched off hdparm settings. Restart on place suspend is always needed.

Bart Rose (jbrose3) wrote :

I switched back to the open source radeon driver and continue to have the same suspend problem. I did notice that when I logged out and suspended using the gdm login option, I did not get the usual beep and message this morning. Although I don't know a lot about the structure of the suspend process, this suggests to me that the issue is not within acpi support or the basic suspend process, but with something loaded at login that is conflicting with the process. I wonder, does everyone resume to the password protected screen?

darthsabbath (pwmoore57) wrote :

Just wanted to throw a little something I discovered about this issue. I've been getting the beeping noise on resume, so I unchecked the box labeled "Use sound to notify in event of error" in System->Preferences->Power Management->General. This has taken care of the beeping (so far). I don't know if any of the devs will find this useful, but those of you experiencing this problem might save your eardrums by giving this a try.

Tom Bamford (tombamford) wrote :

The beeping I mentioned could not have been a notification sound, it is more like the sound made when undocking without first pressing the dock's eject button. It's also very loud regardless of my volume setting (which is a hardware volume control). I'm having the issue regardless of sleep time, whether I leave the laptop for a minute or a day. I can't reproduce it anymore unfortunately as due to this and other issues I've reinstalled Gutsy, however I could boot from a Hardy live CD [and install the updates to ramdisk] if there is any information I can gather that will help.

Gabriel Velo (gabriel-velo) wrote :

Same problem on a HP nx6125.
Sleep and resume work without problem but I always get this notification message.

same problem here sometimes suspends properly sometimes not.
when it doesnt suspend correctly it still uses up the battery like as
if it was on. I didnt have this problem with Gutsy only with Hardy
I get the same beeping noise which is very annoying
actually is there anyway to stop the system beep?

Shane,

I'm not a dev or even a Linux expert, so I don't know if this will
cause any future problems, but I at least got rid of the beeping by
unchecking the box labeled "Use sound to notify in event of error" in
System->Preferences->Power Management->General. Once I did this I no
longer got the beep on resume, although I have tried it in a few days
since I'm back in Windows due to school :-(

Hope this helps.

On Tue, Jun 10, 2008 at 7:58 PM, shane fagan <email address hidden> wrote:
> same problem here sometimes suspends properly sometimes not.
> when it doesnt suspend correctly it still uses up the battery like as
> if it was on. I didnt have this problem with Gutsy only with Hardy
> I get the same beeping noise which is very annoying
> actually is there anyway to stop the system beep?
>
> --
> [Hardy] Message: "Suspend Problem. Your computer failed to suspend"
> https://bugs.launchpad.net/bugs/199088
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Phillip Moore
Computer Science & Engineering
<email address hidden>
<email address hidden>

"Reality is that which, when you stop believing in it, doesn't go away."
- Philip K. Dick

Will try that it might stop one annoying problem

haelix (haelix) wrote :
Download full text (3.9 KiB)

Hi,

I used to suffer from a regression in hardy: I would often get a beep, lose (as in X server reset) my gnome session (without all gnome infrastructure programs being killed, quite interestingly)

I performed an upgrade (I'm usually upgrading every dozen days or so) on last sundayy. That seems to have improved vastly over the previous state of affairs. Fwiw, the packages likely relevant to the issue have been upgraded as follow:

initramfs-tools 0.85eubuntu36 -> 0.85eubuntu39.1
pciutils 1:2.2.4-1.1ubuntu3 -> 1:2.2.4-1.1ubuntu4
libgnome-desktop-2 1:2.22.2-0ubuntu2 -> 1:2.22.2-0ubuntu3
deskbar-applet 2.22.1-0ubuntu1 -> 2.22.2.1-0ubuntu1
pm-utils 0.99.2-3ubuntu9 -> 0.99.2-3ubuntu10
xserver-xorg-core 2:1.4.1~git20080131-1ubuntu9 -> 2:1.4.1~git20080131-1ubuntu9.2

Other most likely irrelevant changes:

xserver-xorg-video-cirrus 1:1.1.0-8 -> 1:1.1.0-8ubuntu1
xserver-xorg-video-intel 2:2.2.1-1ubuntu13 -> 2:2.2.1-1ubuntu13.4

 (I use nvidia binaries)

apache2 2.2.8-1ubuntu0.1 -> 2.2.8-1ubuntu0.2
apache2-mpm-prefork 2.2.8-1ubuntu0.1 -> 2.2.8-1ubuntu0.2
apache2-utils 2.2.8-1ubuntu0.1 -> 2.2.8-1ubuntu0.2
apache2.2-common 2.2.8-1ubuntu0.1 -> 2.2.8-1ubuntu0.2
cpp 4:4.2.3-1ubuntu5 -> 4:4.2.3-1ubuntu6
g++ 4:4.2.3-1ubuntu5 -> 4:4.2.3-1ubuntu6
gcc 4:4.2.3-1ubuntu5 -> 4:4.2.3-1ubuntu6) ...
gnome-about 1:2.22.2-0ubuntu2 -> 1:2.22.2-0ubuntu3
gnome-cards-data 1:2.22.1.1-0ubuntu3 -> 1:2.22.2.1-0ubuntu1
gnome-desktop-data 1:2.22.2-0ubuntu2 -> 1:2.22.2-0ubuntu3
gnome-games 1:2.22.1.1-0ubuntu3 -> 1:2.22.2.1-0ubuntu1
gnome-games-data 1:2.22.1.1-0ubuntu3 -> 1:2.22.2.1-0ubuntu1
libgksu2-0 2.0.5-1ubuntu5 -> 2.0.5-1ubuntu5.1
libldap-2.4-2 2.4.7-6ubuntu4.1 -> 2.4.7-6ubuntu4.2
libldap2-dev 2.4.7-6ubuntu4.1 -> 2.4.7-6ubuntu4.2
liblircclient0 0.8.3~pre1-0ubuntu7 -> 0.8.3~pre1-0ubuntu7.1
libnspr4-0d 4.7.1~beta2-0ubuntu1 -> 4.7.1+1.9-0ubuntu0.8.04.1
libnss3-1d 3.12.0~beta3-0ubuntu1 -> 3.12.0.2+1.9-0ubuntu0.8.04.1
libpam-smbpass 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
libparted1.7-1 1.7.1-5.1ubuntu9 -> 1.7.1-5.1ubuntu9.1
libsmbclient 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
libsmbclient-dev 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
parted 1.7.1-5.1ubuntu9 -> 1.7.1-5.1ubuntu9.1
python-launchpad-bugs 0.2.30 -> 0.2.30.1
samba 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
samba-common 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
smbclient 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
smbfs 3.0.28a-1ubuntu4 -> 3.0.28a-1ubuntu4.1
ufw 0.16.2 -> 0.16.2.1
yelp 2.22.1-0ubuntu2 -> 2.22.1-0ubuntu2.8.04.1

firefox 3.0~b5+nobinonly-0ubuntu3 -> 3.0~rc1+nobinonly-0ubuntu0.8.04.1
firefox-3.0 3.0~b5+nobinonly-0ubuntu3 -> 3.0~rc1+nobinonly-0ubuntu0.8.04.1
firefox-3.0-dom-inspector 3.0~...

Read more...

Jerry Fan (jerryjr-fan) wrote :

happens on ume too

Hi - I've experienced the same problem with my HP dv6000. BTW, anyone know how to cancel my decision to "don't show me this message again"? I'd like to keep seeing it so I can help debug this (if possible).

BTW, there's another, VERY similar bug - probably the same one:
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/195095

ALSO, on the subject of the AWFUL screeching sound you get when waking up the computer -- it's due to this little guy right here: /usr/share/gnome-power-manager/gpm-suspend-failure.wav

It's interesting that the other "warning" sounds there are barely noticable clicks, boops and bips, but this one will knock your teeth out -- and usually in the MORNING of all times. But hey, at least I'm awake now.

I guess darthsabbath told us how to disable sounds for failure situations, but I think a better solution might be to just replace that wav file with something a little more tame. Your choice.

I'll try and attach the appropriate log files...

Peter Kerekfy (kerekfyp) wrote :

To enable the notofocations again open gconf-editor and enable the key named "/apps/gnome-power-manager/notify/sleep_failed".

Tom Bamford (tombamford) wrote :

The wave file identified by Paul Vinson Brown is the one played on my machine when coming back from suspend. This is a poor choice of error tone, especially so as the volume on my Thinkpad X31 seems to be turned to maximum after a resume.

Oh, so it's a recorded sound... it sure sounds more like "somethings broken in my speakers". I think it is the same, but it seems it is played a bit faster (and therefore also at a higher pitch) when it indicates suspend failure.

This GNOME bug is about this sound: http://bugzilla.gnome.org/show_bug.cgi?id=406144 - quote Rickard Hughes: "It needs to be quite painful to listen to be able to be heard in a laptop bag."

The real bug is of course that suspend does work, but is giving error messages anyways.

BobSongs (bobspcrepair) wrote :

Obviously a lot of posts have been added. Hopefully mine will assist a bit too.

I've got a generic desktop build from 1,000 various parts. Here's my log from gnome-power-bugreport.sh.

Sam_ (and-sam) wrote :

Hi,
back to topic:
>>It suspends to RAM, but when you resume after several hours it shows always this message in a window: "Suspend Problem. Your computer failed to suspend"<<

I've pressed the button "hibernation", screen turns black without splash and showed a short message, something like hibernation could not be activated.
Then shutdown fast.
Start up the next day was fine, splash stops, screen isn't locked and desktop appears very fast, only beeps and the message mentioned in the topic appeared.
For the record: amd_64, compiz, open source driver radeon x300.
Attached sum of logs.

maris382 (maris382) wrote :

I'm also affected by the annoying sound thing.

For me it only occurs when multiple users are logged in and it seems to be the gpm instance of the inactive user that makes the noise.
This can be verified by disabled sound in System->Preferences->Power Management->General for the other user and suspending using the suspend key on my laptop.

Sometimes I don't hear any sound when suspending. Instead, after waking up the computer and after switching to the inactive user, the computer immediately suspends again (without me taking any action).

My conclusion: Probably some race condition when multiple users are logged in (and multiple gpm instances are running).

This seems to be fixed for me in Intrepid. I've been running it for a week and have not heard the sound yet, earlier it was almost every day.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.