gnome-power-manager fails to keep scaling_governer setting over suspend

Bug #198869 reported by Dan Alderman on 2008-03-05
24
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

When suspending I would expect the setting in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor to be saved somewhere.

Upon resume the scaling_governor is always set to performance, even if the setting in gconf says ondemand. Could this be a bug in HAL?

Linux nano 2.6.24-10-generic #1 SMP Fri Feb 22 18:26:06 UTC 2008 x86_64 GNU/Linux
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

gnome-power-manager:
  Installed: 2.21.92-0ubuntu2
  Candidate: 2.21.92-0ubuntu2
  Version table:acpid scripts

I can confirm this problem.

Linux ubuntu 2.6.24-11-generic #1 SMP Fri Feb 29 21:26:31 UTC 2008 x86_64 GNU/Linux
gnome-power-manager:2.21.92-0ubuntu2

If I switch between battery and ac, the governor is set to ondemand again.

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem.Thanks in advance.

Changed in gnome-power-manager:
status: New → Incomplete
Dan Alderman (danalderman) wrote :
Jeffrey Baker (jwbaker) wrote :

The reporter has provided the requested information, and I can confirm this bug. CPU scaling is always set to 100% on resume, regardless of the setting before sleep.

Changed in gnome-power-manager:
status: Incomplete → Confirmed
Ted Gould (ted) wrote :

This isn't GPM's responsibility. Pushing it down the stack.

Jeffrey Baker (jwbaker) wrote :

This shouldn't be hal's responsibility either, I reckon. The scaling governor should remain unchanged even if a desktop environment is not installed or is not running. Ubuntu-minimal does not require hal. This functionality should be provided by the lower level ACPI scripts that are responsible for suspending the machine.

I believe this bug has something to do with:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/183033
and with:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/64070

I already have this bug on Ubuntu Hardy with latest updates. My workaround is
#powernowd restart
fixes the bug

Chak Man Yeung (dasunst3r) wrote :

Confirmed on Dell Inspiron E1505 w/ C2D T5600. However, I could restore my previous setting by right-clicking on gnome-power-manager and clicking on Preferences.

aldebx (aldebx) wrote :

I confirm this bug on HP Pavilion Intel Based laptop.
This is a long going bug since I experienced as far as in Ubuntu Gutsy. Now using Hardy beta issue still occurs.

Switching back to OnDemand governor is, however, easy with the CPU Frequency applet after having run 'sudo dpkg-reconfigure gnome-applets' and having enabled the suid.

Victor Osadci (victor-os) wrote :

This has started working for me recently - after resuming from sleep, the governor is "ondemand".

Can anyone confirm ?

aldebx (aldebx) wrote :

I can confirm this.
In some in these last 4 days update (my last post was of 25th) this issue has been somehow fixed for me too.
Now I can resume having the same ONDEMAND governor as when I put my computer in standby.

Thank you devs!!

aldebx (aldebx) wrote :

This bug was fixed in the package pm-utils - 0.99.2-3ubuntu5

---------------
pm-utils (0.99.2-3ubuntu5) hardy; urgency=low

  * Fix typo in 95-fix-config-file-parsing.patch which made loading
    configs from /etc/pm/config.d/* break. LP: #190679
  * Add 35-skip-linked-cpus-cpufreq.patch which skips all CPUs whose speed
    is shared with other CPUs (or cores) when saving state. LP: #162652.

aldebx (aldebx) on 2008-04-13
Changed in hal:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments