Ubuntu

[hardy] "Del"-key doesn't work on Acer Extensa laptops

Reported by apito on 2008-01-07
22
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
hotkey-setup (Ubuntu)
Undecided
Unassigned

Bug Description

On Acer extensa 5220 with Ubuntu 8.04 and kubuntu also, Delete key dosn't work. There isn't any reaction when I type it.
I tested it in live cd version and also after upgrade from gutsy. I used severela keypad configurations but Del key steel doesn't work.

zombiepig (nyall-zombiepigs) wrote :

I can confirm this behaviour also happens on my acer extensa 5620, using ubuntu 8.04. Versions of ubuntu prior to 8.04 all worked fine.

Some more details -

The problem seems to be irrespective of desktop environment - if I switch using ctrl-alt-f1 to a terminal screen, the delete key still doesn't work. However, running 'xev', and pressing the delete key results in:

KeyPress event, serial 30, synthetic NO, window 0x3000001,
    root 0x68, subw 0x0, time 7525668, (507,296), root:(511,345),
    state 0x0, keycode 242 (keysym 0x1008ff4b, XF86LaunchB), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x3000001,
    root 0x68, subw 0x0, time 7525668, (507,296), root:(511,345),
    state 0x0, keycode 242 (keysym 0x1008ff4b, XF86LaunchB), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

So it seems like the key is registering somehow, but not behaving correctly!

I also tried a "sudo dpkg-reconfigure xserver-xorg", but no change in behaviour.

zombiepig (nyall-zombiepigs) wrote :

For comparison sake, when I run xev on 7.10 (delete key works fine), the output is:

KeyPress event, serial 30, synthetic NO, window 0x3400001,
    root 0x67, subw 0x0, time 3103246438, (169,-8), root:(173,41),
    state 0x0, keycode 107 (keysym 0xffff, Delete), same_screen YES,
    XLookupString gives 1 bytes: (7f) ""
    XmbLookupString gives 1 bytes: (7f) ""
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x3400001,
    root 0x67, subw 0x0, time 3103246553, (169,-8), root:(173,41),
    state 0x0, keycode 107 (keysym 0xffff, Delete), same_screen YES,
    XLookupString gives 1 bytes: (7f) ""
    XFilterEvent returns: False

So it looks like the keycode has changed from 107 in gutsy, to 242 in hardy, and no longer registers correctly as delete.

apito (adamczuk-piotr) wrote :

This is my output from 7.10
KeyPress event, serial 30, synthetic NO, window 0x4200001,
    root 0x67, subw 0x0, time 3147046904, (394,271), root:(400,318),
    state 0x0, keycode 107 (keysym 0xffff, Delete), same_screen YES,
    XLookupString gives 1 bytes: (7f) ""
    XmbLookupString gives 1 bytes: (7f) ""
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4200001,
    root 0x67, subw 0x0, time 3147046977, (394,271), root:(400,318),
    state 0x0, keycode 107 (keysym 0xffff, Delete), same_screen YES,
    XLookupString gives 1 bytes: (7f) ""
    XFilterEvent returns: False

VisibilityNotify event, serial 30, synthetic NO, window 0x4200001,
    state VisibilityFullyObscured

FocusOut event, serial 30, synthetic NO, window 0x4200001,
    mode NotifyNormal, detail NotifyNonlinear

I think, problem is in desktop environment. When I installed Debian-lenny witouth xserver Del - key work normally, byt after install gnome or kde it didn't work

zombiepig (nyall-zombiepigs) wrote :

Here's some more troubleshooting information:

Under Gutsy, with a working delete key:
running showkey -s and pressing delete results in:
0x9c
0xe0 0x53
0xe0 0xd3

Under hardy,
0x9c
0xe0 0x72
0xe0 0xf2

Running showkey -k and pressing delete
Under Gutsy:
0x9c
0x6f
0xef

Under Hardy:
0x9c
0x00 0x81 0xed
0x80 0x81 0xed

Running showkey -m
=Under Gutsy:
keycode 27 press
keycode 91 press
keycode 51 press
keycode 126 press

Under Hardy:
keycode 0 press

description: updated
Pizuz (florian-fahr) wrote :

I can confirm this on a German Medion MD 42200 keyboard. Pressing the key alone doesn't produce any reaction, however, combinations like Ctrl-Alt-Del or Ctrl-Del (the latter is used to delete all letters after the cursor) do work well.

zombiepig (nyall-zombiepigs) wrote :
zombiepig (nyall-zombiepigs) wrote :
zombiepig (nyall-zombiepigs) wrote :
apito (adamczuk-piotr) wrote :

I tested Del - key on my laptop using Debian Lenny and Sid distributions. Del-key works fine without instaled graphical environmen (gnome, xfce, kde). After instaling one of them it didn't work. I haven't tested yet if it will work after installing only x-server package.

zombiepig (nyall-zombiepigs) wrote :

Looks like the same bug might affect mandriva - although the bug report is very light on information:
http://qa.mandriva.com/show_bug.cgi?id=37570

apito (adamczuk-piotr) wrote :

I tested "Del" on Debian Lenny. After I installed xfce it didn't work. With xserver installed Del-key works normaly.
When I purge all xfce packages Del didn't work but after restart it start working.
In my opinion the bug is in one of graphical environment packages.
Could anyone check ubuntu hardy without graphical environment?

zombiepig (nyall-zombiepigs) wrote :

From the mandriva bug page, a temporary workaround is to run

xmodmap -e "keycode 242 = Delete"

after login. This change could be made permanent by adding it to ~/.Xmodmap , but I'd rather get it fixed properly and working out of the box!!

Pizuz (florian-fahr) wrote :

Anyone experience same issues with the Return, RightArrow and Backspace keys? Because I do.

zombiepig (nyall-zombiepigs) wrote :

delete is the only key not working here - what model laptop do you have?

Pizuz (florian-fahr) wrote :

As I said, I use a Medion MD 42200. However, it seems like they share a lot with those Acer laptops. Another theory might be that my keyboard is dying. I'll check that against my Gutsy CD. As I said, the keys not working are LeftArrow, DownArrow, PgDown, Backspace, Delete and Return. However, Backspace and Return do work if pressed together with Shift while all the others work with Ctrl pressed.

By the way: This happens in GRUB already.

Pizuz (florian-fahr) wrote :

Uh, don't mind my comments... my keyboard IS dying.

Thomas Heidrich (gnuheidix) wrote :

I'm also using an Acer Extensa 5220 and I'm experiencing exactly the same problem as zombiepig does.
Besides, if i press delete, currently known as keycode 242, the wlan status indicator led toggles. That doesn't have any effect on the wlan module at all. I tested all available keys with xev and found out that the bluetooth key is also having keycode 242. That key shouldn't work at all because of the lack of a bluetooth module.
I also tested all generic and acer keyboard layouts. None of them revived my delete key. After studying man xmodmap I entered the "xmodmap -e "keycode 242 = Delete"" command which revives the key for the current session. Unfortunately the wlan status indicator led still toggles.

We might rename delete's keycode, but how to do that. I'm not having any further ideas for fixing that issue. Please fix that. :)

Thomas Heidrich (gnuheidix) wrote :

I forgot to say that I'm using Hardy. (up-to-date)
uname -a: Linux lap 2.6.24-12-generic #1 SMP Mon Mar 10 15:32:00 UTC 2008 i686 GNU/Linux

Dan Ballard (haplo) wrote :

Confirmed for another Acer Extensa 5620.

Peter (sqrt-gmx) wrote :

I have an Acer Extensa 5210 showing the same problem.

apito (adamczuk-piotr) wrote :

Hi!
My Del key works now :)
I did one think only on live-cd hardy: "sudo /etc/init.d/hotkey-setup restart". I don't know if "restart" is nesessery but after that my del work.
Please check yours laptops.
:) :)

Thomas Heidrich (gnuheidix) wrote :

That doesn't for my Extensa 5220.

zombiepig (nyall-zombiepigs) wrote :

Thanks apito! Running "sudo /etc/init.d/hotkey-setup restart" works for my extensa 5620, but only until a reboot. After rebooting the system goes back to the original behaviour.

Dan Ballard (haplo) wrote :

Huh... /etc/init.d/hotkey-setup restart has no effect on my extensa 5620.

Peter (sqrt-gmx) wrote :

This doesn't work for my Extensa 5210.

Sylwester Grzywna (gryziwons) wrote :

Hi!
I have the same problem on my Acer Extensa 5620Z, i.e. "Del" key doesn't work (well, it makes wlan's led on/off), until I execute "sudo /etc/init.d/hotkey-setup restart". Then it works correctly.

uname -a: Linux notebook 2.6.24-15-generic #1 SMP Fri Apr 4 03:10:59 UTC 2008 x86_64 GNU/Linux

Daniel Eckl (daniel-eckl) wrote :

Restarting hotkey-setup works for me as well with hardy on an Acer Extensa 5220.

Although this is really not usable in a senseful manner.

The Xmodmap workaround ist not that of a good workaround, because Shift-Del still remains non-functioning, as does Strg-Alt-Del. Just Del itself works now. WAY better, sure, but not the full picture....

Does anybody has a workaround until this is fixed? What is the best way to do this restart automatically perhaps after Xorg fires up? Or are there xmodmap commands for making shift-del and [everything-else]-del working?

zombiepig (nyall-zombiepigs) wrote :

Can we please get some dev attention to this bug? It's a very serious issue that's affecting a lot of users - I can only imagine the frustration this will cause if hardy is released with this issue still present!

If there's anything else us users can do to help track down this issue, please let us know!!

Daniel Eckl (daniel-eckl) wrote :

I found a usable workaround

I found a hal keymap for acer here:
http://ecarux.de/files/misc/30-keymap-acer.fdi
German blog entry for that is here:
http://ecarux.de/index.php?option=com_content&task=blogsection&id=12&Itemid=43 (scroll down rather far)
I installed it to /usr/share/hal/fdi/information/10freedesktop

Please note that this is just a workaround, because the package hal-info contains the same file with different contents. So if afterwards comes an update to package hal-info you have to reinstall the correct file.

Daniel Eckl (daniel-eckl) wrote :

For your convenience I attached the named fdi file so it's still there in case the original location get's lost some day

Peter (sqrt-gmx) wrote :

I changed 'contains="5220"' to 'contains_outof="5210;5220"'. Having done so the keymap works for my Extensa 5210. Thanks.

kni (kni) wrote :

I can confirm, the same problem on my Acer Extensa 5620Z

zombiepig (nyall-zombiepigs) wrote :

problem exists in the /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi file, definitely a hal problem!

zombiepig (nyall-zombiepigs) wrote :

Ok, i've tracked down the line which causes the problem, by manually applying each change from the working hal keymap file.
The problem is the line

"<append key="input.keymap.data" type="strlist">e053:bluetooth</append> <!-- Bluetooth (toggle) on-to-off -->"
on line 141 of /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi

Removing this line (and restarting) fixes the problem properly. Removing it doesn't affect the bluetooth functionality either, since it's the next line
"<append key="input.keymap.data" type="strlist">e054:bluetooth</append> <!-- Bluetooth (toggle) off-to-on -->"
which allows the bluetooth module to be switched toggled.

So it's perfectly safe to remove line 141, retain full functionality, and fix the delete key issue permanently! I'm going to try and find a way of getting this fix upstream, and hopefully a ubuntu dev can make the required change before hardy release....

(and thanks go to daniel eckl for finding the fix for this one!)

Daniel Eckl (daniel-eckl) wrote :

Wow, zombiepig really did the difficult part, whilst I did just google. Respect.
Attached is the unified diff for that change.

I did not have the time yet to confirm that this change fixes the bug, but I'm very confident in zombiepigs work.

What I can't say is, which implication this fix has. Does it break some bluetooth switch functionality for all acer laptops or such?

I can't tell bout that, because up to now I didn't get BT to work out of the box and did not have the pain to look into it, but I know that either WLAN nor BT switches do anything on software side yet. They don't produce any visible events, nor does the LEDs go on, they keep stying off. This might be a completely other bug, but who knows...

Best,
Daniel

zombiepig (nyall-zombiepigs) wrote :

It's now been fixed upstream - http://bugs.freedesktop.org/show_bug.cgi?id=15576

Last step is to get this fix into hardy somehow!

apito (adamczuk-piotr) wrote :

I'm very happy, that we now how it can be fixed. (It is work on my ex 5220)
I hope in oficial hardy realise delete key will work "out of the box" and also in other debian distriributions.
Thanks for all for this discussion.
---
Pitor Adamczuk
Kraków, Polska (Poland)
:)

daniel_perella (dani-perella) wrote :

In official Hardy release doesn't work. This worked fine for my Extensa 5620Z: xmodmap -e "keycode 242 = Delete"

Thanks!!

And also for my Extensa 5620Z: xmodmap -e "keycode 242 = Delete" :-) Thanks!

zombiepig (nyall-zombiepigs) wrote :

Just a warning - the xmodmap fix isn't complete. It won't let you use combinations like shift+del. (see https://bugs.launchpad.net/ubuntu/+bug/181057/comments/28 )
The real fix is to modify the /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi file, like in https://bugs.launchpad.net/ubuntu/+bug/181057/comments/35

>>>Siaržuk Piatroŭski wrote 7 hours ago

I'm agree with zombiepig!

apito (adamczuk-piotr) wrote :

I deleted this line and now my keyboard works fine, but in ex5220 isn't bluetooth module. Could anybody write if in acer laptops with blueatooth, delete this line also can be used? If yes, this line should be deleted permanently.

zombiepig (nyall-zombiepigs) wrote :

Yes - on my 5620 with bluetooth, it's fine to remove this line without affecting bluetooth functionality.

Russell John (russell.john) wrote :

Here's a fix:

1) Open the following file as root: /etc/X11/xkb/keycodes/xfree86
2) Find the line <DELE> = 107
3) Replace it with <DELE> = 242
4) Find the line <I72> = 242
5) Replace it with <I72> = 107
6) Save and reboot, delete key will now work.

Tested on Extensa 5620 running Hardy.

Daniel Eckl (daniel-eckl) wrote :

John, sorry, but this is no fix, that's a workaround and above that it's highly incomplete as far as I know. I expect the same drawbacks as with xmodmap.

Real fix is the corrected hal keymap, see above.

You might need to change the line
'contains="5220"' to 'contains_outof="5210;5220;5620"'
in /usr/share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi

Russell John (russell.john) wrote :

Thanks Daniel, I hope it'll work out of the box on the next release.

zombiepig (nyall-zombiepigs) wrote :

This should be fixed in hal-info (20080508+git20080601-0ubuntu0.8.04), which has been released to hardy-proposed.

Looking through the debdiff for the package, it includes:

+commit 6c3358c585e3fb90419e0052f24c2591b713c05d
+Author: Carlos Corbacho <email address hidden>
+Date: Mon Apr 21 23:26:59 2008 +0100
+
+ Remove bad key from Acer keymappings
+
+ Scancode e053 appears to map to the delete key. (This is my bad, as I
+ assumed that it would be the 'other' bluetooth scancode on this
+ laptop,
+ based on how other Acer models handle such buttons).
+
+ fdi/information/10freedesktop/30-keymap-acer.fdi | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)

Gunni (fgunni) wrote :

For me its fixed with the new hal-info package in hardy-proposed. Seems like bug status can be changed, if someone else can comfirm its fixed.

LeO (leo-welsch) wrote :

Adding the new patch did solve as well the problem. The Bug could be closed.

Gunni (fgunni) on 2008-07-06
Changed in hal:
status: Confirmed → Fix Released
Changed in hotkey-setup:
status: New → Fix Released
Iwan Smith (itsmith) wrote :

I'ts the same problem for me.
 I have (x)ubutnu(studio), and fixed it by adding <xmodmap -e "keycode 242 = Delete"> to the list of autostarted apps.
not perfect but it works :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.